open port in solaris for ftp

I am on windows machine, I am trying to ftp some files to a diff server

i am executing ftp command in cmd.
c:> ftp a.b.c.d
Connected to a.b.c.d
Connection closed by remote host.

how can I open the port?
ramavenkatesaAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Brian UtterbackConnect With a Mentor Principle Software EngineerCommented:
The message "Connection closed by remote host." means just that, the remote host closed the connection.  That indicates that the other host accepted the connection and then closed it. This sounds like the other host either is using something like TCP-wrappers to deny your system service, or the
FTP server is configured to deny you service, or there is a problem with the FTP server such that it is
exiting after the connection is made.

What kind of access do you have to the remoter server? Can you log on to try and diagnose the problem?
0
 
arnoldConnect With a Mentor Commented:
On the same path as Blu, to check whether the issue is with TCP wrapper, see whether your IP resolves to a hostname, but the same hostname does not resolve to the IP.

Depending on the configuration of the server, FTP access might also be limited to certain IPs, but your current IP is not one of those.
0
 
omarfaridCommented:
it could be a firewall denying your connection.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
Brian UtterbackPrinciple Software EngineerCommented:
So, we have offered a number of hypothesises. You need to get back to us if you want us to help you. A
application level denial rule (ala TCP wrappers or ftp.deny), a misconfiguration of the ftp server that causes it to exit, and a firewall. If you want help on fixing the problem, you need to respond. Otherwise, I hope
those guesses help you.
0
 
Mohan ShivaiahConnect With a Mentor Commented:
Check your in /etc/inetd.conf:
  ftp stream tcp nowait root /usr/etc/in.ftpd in.ftpd -l


Warning: it will log passwords of ordinary users. Also enable syslogd by adding:
   daemon.info      /var/adm/syslog

   to "/etc/syslog.conf".
0
 
ramavenkatesaAuthor Commented:
not that much satisfactory
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.