Solved

New Cisco 3845 Router setup / How do I get at the SDM??

Posted on 2009-04-06
16
1,013 Views
Last Modified: 2012-08-13
OK,

So i have a new Cisco 3845 Router that I need to setup.  I was able to login via the console, I made an account, level 15, and I changed the enable password.

I want to setup the router using the SDM that I read about on Cisco, the only thing is....I dont know how to access it.

I have 2 Fast Ethernet ports on the back of the router, in addition to the T3 card that it will be connecting to.

Is there a default IP address set to one of the interfaces?  How do I get at it?  I'm famillair how the ASA firewalls and they have a mgmt port so you can get at the asdm.  is there something similar for the 3845 router?

This is brand new out of box, and must be really easy, just haven't done it before and finding such basic info on Cisco's website is a pain.

Any help out there?
0
Comment
Question by:Vjz1
  • 8
  • 7
16 Comments
 
LVL 5

Accepted Solution

by:
andrewis earned 500 total points
ID: 24077468
you will need to assign an IP address to one of the interfaces as well as enabled the http server

conf t
interface fa0/0
ip address 192.168.0.1 255.255.255.0
no shut
exit
ip http server
exit
wr

then https://192.168.0.1



https://192.168.0.1


0
 

Author Comment

by:Vjz1
ID: 24078219
Ok so i did that successfully, but when i try to load the page, it does not load.

I can confirm that I can ping the interface that I setup, through your steps.

There must me be something else to get me going on this http interface.

any help?
0
 
LVL 5

Expert Comment

by:andrewis
ID: 24078265
I apologise try http://192.168.0.1
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:Vjz1
ID: 24078276
yes tried that as well, no go...
0
 
LVL 5

Expert Comment

by:andrewis
ID: 24078296
does it socket if you try and telnet to port 80 from a cmd prompt?

telnet 192.168.0.1 80    


0
 

Author Comment

by:Vjz1
ID: 24078301
nope, could not open connection on port 80
0
 
LVL 5

Expert Comment

by:andrewis
ID: 24078466
if you type "dir flash"  can you see any sdm.tar, home.tar, sdm.html or home.html?


0
 

Author Comment

by:Vjz1
ID: 24078938
here is what i get:

Directory of flash:/

    1  -rw-    34823076  Feb 11 2009 05:48:28 +00:00  c3845-spservicesk9-mz.124-
21a.bin
    2  -rw-        2751  Feb 11 2009 05:58:14 +00:00  sdmconfig-38xx.cfg
    3  -rw-      931840  Feb 11 2009 05:58:28 +00:00  es.tar
    4  -rw-     1505280  Feb 11 2009 05:58:44 +00:00  common.tar
    5  -rw-        1038  Feb 11 2009 05:58:56 +00:00  home.shtml
    6  -rw-      112640  Feb 11 2009 05:59:10 +00:00  home.tar
    7  -rw-     1697952  Feb 11 2009 05:59:28 +00:00  securedesktop-ios-3.1.1.45
-k9.pkg
    8  -rw-      415956  Feb 11 2009 05:59:44 +00:00  sslclient-win-1.1.4.176.pk
g
0
 
LVL 5

Expert Comment

by:andrewis
ID: 24078972
looks good..  could you post your config?
0
 

Author Comment

by:Vjz1
ID: 24079009
sure, see below, also this is brand new out of box, so there has been no default config changes other then setting up a user, and the changes you had me put in.


Current configuration : 4655 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
card type t3 1
logging buffered 51200 warnings
enable password ------ Edited by Modularity, EE Moderator ----------------
!
no aaa new-model
ip cef
!
!
!
!
ip domain name yourdomain.com
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-1725046325
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1725046325
 revocation-check none
 rsakeypair TP-self-signed-1725046325
!
!
crypto pki certificate chain TP-self-signed-1725046325
 certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31373235 30343633 3235301E 170D3039 30323131 30363436
  31315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 37323530
  34363332 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B3A0 704A99C0 BF92108C 773383B6 00FB944F 723AB1A8 FDD52E19 1E413774
  A77A59C7 4E37E331 D2C6D084 443FFAD6 25DCFCC7 FC9DF294 D3301AA9 D6E87FAD
  108663A4 66E7554E D0BBE951 F874F081 A596996E 57F91EAC 68382805 E45CD4AB
  2A604CEF 69D31DF9 DD9A88B4 C2F5310D DB92D6C5 59EB86C2 0D310F3B F9969A31
  E6FB0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 146E91ED B5ADBB2A 87A42E5A 2068D31E ABF4B4B6
  31301D06 03551D0E 04160414 6E91EDB5 ADBB2A87 A42E5A20 68D31EAB F4B4B631
  300D0609 2A864886 F70D0101 04050003 81810092 493AE37F 3E7FDF7E BD4129E5
  5BBA6F49 06EF3634 E47D3C49 B08F2F0E 43CB1DB0 EB598CBE 32C48C1B E3886632
  106F5844 D749B49F 68155457 E3118525 699B04F4 7DDCC246 3A30232F 149DA4D2
  109BD737 F5C4E536 05FFC619 935FF5D5 2452BD54 183881E7 1AD3AF8A 862CAB5A
  F52D97D8 B5AA79BB 118222E3 E76C030B 1D9181
  quit
username admin privilege 15 secret 5 PASSWORDHERE.
!
!
controller T3 1/0
!
!
!
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 10.250.10.253 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
interface Serial1/0
no ip address
 dsu bandwidth 44210
!
ip forward-protocol nd
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end
0
 
LVL 5

Expert Comment

by:andrewis
ID: 24079052
ok I see the problem.

There is an access class "ip http access-class 23" if you take this command out it should be good

conf t
no ip http access-class 23

with this access-class enabled you will only be able to connect to the router from this subnet 10.10.10.0 255.255.255.248

should do the trick ;)

0
 

Author Comment

by:Vjz1
ID: 24079196
ok that worked, i'm in thanks.

1 last thing.  i can't see my T3 card thats in serial slot 1, through this SDM GUI.

is there something I need to do to see it?

fyi, i can see eth0/0 on the LAN and eth0/1 as an available interface under wan, but thats it.
0
 
LVL 5

Expert Comment

by:andrewis
ID: 24079313
I don't have much experience configuring a T3 controller but I found this doc which may help you.

http://www.opennet.ru/soft/cisco-configuration.html#configuring-serial

VI. Configuring the CIP card and the virtual interfaces

Perhaps other experts can comment further..
0
 

Author Comment

by:Vjz1
ID: 24079359
can you please delete this question?  points awarded should definately stay, i would just like the question deleted for obvious reasons.

sorry about that guys, i'm usually better.

thanks
0
 

Author Comment

by:Vjz1
ID: 24086801
Can I please get this question deleted???????

PLEASE!!!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question