W32Time on Server 2008 Domain Controller Not Synchronizing

I can't seem to get our domain controller to synchronize to an outside time source. Our domain controller is server 2008 and is a virtual machine (HyperV). When I run w32tm /resync /nowait it says that it was successful, but the clock doesn't change to the correct time. Our time is off by about 10 minutes. I have verified that the issue is not with our firewall as I can connect and get time from an NTP server. All of our computers / servers have a setting in the group policy to sync to the domain controller(NT5DS). In our domain controller policy I have it set to NTP to windows time server. I've attached the results of w32tm /query /configuration. We have 2 domain controllers, both have time issues.

The last event viewer record for the time service shows this:

The time service is now synchronizing the system time with the time source time.windows.com,0x9 (ntp.m|0x9|0.0.0.0:123->207.46.232.182:123).

I was curious if VMICTimeProvider was synching it to the host servers clock, so I adjusted the host servers clock to the correct time, did a resync, and it changed the domain controllers clock to the correct time for about 2 seconds, then switched it back ahead 10 minutes.

Thanks for any help!
settings.txt
CorporateTrafficAsked:
Who is Participating?
 
a_ro_noTechnical Account ManagerCommented:
http://technet.microsoft.com/en-us/magazine/2008.10.hyperv.aspx

Integration Components

Hyper-V was built to provide strong boundaries between various instances running on one computer. To enable interaction between the guest OS and the host OS and to supply some additional functionality for supported guest OSs, Hyper-V provides Integration Components.
The Hyper-V Integration Components support the following features:
Time synchronization
Volume Shadow Copy Service (VSS)
Heartbeat functionality
Guest shutdown
Key value pair exchange (used to access the registry of a guest OS)
OS identification

I guess you are synchronizing with your parent OS
0
 
a_ro_noTechnical Account ManagerCommented:
oops sorry I didn't read the last part.
0
 
CorporateTrafficAuthor Commented:
Actually, I just turned off the time synchronization from the host and it appears to work now. Although, I still don't know where it was getting the time from (+10 minutes), since the host server had the correct time.
0
 
CorporateTrafficAuthor Commented:
It wasn't the exact answer, but it made me look in the integration settings and I think that fixed the problem. Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.