Solved

Corrupt images/websites on new 2008 server

Posted on 2009-04-06
33
618 Views
Last Modified: 2012-05-06
Hi Everyone,
I have a new HP Prolaint ML350 G5 running Windows server 2008 as a web server. Everything is fine when viewing web pages on the server itself (using IE going to the site, and opening the actual html file on the server) All the images show up and there is no corruption.

When accessing the websites (thru IIS) from a different computer (xp or server 2003) some of the images appear corrupt. If I were to map to the sites folder from my workstation, and open any of the html files directly from the servers hard drive, there is even more corruption of the images, and some of the html looks corrupt. This is a problem because we use Dreamweaver on our workstations and our sites won't open in DW when there are corrupted images.

I transferred the websites to the new web server by zipping all of the sites together, and used a usb hard drive to transfer the zip file from on server to the other. Once on the new server I unzipped the sites and set up user permissions and IIS site mappings.
To make sure the files didn't become corrupt when being zipped I also put them on my desktop computer and they all load fine.

I have installed the latest nic driver for the server with no luck, and last Friday formatted and reinstalled the OS, with no change.

To recap, everything looks and works fine on the 2008 server. When using a different computer to access the files on the server they appear to be corrupt.

Thanks for you help
0
Comment
Question by:nicolausj
  • 19
  • 11
  • 3
33 Comments
 
LVL 23

Expert Comment

by:ComputerTechie
ID: 24081411
Are you using anything like http compress.
I know this is 2003 but it might help.
http://www.keylimetie.com/Blog/2008/5/20/How-to-enable-HTTP-Compression-on-Windows-Server-2003/
CT
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24081448
Thats not the problem.... I have tried that. I does help the pages load faster but doesn't solve the the files appearing as corrupt from other computers. I don't suspect iis is the problem, but I'm not sure.
0
 
LVL 23

Expert Comment

by:ComputerTechie
ID: 24081972
try this.
You may be able to temporarily work around this problem by deleting the cached, compressed copy of the affected file or files on the IIS server. By default, the compressed file is located the following folder:
%windir%\IIS Temporary Compressed FilesThis temporary directory location can be changed in the IIS Manager on the Service tab in the Web Sites property sheet.

To delete the cached files on the server, follow these steps: Open the IIS Temporary Compressed Files folder.

The default path is %windows%\IIS Temporary Compressed Files. Delete all the files in this folder. At a command prompt, enter IISReset to restart all IIS services.

You may also have to delete the cached files on the client to make sure that the corrupted files from the cache are not used. To do so, follow these steps: In Internet Explorer, click Internet Options on the Tools menu . Click the General tab, and then click Delete Files. Click OK.

CT
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24088312
How is this going to solve the corruption when I try editing the sites? really IIS does a nice job when viewing the stie, just some of the pic's are corrupt. But again when on the 2008 server EVERYTHING looks good and is working. Only when I got to a differen't computer do you notice any corruption, not just in iis like I said but the actuall images on the server appear corrupt ad to the html files.
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24088441
I'll still give it a try since nothing else has worked.
0
 
LVL 26

Assisted Solution

by:lnkevin
lnkevin earned 250 total points
ID: 24091217
Take a screenshot of your broken image and post it.
When you browse to the web site, did you try to type the IP address of the server instead of server name? For example: http://192.X.X.X...
The main reason that your pictures woudn't show up properly because the path to picture folder is broken or inaccessible from the workstation. You can try to do this to see if it's better.
Open C:\WINDOWS\system32\drivers\etc on your workstation and open the file called hosts in notepad. Add another line as the following:
Yourserver IP address        servername

From your server, edit the same file as the following
Your server IP address      localhost

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24091813
Hi Inkevin,

Going to the IP address of the site internally is how I have been running test using IIS and most images load while some do not.

After putting the websites IP address in the Host file any corruption that may have appeard in IIS is gone. You get part of the points for that and thanks.

It still hasn't solved my biggest problem though and I will try to clerify as best I can:
When mapping to the server \\servername\website home folder, Then clicking on a html, or htm page it looks like there is corruption to the images and some of the html code itself. If i go into the images folder this way most of the images look corrupt.

Below are 2 screen captures of the same image, on using the sites ipaddress in IE, the other directly opening the htm file (IE as well) in the server folder from my workstation.

ScreenHunter-05-Mar.-11-16.59.gif
ScreenHunter-04-Mar.-11-16.58.gif
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24091862
wait, i missed the server bit at the end of your last post. I will try that and get back to you.
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24091929
Nope, changing the host file on the server didn't fix the problem.
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24096575
The first picture is using IIS to open the file via web browser and the second picture is using DNS server name and opening directly from computer file system browsing. Although the picture looked broken, but I could tell the path and DNS is working properly. Otherwise, you will receive some "red X" instead of broken picture.
The issue is not serious at all. It may just be a caching issue and could be resolved with a server and client reboot. Before reboot your systems, try to restart DNS services in your DNS server. Wait about ten seconds and  run ipconfig /flushdns at the command line in your client.
Overall, your DNS server is not working properly. That is the reason why it works perfectly on the IP address but breaks up on the DNS name. If you edit your home site by using ip address: \\yourIPaddress\homeSiteFolder\ the picture should come up fine.
One last thing I need to mention is watching for the name spaces. In web technology, there should be no spaces between a file or folder. For example, folderA instead of folder A.

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24097911
\\serverIPaddress\homeSiteFolder\ the pictures still appear to be corrupt. I have even tried \\SiteIPaddress\SiteFolder\index.htm and that doesn't work either.

A few years back we had a web server using the same IPaddress I'm using now. Is it possible if i change the servers ip it will work? I have setup seperate ip bindings on the network card for each or our websites.



0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24098936
Did you try to reboot the server?
Did you try all above suggestion?

It's good to try the other IP address, but you may have to make changes on the hosts again.

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24099076
I think our firewall is running the DNS for out DMZ. I'll have to wait for an appropriate time to try a reboot.

I will try it on Monday.
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24099773
Ohh! There is DMZ involved! You need to also make sure port 80 is open appropriately to all LAN in your firewall.

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24100399
....which is why when accessing the files on the server it looks corrupt... makes a bit more sence to me now... I think.

I have put in a call to our firewall guy. Hope he gets back to me soon.
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24131911
I tried everything above with no luck.
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 
LVL 3

Author Comment

by:nicolausj
ID: 24131926
IIS works..... accessing the files on the server from a different server or computer makes the html and image files apear corrupt and make it impossible to edit. DNS doesn't appear to be a problem since i can get to the server using its DNS name.
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24132439
Have the firewall guys open all connections to the desktop that you use to edit the page. Make sure your desktop has a static IP address when you access things through DMZ. Otherwise, all edit works need to be done on the server thru terminal service. You cannot browse to a DMZ without all rules are open to the target computer.

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24132594
Alright, below is another example.

The first image is using internet explorer and the server's internal ip address (default IIS webpage)
The second I went to the site folder on the server and double clicked the iisstart.htm. (from my pc) on the server this would work with no problem.

As you can see iis is fine. I can't figure out why the images are corrupt when launching them on the server from my computer.... I should also add that I'm logging in using Admin privileges.
ScreenHunter-01-Apr.-13-16.09.gif
ScreenHunter-02-Apr.-13-16.09.gif
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24132656
The iis is fine because all DMZ rules open to the IIS server. Your PC is not fine because DMZ is not totally open to your PC where you tried to open the files. Talk to the DMZ guys again and work on the rules to your PC. Make sure your PC has a static IP.

Working on the server befind DMZ is not easy and normal as regular network. You may not want to overlook any of my comments.

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24142956
He has that all set up..... I have tried computers withing the dmz (like our current webserver) and get the same results.

I'm using widows authenrtication on the new server..... its it because I'm not using iis authentication I can access the files on the server from any other computer/server?

Not ever having setup iis users ever... I'm not sure.

Thanks for sticking with me,
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24147903
I just looked at the pictures and found certain issue of your broken image. When you type the IP address on the browser by itself, you call IIS start up page (index, default page.... same things) and of course the link to the images are taking care by IIS. What if you remote desktop to the server then open the page by double click on the file there? Does the picture look OK? Or you can map or browse to the server with IP address instead of server name (\\192.x.x.xx\c$\inetpub\...) is the picture OK?

K
0
 
LVL 23

Expert Comment

by:ComputerTechie
ID: 24147940
just for giggles try uninstalling http compression. reboot and checking the site.
CT
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24148220
Click on the following link and make sure the circled check boxes are unchecked.

http://www.webpaths.com/archives/software/microsoft/iis/2009/02/02/enabling-http-compression-in-iis6.html

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24148860
On it.... I'll post back in a few.
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24149055
ComputerTechie and Inkevin,

Compression is off on the site and don't think I ever turned it on actually.

I tried a random random test,  (On my computer)  Start-->RUN-->\\servername\c$ using administrator credentials on the server. I then copied a jpeg file over to the server then tried to open it on the server and it looked corrupt, I copied it back to my computer and it looked fine. I tried this with several images from my desktop computer, all looked corrup whe launching then from the \\servername\c$ mapped window, and some (50%) were corrupt when copied back to my computer.

Could this be a file printer sharing issue?
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24149746
Could this be a file printer sharing issue?

I don't think so. It's just the broken link from the picture because the way it programs. In your server, the picture path that links from the page to image folder uses localhost or local path. However, when you try to open it from a remote computer, its localhost or local path does not contain the pictures. Therefore, your pictures should not show up when browsing. That is why when you develop a web site, you need to copy the entire web site to your local computer (that run IIS or other web servers). Any modification from your computer needs to replicate to your server via file copy or ftp. (recommend ftp so you don't mess with file copy/delete/change... on the fly)

Bottom line, it is normal when you don't see the pictures via browsing \\servername\c$..... When you see a broken picture, it means something in your cache store the picture when you access it from IIS. If you clear all cache by reboot your PC, you should not see pictures when browsing again.
I suggest you to copy entire website locally to your PC. Never access to the Inetpub folder when you developing the web site. Instead, start learning how to use ftp for web site update.

K
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24149867
If you still persisted with the plan to view the pictures from your remote PC, you may have to do the following:
- In your hosts file of the PC, replace the 127.0.0.1 with your server IP address 192.x.x.x.. or server name
- grant permission for Internet Guest account in Security tab of the folder where your pictures resided. This would break your security purpose, but you may see your picture. Give it a try for testing, but I still don't recommend this workaround method.

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24152729
I guess the IIS default page was a bad example. When moving the sites over to the new folder I copied the whole site folder so the server does know where the pictures are...

I'm my above post I said I put the file in the c drive... then tried to view the image that I had just place on the server. I just tried it with a .doc file to the servers c drive... with the same result. I didn't put them in a specific folder, completely taking iis out of the question.

I'm also logging with the servers administrators credientials..... which should be solving any permissons issues. There is something else going on here, but because I'm using the server as a web server people(myself included) cannot get past iis as being the problem.

Lets say I was using the server to serve up files for co-workers and had a problems viewing files and images. What would you have me look at then? I
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 24156880
Lets say I was using the server to serve up files for co-workers and had a problems viewing files and images....

Do you also have problem when viewed the image (by double click on image)? If you view the image via open up an html page, you are directly access to your image with html code and you need to satisfy html syntax. If you can, at the page that you try to access your image (html or htm) right click and Edit. Copy all codes and post it here. You don't need to hide your internal IP address such as 192.168....

K
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24157569
yes, if I double click on an image file it appears corrupt as do .doc files and som html code. even if I go right into the images folder and try double clicking on one of the images it will show as being corrupt.

I'll post what I can.
0
 
LVL 3

Author Comment

by:nicolausj
ID: 24214953
I'll post more information later today... it has been a busy week.
0
 
LVL 3

Accepted Solution

by:
nicolausj earned 0 total points
ID: 24217592
... Felling a bit dumb right about now...I suspected the anti-virus from the beginning, and was right. I upgraded my symantec 10.2 licence to be 11 which was supposed to work with server 2008 32bit.

When I fromatted the machine I first installed my anti-virus, then ran my windows updates.

I have unistalled it 2 times before and didn't have any change... Today I tried again, and with symantech removed everything is working. To be sure I installed it again, and my documents failed, I then uninstalled it and everything worked.

Now its time to call Symantec, thanks everyone for there help.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

More or less everybody in the IT market understands the basics of Networking, however when we start talking about Storage Networks, things get a bit dizzier, and this is where I would like to help.
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
The goal of the tutorial is to teach the user what gradient filters are and how to use them. When you have a photo and some part of the photo is either over exposed or under exposed, you use a gradient filter to help mask the need to touch up th…
The goal of the tutorial is to teach the user what exposure is and how to use the exposure slider. Analyze the photo that you want to edit, then adjust the exposure slider to your liking.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now