• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 529
  • Last Modified:

smart host not responding

We are in the middle of moving to a new ISP.  I tried switching us over to the new connection and had not problem with general connectivity, however our Exchange server could not seem to connect to the new ISPs SMTP to forward outbound mail.  Can all SMTP servers act as a smart host for Exchange, or do they have to be specially configured to allow Exchange to connect to forward mail?  Our ISP has not stated either way whether they have an Exchange smart host available; they just say they have an SMTP server.
0
I_play_with_DNA
Asked:
I_play_with_DNA
  • 4
  • 3
1 Solution
 
I_play_with_DNAAuthor Commented:
I should have added that the following error appeared in the event log:

MSExchangeTransport, Event ID 4006
Message delivery to the host '72.1.205.168' failed while delivering to the remote domain  'smtp.bluarc.ca' for the following reason: The remote server did not respond to a connection attempt.

And I was able to Telnet to the SMTP server on port 25.
0
 
MesthaCommented:
Smart host is almost an exclusive Microsoft term. You just need to know your ISPs SMTP server and whether they have restrictions on its use (domains need to registered, username/password required etc).

Can you telnet to the smart host on port 25?
Have you changed any DNS forwarding on the domain controllers to use the new ISP?

Any reason why you cannot use DNS for delivery? Do you not have a static IP address or have reverse DNS/PTR records set?

Simon.
0
 
I_play_with_DNAAuthor Commented:
I can telnet to the SMTP on port 25.

There were no DNS forwarders set on the domain controller.  This controller was set up by my predecessor and he did not configure any forwarders, but DNS resolution on our network works fine, so I assume that the domain controller is using it's gateway as the DNS automatically, and the gateway has it's DNS set as the new ISPs DNS.

I am considering using DNS for delivery, but I worry about our static IP being blacklisted if our mailserver were to become compromised at some point.  If we were to be blacklisted it would cripple the company.  II do have a PTR set though, so DNS is a possibility.



0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
MesthaCommented:
Blacklisting is something that every company has to worry about. Using a smart host wouldn't really help with that - if the server was compromised then the spam would go through the smart host and your ISP could kick you off their network.
As long as the secure is secured, you have applied the relevant settings (recipient filtering, tar pit, restricted relaying, used strong passwords etc) then the chances of being blacklisted are minimised significantly.

Simon.
0
 
I_play_with_DNAAuthor Commented:
Further information:

When I telnet into the ISPs smart host (FROM the Exchange server) I can connect and actually send an e-mail using manual SMTP commands.  The e-mail is received by the recipient account.  But when Exchange tries to relay through the smart host I get "The remote server did not respond to a connection attempt" (MSExchangeTransport Event 4006) as mentioned above.

When I configure the SMTP Connector on our Exchange server to send using DNS, outbound mail simply sits in the various SMTP Connector queues and is never actually sent.

It seems that I cannot get our Exchange server to connect to ANY smtp server other than that of our old ISP.  I can relay mail through that server.  So I must be missing something in the Exchange configuartion.

Any ideas?
0
 
MesthaCommented:
If telnet can connect then Exchange should be able to connect. There is nothing in Exchange which would stop the email from flowing correctly.

However what can stop email delivery is an authentication issue, so a username and password has been put on the SMTP virtual server directly and/or a smart host set on the SMTP virtual server directly.

Simon.
0
 
I_play_with_DNAAuthor Commented:
I think the problem was that there was a password set in the SMTP Virtual Server, but I only removed the one from the connector.  I ended up deleteing the connector completely and removing the PW from the virtual server and this fixed the problem.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now