Can't connect to SQL Server 2005 Express from SQL Server 2005

I am using SQL Server Management studio to connect to a SQL Server 2005 Express database. I keep getting the following error:

TITLE: Connect to Server
------------------------------

Cannot connect to VMWINXPBLOOM1.

------------------------------
ADDITIONAL INFORMATION:

An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 1265)

I have allowed for remote connections(both TCP/IP and named pipes) and configured SQL browser to start The SQL Server Express Machine VMWINXBLOOM1

THe SQL Server 2005 machine is running win2k3, the express machine winxp sp2




adimitAsked:
Who is Participating?
 
udaya kumar laligondlaTechnical LeadCommented:
check if the port no 1433 is open and allowed to access on both the machines in firewall. use the machine IP address and try
0
 
jss1199Commented:
You are attempting to connect to VMWINXPBLOOM1\SQLEXPRESS or just VMWINXPBLOOM1?
0
 
adimitAuthor Commented:
the only option that is available to me when I browse is VMwinxpbloom1. I don't see the option for SQLEXPRESS
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
adimitAuthor Commented:
I just tried typing in vmwinxpbloom1\sqlexpress and I received the same error
0
 
adimitAuthor Commented:
there is no firewall. The port is opened. I can connect to any other SQL Server Machine except any computer running SQL Server express. They all use port 1433
0
 
udaya kumar laligondlaTechnical LeadCommented:
it looks like the client is trying to use named pipes. check if it is enabled on the server and that port is exempted from firwall list.

use the checklist provided at
http://blogs.msdn.com/sql_protocols/archive/2007/03/31/named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server.aspx
http://blogs.msdn.com/sql_protocols/archive/2005/10/22/483684.aspx
0
 
adimitAuthor Commented:
by default i had to enable incoming connections and sql browser on sql express station
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.