Autodiscover connecting to internal AD

A quick one for you guys, but I'm going around in circles trying to find a fix.

I've taken on a job to troubleshoot an Exchange 2007 Server on a Server 2008 Standard Edition machine. A SAN certificate has been installed, which has the domains mail.company.com, servername, servername.ad.company.com and autodiscover.company.com listed. (mail.company.com being the Common Name, the others being Subject Alternate Names).

The firewall has already been configured to allow port 443 through to the server, URLs updated in Exchange and the SSL certificate installed. Outlook (on a non-domain joined machine) does seem to work. However, it is painfully slow in the initial discovery and start-up phases.

What seems to be happening is Outlook is attempting to connect to the internal server name (servername.ad.company.com) rather than the external name (mail.company.com). I've checked every location in Exchange but cannot find where the wrong URL is located.

Any insight would be appreciated as I'm going round in circles. Thanks.
LVL 58
tigermattAsked:
Who is Participating?
 
MesthaConnect With a Mentor Commented:
Standard first test: https://www.testexchangeconnectivity.com/
See what that throws up. It will show you everything the process goes through.
There is an initial connection on the AD name, because Outlook Anywhere doesn't kick in until after that has failed, so a slight delay in connecting is to be expected. However if the Outlook install is in cached mode then Outlook should start correctly.

Where you can get odd things happening is if the server's FQDN resolves externally due to a wildcard on the domain. That will cause things to take longer to time out because it is now a connectivity rather than a name resolution time out.

Simon.
0
 
kevalaConnect With a Mentor Commented:
Can you post a "Test E-Mail AutoConfiguration" with only "Use AutoDiscover" enabled?


Hold CTRL, right-click the Outlook icon, select Test E-mail.....
Check only "Use Autodiscover"
Click Test

Look through the connections on all tabs, post results of results tab and log tab if possible.
0
 
FearNoMoreConnect With a Mentor Commented:
Hmmm.....have you checked the SCP (Service Connection Point) in ADSIedit?
 DC=<domain>, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=First Organization, CN=Administrative Groups, CN=Exchange Administrative Group, CN=Servers, CN=<CAS Name>, CN=Protocols, CN=AutoDiscover, CN=<CAS Name
 A similar problem is posted here
http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/57574406-dddc-4a4b-98ac-0ba8585940bb
 
0
 
tigermattAuthor Commented:
Well, I've advanced a lot in the last 12 hours. This server had been completely incorrectly configured, which was the cause for Autodiscover to be very slow.

In short, this is what I've now done:

Re-keyed the SSL certificate with the supplier and re-applied the SSL certificate
Reset the configuration of the various Exchange Virtual Directories
Fixed the EAPs and Accepted Domains lists, to include only the client's main domains and none of the other rubbish which was in there
Disabled Autodiscover, rebooted, re-enabled.

And it is now much, much quicker - in fact, whereas configuration in Outlook could take upwards of 5 minutes to detect and make the initial connection, I just made a connection in less than 15 seconds. So, a lot quicker!

Thanks for your help guys. Simon, that test site is particularly useful and is now in my bookmarks. Thanks!

-Matt
0
 
tigermattAuthor Commented:
All useful information, thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.