GPO for Wallpaper on Windows 2000 Server

Hello all,
I have a client that has a Windows 2000 server that has all users connect to it through terminal services.
I am trying to use GPO to make it so that there is a specific wallpaper that everyone uses.  This is wallpaper that has writing on it that tells the user that they are connecting for business purposes and that there is no internet access on this connection especially for personal use.
Anyway, under the GPO the only way I can see to force a certain wallpaper (and yes it is a .bmp file) is to enable Active Desktop.  As soon as I do that then the next time the user connects through terminal services (or RDP) two internet explorer pages come up.  
It would be sending the wrong message to have a wallpaper that states no internet access then two web pages come up on startup.
How else can I do this without enabling Active Desktop?
Thanks,
Kelly W.
LVL 4
Kelly_WAsked:
Who is Participating?
 
snusgubbenConnect With a Mentor Commented:
You can open regedt32, navigate to the last key in your string and give the user write access to the key.

Under HKEY_USERS\.default\..\..

and to the rest of the SIDs :)
0
 
snusgubbenCommented:
If you use a GPO then Active Desktop needs to be enabled.

Take a look at this for an alternativ way:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_22117293.html


SG
0
 
Kelly_WAuthor Commented:
Hello all,
I tried that and still I cannot get the .bmp to come up as the wallpaper.  It will if I turn on Active Desktop but I do not want to do that.
I have gone through everything that I can think of under the GPO and everything is set to Not Configured for the desktop so I don't know what I am doing wrong.
I looked under the test user and in the registry under hkcu\control panel\desktop the wallpaper is set correctly.
Thanks,
Kelly W.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
Kelly_WAuthor Commented:
Hello all,
Okay I found two additional lines to add to my script:

reg add "hkcu\software\microsoft\windows\currentversion\policies\system" /v Wallpaper /d "c:\grpscrpt\server1.bmp" /f
reg add "hkcu\control panel\desktop" /v Wallpaper /d "C:\GRPSCRPT\server1.bmp" /f
reg add "hkcu\software\microsoft\windows\currentversion\policies\explorer" /v NoActiveDesktop /d "1" /f

On line one and line three (new lines I added) when the user tries to run this script, they get an access is denied error.  How can I give access to the user to those two parts of the registry that is under their user id?
Thanks,
Kelly W.
0
 
Kelly_WAuthor Commented:
Hello,
I tried under HKEY_USERS of giving permissions of write access to the user and still I get an Access is Denied error.
Thanks,
Kelly W.
0
 
Kelly_WAuthor Commented:
Hello,
I got the permissions to work but still no go on the wallpaper.
I am stumped on what to do now,
Thanks,
Kelly W.
0
 
Kelly_WAuthor Commented:
Hello all,
There has got to be a way to do this, isn't there?
Thanks,
Kelly W.
0
 
Kelly_WAuthor Commented:
Hello all,
Yeah I got it to work.  I had to use BGInfo but it works great, and NO Active Desktop.
I had to put the following line in as a script:
\\server\netlogon\bginfo.exe \\server\netlogon\config.bgi /timer:0 /NOLICPROMPT /silent
Thanks,
Kelly W.
0
 
Kelly_WAuthor Commented:
Though your recommendation did not solve the issue, it led me down the correct patch.  Thank you much.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.