• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 403
  • Last Modified:

Error installing phpAuction

I am trying to install phpAuction on our website, which is hosted on LunarPages. I followed all the instructions from phpAuction very carefully, and now when I try to run the installation script I get the following error:

extension_dir does not exists /usr/local/lib/php/extensions/no-debug-non-zts-20020429

I have submitted tickets on LunarPages & phpAuction support, but they're both closed for the night and I thought I'd try asking here. What does this error mean? Any ideas how to get around it?
0
figsagee
Asked:
figsagee
  • 5
  • 3
1 Solution
 
NerdsOfTechTechnology ScientistCommented:
The directory where the phpAuction believes the php script to be is referenced incorrectly.

You will need to determine what your server directory path is and readjust the configuration file to point to the correct "local" directory where that file actually resides.

=NerdsOfTech
0
 
figsageeAuthor Commented:
I'm trying to run install.php, which is in the auction/admin folder on my site. The instructions had me point my browser to /auction/admin/install.php. It seems to me, based purely on my outdated and inadequate knowledge, that it would just run if you try to run it from the folder that it's in. But not so? Where is it looking for the config file?

One entry on the phpAuction knowledgebase said to create a file named php.ini that contains this line...
extension_dir = ./
and put it in the cgi-bin folder. I did that, but it didn't help. Should it be in a different folder or have a different path?

I really appreciate your help. Thank you.
0
 
NerdsOfTechTechnology ScientistCommented:
Looks like your host is Windows

Configure php.ini shold be
extension_dir = "c:\php5\ext"

Open in new window

0
 
NerdsOfTechTechnology ScientistCommented:
php.ini
extension_dir = "c:\php5\ext"

Open in new window

0
 
figsageeAuthor Commented:
Our web host is a linux/apache server. Here's something I just found on the compatibility test we ran...

Setting/Option: Extension dir        
Value:  /usr/lib/php/extensions/no-debug-non-zts-20020429
Compatibility: You must place ixed files at/usr/lib/php/extensions/no-debug-non-zts-20020429/

Does that help?
0
 
figsageeAuthor Commented:
I got the following response from LunarPages support:
The php.ini file needs to go in the public_html folder on our servers. Please move your php.ini to that directory and using the following: extension_dir = / or extension_dir = You will also need to add the following to the .htaccess in the public_html folder: suPHP_ConfigPath /home/username/public_html/sub-mhvtnet/bmanager02 where "username" is your cPanel username.

I made these changes and called LunarPages to make sure I had done it correctly, but am still getting the error. They wouldn't go any further with me on phone support, but told me to reply to the ticket which I have done.



0
 
figsageeAuthor Commented:
LunarPages escalated the ticket, and one of the techs created a custom php.ini file for my account which included the correct path of the affected extension (/usr/local/lib/php/extensions/no-debug-non-zts-20060613).
That allowed the install script to run successfully, but when I tried to load the page I got the same error with a different number at the end.
The LunarPages tech adjusted the php.ini file again and now it all works.
0
 
figsageeAuthor Commented:
I just didn't have enough knowledge to fully implement your solution, but it helped me understand what was happening. Thank you.
0
  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now