Solved

Localhost maps to multiple IP addresses in weblogic 10.3

Posted on 2009-04-06
6
14,616 Views
Last Modified: 2013-12-10
Hi All,

         i am a newbie in weblogic.i have installed weblogic 10.3 in my Rhel 5 box.But when i start the script startweblogic.sh i am getting a error which i mentioned below.

ly.>
<Apr 7, 2009 5:07:14 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to ADMIN>
<Apr 7, 2009 5:07:14 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RESUMING>
<Apr 7, 2009 5:07:14 PM IST> <Warning> <Server> <BEA-002611> <Hostname "admin-cgi1.main.cobaltgroup.com", maps to multiple IP addresses: 192.168.142.149, 127.0.0.1>
<Apr 7, 2009 5:07:14 PM IST> <Notice> <Server> <BEA-002613> <Channel "Default" is now listening on 192.168.142.149:7001 for protocols iiop, t3, ldap, snmp, http.>
<Apr 7, 2009 5:07:14 PM IST> <Notice> <Server> <BEA-002613> <Channel "Default[1]" is now listening on 127.0.0.1:7001 for protocols iiop, t3, ldap, snmp, http.>
<Apr 7, 2009 5:07:14 PM IST> <Notice> <WebLogicServer> <BEA-000329> <Started WebLogic Admin Server "AdminServer" for domain "cblt" running in Production Mode>
<Apr 7, 2009 5:07:14 PM IST> <Warning> <Server> <BEA-002611> <Hostname "localhost", maps to multiple IP addresses: 192.168.142.149, 127.0.0.1>
<Apr 7, 2009 5:07:14 PM IST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RUNNING>
<Apr 7, 2009 5:07:14 PM IST> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>

i did a netstat -an | grep 7001
[root@admin-cgi1 uninstall]# netstat -an | grep 7001
tcp        0      0 ::ffff:127.0.0.1:7001       :::*                        LISTEN
tcp        0      0 ::ffff:192.168.142.149:7001 :::*                        LISTEN
[root@admin-cgi1 uninstall]#

i tried going to the console through both the ip and localhost from the admin-cgi1 machine and its working fine. But from the remote machine i am not able to connect to the weblogic console..i tried googling it and found a solution to edit the config.xml. As i dont know know to edit config.xml i am not able to completed this task. Can someone please help me to solve this issue.
0
Comment
Question by:In_Ness_EE02
  • 3
  • 3
6 Comments
 
LVL 10

Accepted Solution

by:
rajesh_bala earned 500 total points
ID: 24087434
Hope you are able to locate config.xml in your domain atleast.

Otherwise, search for config.xml in the directory from where you are starting startWeblogic.sh

Now, in config.xml, do the following

<server>
    <name>AdminServer</name>
    <listen-address>ENTER_YOUR_HOSTNAME</listen-address>
  </server>

Replace ENTER_YOUR_HOSTNAME with your machine name. I hope your server name is AdminServer. If you see something else dont change it.

CRUX is to just set listen-address value and restart your server. Now you can access from anywhere provided your machine name is resolvable from other systems.
0
 

Author Comment

by:In_Ness_EE02
ID: 24088183
i can find config.xml in 3 locations
/opt/wls10.3/cblt/cblt/cblt/config/config.xml
/opt/wls10.3/cblt/cblt/config/config.xml
/opt/wls10.3/samples/domains/medrec/config/config.xml

and i tired editing the first 2 file i am still getting the error
<server>
    <name>AdminServer</name>
   <listen-address>admin-cgi1</listen-address>
    <listen-address/>
  </server>
host name is admin-cgi.
0
 

Author Comment

by:In_Ness_EE02
ID: 24088231
sorry admin-cgi1
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 10

Expert Comment

by:rajesh_bala
ID: 24090609
You dont need to add listen-address 2 times. It should be like follwing

 <server>
    <name>AdminServer</name>
   <listen-address>admin-cgi1</listen-address>
  </server>

In /etc/hosts ensure, admin-cgi1 is properly mapped to your ip. Check in other boxes if it has got the admin-cgi1 is properly configured in its hosts file.

you can check by running "ping admin-cgi1" from other boxes. If it works, you should be fine.
0
 
LVL 10

Expert Comment

by:rajesh_bala
ID: 24090622
If possible, check if you can remove admin-cgi1 mapping to 127.0.0.1 in your /etc/hosts file.
0
 

Author Comment

by:In_Ness_EE02
ID: 24591823
Thanks its working fine now...
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
How following rewrite rule works in Apache? 7 119
Fisheye tool 2 104
Wesphere App server multiple instances on single Windows server 5 80
Https with tomcat. A myth. 5 101
-Xmx and -Xms are the two JVM options often used to tune JVM heap size.   Here are some common mistakes made when using them:   Assume BigApp is a java class file for the below examples. 1.         Missing m, M, g or G at the end …
Verbose logging is used to diagnose garbage collector problems. By default, -verbose:gc output is written to either native_stderr.log or native_stdout.log.   It is also possible to redirect the logs to a user-specified file. This article will de…
Concerto provides fully managed cloud services and the expertise to provide an easy and reliable route to the cloud. Our best-in-class solutions help you address the toughest IT challenges, find new efficiencies and deliver the best application expe…
A company’s greatest vulnerability is their email. CEO fraud, ransomware and spear phishing attacks are the no1 threat to a company’s security. Cybercrime is responsible for the largest loss of money to companies today with losses projected to r…

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now