?
Solved

i have set up rpc over http and followed al the instructions. i am not using ssl just port 80 to do some testing. When I try to log on the password prompt keeps coming back. if i turn auditing on i ca

Posted on 2009-04-07
6
Medium Priority
?
258 Views
Last Modified: 2012-06-27
i have set up rpc over http and followed al the instructions. i am not using ssl just port 80 to do some testing. When I try to log on the password prompt keeps coming back. if i turn auditing on i can see the user logging on so the proxy server is passing the request to the mail server but it does not appear to be going back to the client.
0
Comment
Question by:tjwoollard
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 4

Expert Comment

by:StefanKittel
ID: 24085670
Hello,

have a look a this: http://www.petri.co.il/how-can-i-configure-rpc-over-https-on-exchange-2003-single-server-scenario.htm
You need to turn off security for some parts.

IIS tries to connect internaly to the exchange which does not support this (wired).

Stefan
0
 
LVL 3

Expert Comment

by:stealthwifi12
ID: 24086374
One little trick to try before all of the below.
Login like this:
Username: DOMAIN\username
password: (enter your password here)

The trick is use the full domain\username in the username box, that will get it working.

Are you using Outlook 2003 or 2007 for this?

Be sure you Outlook account settigns are correct:
Under Account - More Settings
Connection tab ensure "Connect to Microsoft Exchange using HTTP"
Click Exchange Proxy Settings ...
Ensure your URL is correct (Un check SSL as you said you are using port 80)
Check the appropriate fas and slow network boxes (probably both need to be checked for you)

Under Proxy Authentication you should have Basic Authentication selected.
Ensure Encryption box is checked on the Security tab (better than nothing).

On the Security tab for Logon network security:
Set it to NTLM. If that does not work try Negotiate Authentication

That should do it for you. Ensure you are not blocking port 80 on your firewall (sounds like you are getting the connection screen so you should be set there) and it's forwraded to the correct server.

0
 
LVL 65

Accepted Solution

by:
Mestha earned 2000 total points
ID: 24086435
This feature should be called RPC over HTTPS - using an SSL certificate is pretty much mandatory. While there are people who claim to get it working on HTTP, it is not supported and is a lot of work. While I appreciate that you are testing it, you really need to deploy it as designed - using a commercial SSL certificate. It will save you a lot of headaches in getting it to work because everything is expecting to work over port 443 - Outlook included.
A self signed certificate is not enough, that will cause you as many headaches, it needs to be a trusted certificate.
RapidSSL do trial 30 day certificates, but the cheapest ongoing is GoDaddy: https://CertificatesForExchange.com/ 

Simon.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 3

Expert Comment

by:stealthwifi12
ID: 24086506
I have done with Self Signed certificate and it is not much more of a headache, I currently have a small branch office running that way. Work great.
0
 

Author Comment

by:tjwoollard
ID: 24086786
i have just read this :-

IIS authenticates the HTTP request using Basic authentication or NTLM authentication, depending on the Outlook profile setting. After IIS authenticates the request, it sends the request to RpcProxy.dll. RpcProxy.dll only accepts authenticated requests. Even if IIS is configured to allow anonymous users, RpcProxy.dll does not forward an anonymous request to the Exchange server. Additionally, RpcProxy.dll only accepts HTTP requests over SSL. If the HTTP session does not use SSL, RpcProxy.dll blocks the request

It clearly states I must use SSL so am I wasing my time trying to use port 80 ?
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24087208
As I wrote above - you are wasting your time trying to get it work on port 80.
While it is possible to get the feature to work on self signed certificates, I don't see the point in doing so. I can get this feature to work, from scratch, in less than 30 minutes, including the time to get an SSL certificate. Now I don't know about how much people's time is worth, but the hours getting it to work with a self signed certificate, then talking remote people through the certificate installation, then repeating it when that certificate expires makes it a no brainer in my eyes. A certificate costs US$30/year!

Simon.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question