[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Cant open / view contents of CD or DVD Vista tries to format disc

Posted on 2009-04-07
16
Medium Priority
?
435 Views
Last Modified: 2012-05-06
When I put a disc in my Vista machine with data on it Vista always asks to format disc.  In computer the D: drive shows the disk as "0 bytes free of 1.5 MB"  this indicates to me that the disc has been closed.  I can view contents in cmd window, but I don't want to use that.  This happens on many of my computers in my domain (all vista), doesn't happen to XP.

I've searched this issue on the web and found many people experience this, but have found no real solutions, so I come the EXPERTS.

How do I view the contents of my discs?  
0
Comment
Question by:cavalierlan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 6
16 Comments
 
LVL 6

Expert Comment

by:akrdm
ID: 24087147
The following website has some information with a possible fix for you.

http://forums.techguy.org/windows-vista-7/689802-solved-vista-cdrw-problem.html

Note: I would recommend backing up the registry before making any of the changes mentioned in this article.  It will require that you delete two registry keys.
0
 

Author Comment

by:cavalierlan
ID: 24087534
Thanks,  I will try this.
Do you know what these reg keys do, so I know what I'm disableing?
0
 
LVL 6

Expert Comment

by:akrdm
ID: 24087625
I am sorry I don't, I just came accross the article in my search for a resolution to your problem.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:cavalierlan
ID: 24096349
I don't have upperfilters and lowerfilters in that directory.  (see screen shot)

Picture1.png
0
 
LVL 6

Expert Comment

by:akrdm
ID: 24096887
I don't know if you have any VM ware installed on any of the machines but one thread I found talked about VMWare being the cause of the same problem you are having.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_Vista/Q_23172393.html

Check to see if you have VMware installed on any of the machines and see if removing it resolves the problem.
0
 
LVL 6

Expert Comment

by:akrdm
ID: 24096977
They other thing I would recommend is that you check the auto play settings for the Drives
Control Panel\Hardware and Sound\AutoPlay.  One forum that I read recommended setting it to explorer and then it would just open the file explorer view.  But check and see what it's set to right now for auto run and see if you can change it to something different and if this resolves the issue.  Please post back with results.

Thank you,

akrdm
0
 
LVL 6

Expert Comment

by:akrdm
ID: 24097132
You also asked for additional information on what the upper and lower filters do the other day.  I came across this article that talks about their purpose and the reason for deleting them.  Since you don't have them this is just an FYI.
0
 
LVL 6

Expert Comment

by:akrdm
ID: 24097159
0
 

Author Comment

by:cavalierlan
ID: 24651936
Sorry for not getting back my subscription ended.
If your still interested in this, I don't have VM ware installed.
My autoplay is turned off, we have to have it off.
Do you have any other insight, Thanks for your help.
0
 
LVL 6

Accepted Solution

by:
akrdm earned 2000 total points
ID: 24652309
Thanks for posting back.  I have found some additional information.  Since you can't use the auto Run feature (even if it's asking what to do?) then you should try disabling the windows vista burning feature.  The following steps will walk you through this process. I believe that you only need to do one or the other.  But if for some reason one does not work then please try the other one.  Remember that editing the registry can always be dangerous and you should create a backup before starting.

By Group Policy:
1. run gpedit.msc
2. go to [User Configuration\Administrative Templates\Windows Components\Windows Explorer]
3. double click [Remove CD Burning Features], choose [Enable]

By Registry:
1. run cmd.exe as administrator
2. reg add HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoCDBurning /t REG_DWORD /d 1 /f
0
 
LVL 6

Expert Comment

by:akrdm
ID: 24652315
Side note to my last post as well.  If you disable the windows burning feature as suggested you will require 3rd part software to be able to burn CD or DVD's.
0
 

Author Comment

by:cavalierlan
ID: 24657094
I would like to give it a try to see if it helps, I don't know if I want to change all my users to this, and buy 3rd party software for all.
Going to try your first solution, but there was no windows explorer GP path. see attached.

No-Windows-Explorer.JPG
0
 
LVL 6

Expert Comment

by:akrdm
ID: 24658521
Just to clarify and make sure the first one was for a Group policy, you can also access group policies via the control panel under administrative tools.  You should be able to access the search section just above the start button and then type in the gpedit.msc.  Then you just need to add a snap in for local or group policies on the machine.  (If this is where you were then I apologize for the further explanation).

Let me know if that is where you were looking so I can see if we can find something else.
0
 

Author Comment

by:cavalierlan
ID: 24659809
No I wasn't in GP.  I have now turned off windows burning features and can now browse a cd/dvd.
What causes this?  Is there a way to have windows burn and see my disc, this seems like a backwards way to fix the problem.
0
 

Author Closing Comment

by:cavalierlan
ID: 31567486
This works, but you have to give up ability to burn from windows.
0
 
LVL 6

Expert Comment

by:akrdm
ID: 24665961
I don't know what causes the issue.  The other posts and items that I found basically stated to make sure the windows autoplay was set correctly.  So maybe if you don't have anything selected for autoplay then windows must default to wanting to burn the CD.  This is a best guess cause I am not really sure what is causing it.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many times while working on a computer regardless of any Operating System, lag and crashes seem to creep in, hindering your working speed. Sometimes, it can also cause your work to be lost unexpectedly and as a result, you are unable to meet your de…
Have you ever had a hard drive that you can't boot into, but need to change the registry? Here is the solution! This article guides you through accessing and editing a registry of a non-primary drive. To read registry information on a non-prim…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question