Can't send mail from a secondary Exchange 2007

I've an Exchange 2003 in a Windows 2003 server working correct. I've installed a Windows 2008 as a secondary domain controller and an Exchange 2007 SP1 in the same exchange organization.

I can create new user mailboxes in the new exchange server 2007 and can receive mails from the internet and mails from the exchange 2003. But I can't send mails from exchange 2007 to the exchange 2003 mailboxes and internet directions.

I've the error in the eventviewer:

Event ID 2017: No se pudo realizar la autenticación saliente debido al error WrongPrincipal para el conector de envío Conector de envío SMTP interno de la organización. El mecanismo de autenticación es Gssapi. El objetivo es SMTPSVC/

Nombre de registro:Application
Origen:        MSExchangeTransport
Fecha:         07/04/2009 17:51:15
Id. del evento:2017
Categoría de la tarea:SmtpSend
Nivel:         Error
Palabras clave:Clásico
Usuario:       No disponible
No se pudo realizar la autenticación saliente debido al error WrongPrincipal para el conector de envío Conector de envío SMTP interno de la organización. El mecanismo de autenticación es Gssapi. El objetivo es SMTPSVC/


  - Provider

   [ Name]  MSExchangeTransport
  - EventID 2017

   [ Qualifiers]  49156
   Level 2
   Task 2
   Keywords 0x80000000000000
  - TimeCreated

   [ SystemTime]  2009-04-07T15:51:15.000Z
   EventRecordID 1175
   Channel Application

- EventData

   Conector de envío SMTP interno de la organización

The error is in spanish. Translation may be like this:
Can't realize autbound authentication because an error WrongPrincipal for the sender connector Conector de envío SMTP intern of organization. The authentication mechanism is Gssapi. The objective is SMTPSVC/

I think it would be a little option or something easy, but I don't know what.

Thank you!
Who is Participating?
milikadConnect With a Mentor Commented:
In exchange 2003, go to protocols - SMTP - Default SMTP VS - Properties - Delivery Tab and Select Advanced - Check the Fully Qualified Domain Name.
It should be FQDN name of Exchange 2003 server (e.g. and not something like
After changing it, go to windows services and restart SMTP and Exchange Routing Engine Service.
Then go to exchange 2007 and force the mails from the queue or simply restart Transport service.
Run the following command and give result
Do you have an SMTP Connector on the Exchange 2003 server?
If so then Exchange 2007 will try and use that, which will mean that internet email would be going to the Exchange 2003 server first.
Therefore the same problem that is stopping internal email would cause the problem for outbound email.

Check that you do not have any restrictions on the SMTP virtual server in Exchange 2003, and ensure that all three authentication options are enabled.

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

It may be issue related AD.
Check if there is any time mismatch between exchange servers and domain controller.
xutiAuthor Commented:

If I execute the command get-routinggroupconnector appears:

Name                      SourceRoutingGroup         TargetRoutingGroup
----                      ------------------         ------------------
EXCHANGE-DC3-SECDOR       Exchange Routing Group ... First Routing Group
DC3-SECDOR-EXCHANGE       First Routing Group        Exchange Routing Group ...

The exchange 2003 server is DC3-Secdor.
The exchange 2007 server is Exchange.

Yes Simon, we want to exchange 2003 send and receive all mails and exchange 2007 only has the mailboxes and OWA for web access. I don't find the options you are referring at. Where can I configure that restrictions?

I've checked errors in AD but it seems to be ok and no errors.

Thank you!
Run the following command:  Get-ExchangeCertificate

Check the FQDN name it is showing in the certificate and check the FQDN name in the default SMTP VS - Properties - Advanced and change it to and restart the SMTP service and check if it work and let us know.
If this doesn't help then paste the output of Get-exchangeCertificate here.
Milikad (M)
One small change to earlier instruction, it seems that your exchange 2003 server name is DC3-Secdor. So change the FQDN name to You have to enter your exchange 2003 servers FQDN name there.
xutiAuthor Commented:
This is the get-exchangecertificate

Thumbprint                                Services   Subject
----------                                --------   -------
9A393699F8B09BFF121B7162B040C6FF3ADEBECF  IP.WS      CN=exchange

I don't know where to change FQDN :S

sorry, what can I do?

thank you
xutiAuthor Commented:
Thank you for the accurate and easy explanation! Now, exchange 2007 can send mails inside and outside our organization!!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.