Solved

OWA Redirecting to Internal Server Name

Posted on 2009-04-07
6
1,195 Views
Last Modified: 2012-05-06
For some reason, when accessing our OWA site through our external DNS https://webmail.domain.com/exchange it gets redirected to https://server.domain.local.  Internally and externally produces the same results even though I created an A record for webmail.domain.com.

What really baffles me though is that OWA still works externally, even though the internal server name is displayed in the address bar.  The biggest problem however is since the incorrect address is being shown we're getting a certificate error.

Any ideas what this could be?

Thanks in advance
0
Comment
Question by:paintb4707
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 65

Expert Comment

by:Mestha
ID: 24089376
Sounds like some kind of redirection has been set, possibly to enforce the use of SSL.
Has it ever worked correctly?

Simon.
0
 

Author Comment

by:paintb4707
ID: 24089660
Yes, it has.  I had to go through some PCI compliance crap recently, I wonder if this has anything to do with it?

http://support.microsoft.com/kb/834141
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24089697
What I was think of was this:
http://support.microsoft.com/kb/839357

The simple way to avoid the problem is to simply not open port 80 on the firewall. Make the users enter the https: version of the URL. After a few days of getting the error they will soon learn.

Simon.
0
Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

 

Author Comment

by:paintb4707
ID: 24089731
I do force HTTPS on our OWA server, since we're behind NAT and we also have a webserver, http is not an option externally.  I figured setting a redirection would be a waste of effort.
0
 
LVL 65

Accepted Solution

by:
Mestha earned 350 total points
ID: 24089787
The only reason Exchange directs to the server's internal FQDN is when you have multiple Exchange servers and you login to the wrong one. It then redirects you to the correct one. If you only have a single server then that shouldn't be happening.

If you undo the change that you made above and then run IISRESET does that resolve the problem?

Simon.
0
 

Author Closing Comment

by:paintb4707
ID: 31567628
Yup, that was it.  Silly me.  I originally set the "Usehostname" command which I guess set it to the internal FQDN.  I used the "Sethostname" command to our external address and that fixed it.

Thanks
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Find out what you should include to make the best professional email signature for your organization.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question