Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

sp3 install on Xp machine not working

Posted on 2009-04-07
4
Medium Priority
?
366 Views
Last Modified: 2012-05-06
When installing Windows Xp's Sp3 i get about halfway through before i get a popup stating that it needs to update the cmd.exe file but can't and i try to install it from the I386 directory i have on the machine but that does not work either

So then i try to uninstall the half install  and i get a Service Pack 3 Setup Error

"Service Pack 3 installation did not complete.
Windoes XP has been partially updated and may not work properly.

0
Comment
Question by:cdubbcisco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 3

Accepted Solution

by:
zrobinson earned 1500 total points
ID: 24089446
Are you getting a message along the lines of "cmd.exe is being run by another process or program and the installation cannot continue?"

If so, you need to check that you have properly quit all programs including antivirus or antispyware before installing SP3.  In addition, make sure the machine is free of any malware, as that could be part of the issue.
0
 
LVL 8

Expert Comment

by:skywalker39
ID: 24089468
Do you have system restore enabled? If so I would do a system restore, turn off any anti-virus, anti-spyware temporally and try again and see if SP3 installs.
0
 

Author Comment

by:cdubbcisco
ID: 24090060
i tried to restore but it said it was unable to do sono after a reboot i get a Isass.exe error
unable to locate Isass.exe component
This application has failed to start because WINMM.dll was not found. Re-installing the application may fix this problem
This comes up before the logon screen


After i logon i get another error

userinit.exe-Unable to locate  Component
This application has failed to start because WINMM.dll was not found. Re-installing the application may fix this problem
arghhhhhhhhhh
0
 

Author Comment

by:cdubbcisco
ID: 24090074
these errors also come up after the desktop is loaded
hkeyman.exe
pctspk.exe
HKEYAPP.exe
SCControlPanel.exe

They all say Unable to located Component
This application has failed to start because WINMM.dll was not found. Re-installing the application may fix this problem

0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you build your web application in Visual Studio you'll get at least a few binaries, or .DLL, files in your bin folder. However, there is more compiling to be done. Normally this would happen when an ASP.NET resource within the web site is request…
We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question