Solved

sp3 install on Xp machine not working

Posted on 2009-04-07
4
363 Views
Last Modified: 2012-05-06
When installing Windows Xp's Sp3 i get about halfway through before i get a popup stating that it needs to update the cmd.exe file but can't and i try to install it from the I386 directory i have on the machine but that does not work either

So then i try to uninstall the half install  and i get a Service Pack 3 Setup Error

"Service Pack 3 installation did not complete.
Windoes XP has been partially updated and may not work properly.

0
Comment
Question by:cdubbcisco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 3

Accepted Solution

by:
zrobinson earned 500 total points
ID: 24089446
Are you getting a message along the lines of "cmd.exe is being run by another process or program and the installation cannot continue?"

If so, you need to check that you have properly quit all programs including antivirus or antispyware before installing SP3.  In addition, make sure the machine is free of any malware, as that could be part of the issue.
0
 
LVL 8

Expert Comment

by:skywalker39
ID: 24089468
Do you have system restore enabled? If so I would do a system restore, turn off any anti-virus, anti-spyware temporally and try again and see if SP3 installs.
0
 

Author Comment

by:cdubbcisco
ID: 24090060
i tried to restore but it said it was unable to do sono after a reboot i get a Isass.exe error
unable to locate Isass.exe component
This application has failed to start because WINMM.dll was not found. Re-installing the application may fix this problem
This comes up before the logon screen


After i logon i get another error

userinit.exe-Unable to locate  Component
This application has failed to start because WINMM.dll was not found. Re-installing the application may fix this problem
arghhhhhhhhhh
0
 

Author Comment

by:cdubbcisco
ID: 24090074
these errors also come up after the desktop is loaded
hkeyman.exe
pctspk.exe
HKEYAPP.exe
SCControlPanel.exe

They all say Unable to located Component
This application has failed to start because WINMM.dll was not found. Re-installing the application may fix this problem

0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are 2 things you must have in order to connect to the internet behind a router, The "Gateway IP" of the router, which is usually something like 192.168.xxx.1, I've seen routers with default values of: 192.168.0.1, 192.168.1.1, 192.168.11.1, …
Step by step guide to Clean and Sort your windows registry! Introduction: Always remember: A Clean registry = Better performance = Save your invaluable time In this article we're going to clear our registry manually! Yes, manually! The e…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question