Solved

Log in from Work to Home -  Remote Desktop Protocol 3389

Posted on 2009-04-07
17
1,431 Views
Last Modified: 2013-11-21
I'm trying to connect from work to home using RDP.  

WORK COMPUTER:
start, run, mstsc, and type in my public ip address (ie...  74.125.91.147)  and the error is "Remote Desktop Disconnected, This computer can't connect to the remote computer. Try connecting again...."

I run this command:  nmap 74.125.91.147 -p3389
and it says:  PORT          STATE       SERVICE
                     3389/TCP    filtered       ms-term-serv

HOME COMPUTER: (static ip 192.168.33.150)
netstat -an |find "3389"
and nothing comes up... nothing is listening, I go to services.msc and set Terminal Services to Automatic, Manual, do a Refresh, Disable it, but nothing seems to help.  Turned Norton Internet Security firewall completely off.  Windows Firewall is off too.  When logging into my router I went to Advanced Settings, Forwarding, Virtual Servers, and enabled tcp/udp ports 3389.

anyone know what I'm doing wrong?  this used to work perfectly.  should my next step be to get terminal services port open, if so how do I do that?
0
Comment
Question by:jkimzlg
  • 5
  • 4
  • 3
  • +4
17 Comments
 
LVL 1

Expert Comment

by:NAK321
ID: 24090725
Just for clarity, you are sure the machine is on, your router is correctly configured, and your home cable modem is working?
0
 
LVL 31

Expert Comment

by:Justin Owens
ID: 24090735
What is the OS on the HOME computer?
0
 
LVL 14

Expert Comment

by:BigBadWolf_000
ID: 24090744
On your router you forwarded port 3389 to you internal IP 192.168.33.150, yes???
What is your router make/model??
Is your public IP static?

 
0
 
LVL 1

Author Comment

by:jkimzlg
ID: 24090811
I'm using Windows xp, the machine is on, home cable modem is working.  Hopefully router is configured correctly.

yes, I forwarded port 3389 to my internal address 192.168.33.150, it's a TP-Link 108M Wireless Router TL-WR641G, my public ip is a Dynamic IP, but it's never changed on me, always been the same one.
0
 
LVL 7

Expert Comment

by:briandunkle
ID: 24090815
I would try something a little more user-friendly, like cports or aports, to see if the service is listening on that port on your home machine.
You say it used to work? Obvious question, but what changed? Did you add a machine to your home network? Did it work before with Norton turned on? Is your router reserving the same IP for your machine each time it comes up, or is it possible another machine grabbed that (local) IP? Have you tried changing the port remote desktop uses?
0
 
LVL 31

Expert Comment

by:Justin Owens
ID: 24090852
There are (if memory serves), a couple of MS security patches for XP that shut off Remote Desktop.  Have you gone in and checked to make sure it is still on?  I know that seems elemtary, but sometimes checking the most obvious is the missing step.
0
 
LVL 7

Expert Comment

by:briandunkle
ID: 24090869
PS - I would say go ahead and reset your cable modem and pull a new IP, because there are probably a ton of people hammering on it right now, benign or not. :)
0
 
LVL 7

Expert Comment

by:briandunkle
ID: 24090882
I have also had this crap out if I've had the home machine up for too long/'doing too many network-related things. Might try immediately after a clean boot of the home machine, if possible.
0
Why won’t your email signature format correctly?

Struggling to get your corporate email signatures to format correctly? Does the logo keep resizing? Is the text appearing too big? What can you do to prevent this? Find out how you can save your signatures today.

 
LVL 1

Author Comment

by:jkimzlg
ID: 24090950
things that changed, I did however also create a VPN connection by setting up a New Connection, Setup an Advanced Connection, Accept Incoming connections..... and that worked from work to home.   This didn't work yesterday and when I restarted my computer this morning it didn't work either.

My router is reserving the same IP for the machine each time it comes up.  How do I change the port remote desktop uses?
0
 
LVL 31

Expert Comment

by:Henrik Johansson
ID: 24091135
You're propably using XP Home Edition at home, which doesn't support incoming RDP access.
You nead to upgrade the home computer to XP Pro to enable RDP-access.

The Terminal Services service exist on XPHE to support local fast user switching.
0
 
LVL 1

Author Comment

by:jkimzlg
ID: 24091210
I'm using winxp pro sp3.

DrUltima, How do you check to see if MS security patches for XP that shut off Remote Desktop is still on?

briandunkle, thanks for the security/hacker warning.
0
 
LVL 7

Expert Comment

by:briandunkle
ID: 24091477
It turns it off one time, but doesn't break it. You just need to see if it's on now or not.
0
 
LVL 3

Accepted Solution

by:
Popeyediceclay earned 500 total points
ID: 24092285
Maybe silly but did you enable Remote Desktop access in the My Computer Properties?  I would start with why it's not listening in netstat.exe because it should be there.
0
 
LVL 1

Author Closing Comment

by:jkimzlg
ID: 31567687
wow, appreciate all the feedback... pretty silly to forget something so simple...  
0
 
LVL 31

Expert Comment

by:Justin Owens
ID: 24093526
Heh... You realize I said that 2 hours before the accepted answer... :)
0
 
LVL 3

Expert Comment

by:Popeyediceclay
ID: 24093547
Sorry about that, I read through all the comments and didn't catch that either.
0
 
LVL 1

Author Comment

by:jkimzlg
ID: 24093552
ah man, my bad, I didn't know what u meant that.... it amazes me sometimes how bright people are on experts exchange... you have to basically spell it out for slow people like myself...  
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Know what services you can and cannot, should and should not combine on your server.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Many functions in Excel can make decisions. The most simple of these is the IF function: it returns a value depending on whether a condition you describe is true or false. Once you get the hang of using the IF function, you will find it easier to us…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now