Solved

Primary Master Drive suddenly inaccessible after running Process 4 with Spinrite 6.0

Posted on 2009-04-07
14
1,001 Views
Last Modified: 2012-05-06
In using a bench system to salve a notebook drive to check its consistency, my primary master drive went south and is intermittently being seen by the system's BIOS.  However, it suddenly will not self-boot.  This is after using a bootable Spinrite 6.0 CD.
The Primary master is an IDE, while the slaved drive is a SATA.
The SATA drive's data is totally accessible, however its Windows Vista will not fully boot up in the notebook, nor can it see the recovery image (hence not allowing a full recovery from the image).
Now I have the possibility that both my intended fix of the SATA -and- the main HD of the bench system may both need to be replaced, or at least reconstructed.  It is still possible that the SATA drive only needs its 1st partition fixed, but I yield to the expertise of my fellow EExperts.
0
Comment
Question by:modemmixer
  • 7
  • 2
  • 2
  • +2
14 Comments
 
LVL 1

Expert Comment

by:NAK321
ID: 24091153
Are you saying that in your bench system you have a PATA drive set to master and a SATA laptop drive set to slave in the same box?  
0
 

Author Comment

by:modemmixer
ID: 24091429
It's a P-III 1Ghz system with on-board IDE controller, so the main drive is IDE and is the master.
I also have a Promise PCI controller with both SATA and IDE interface.  The SATA drive from the notebook is attached to the Promise controller and can be seen by the Spinrite program as well as by the P-III's BIOS through the add-on controller.
It appears that my main drive (a Maxtor 80Gb, 2 equal partitions) is no longer accessible, but curious that this occurred only after using Spinrite. Hmmm ...
Ted
0
 
LVL 1

Assisted Solution

by:NAK321
NAK321 earned 150 total points
ID: 24091691
Sorry but I have a few more questions ...

Have you tried removing the SATA drive and performing the disk maintenance from within the laptop?
What happens in the bench system when you remove the Sata drive?
What functions did you perform with Spinrite?
0
 

Author Comment

by:modemmixer
ID: 24092205
I have now tried both slaving and native-to-notebook scenarios.
The 2 functions of which I am aware are Surface Analysis and Recovery of Data.

In either scenario doing the analysis on the primary partition, Spinrite went through without any problems to report. This took about 8-10 seconds.
In either scenario doing the Recovery process, Spinrite found nothing to recover and in even less time.

It just seems rather odd that this degradation took place within an hour of the installation of 2 new 2gb DDR2 memory modules (which I have since replaced with the 2 x 1gb original modules) now returned to place of purchase.
Ted
0
 
LVL 1

Expert Comment

by:RecoveryMan
ID: 24092724
Spinrite... sorry to the owners of this product but this product (as a recovery expert opinion :-) is up there with chkdsk...DANGEROUS. Performing a full surface scan on any drive is a risk if it has data on or not because it reads every block on the drive. There could be a bad area on any drive in lba addresses that you may never access (unless your drive gets really full) but when an application accesses it beware. Not sure there is much help within Vista such as fix MBR or repair installs so sadly you might just have to pull off the data and perform a full install.
0
 
LVL 47

Expert Comment

by:dbrunton
ID: 24094133
This is my standard advice on faulty hard disks.

Your best bet is to slave these hard disks into another computer.

Try GetDataBack http://www.runtime.org/  Free to try.  If it sees the missing files you pay for full functionality.

Also look at PCInspector http://www.pcinspector.de/file_recovery/UK/welcome.htm and Recuva http://www.recuva.com/

Both are free.

I'd try GetDataBack.  If it sees your files then try the free ones.  If they work you save money.
0
 
LVL 91

Expert Comment

by:nobus
ID: 24094552
test your disk drives to know their status :   http://www.tacktech.com/display.cfm?ttid=287
note that Spinrite is NOT dangerous, and one of the best disk softwares on the market
you can read the reason on their site...
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 

Author Comment

by:modemmixer
ID: 24097085
Just to set the record straight ...

1. All Data was been successfully recovered PRIOR to using Spinrite, by slaving drive to my bench system (but not before the following steps were taken first).
2. Yes, the drive eventually tested had experienced its primary (OS booting) partition becoming full while still operable.
3. Yes, I did replace 2 x 1gb DR2 original modules with new 2 x 2gb DDR2 modules prior to space cleaning.
4. Yes, I recovered space by moving files found stored by Realplayer on main partition to ext USB HD.
5. AVG discovered files on ext HD infected by trojan as well as in 4 system restores.
6. Yes, I turned off system restores to effectively remove the 4 infected restore files (as advised).
7. Yes, I deleted infected files on ext HD prior to turning off system restore.
8. Yes, it was THEN that the OS began showing IE, WE, MP, etc errors requiring restarts of these apps.
9. Yes, thought about system restore, but of course had no ability to do so, having turned feature off.
10. Yes, with new RAM still in place, the notebook eventually displayed BSoDs on 3 seperate reboots.
11. Around this time, the system bagan to complain as it tried to reboot into the OS that a startup recovery needed to be performed - attempted this, but system was unable to complete - no error code.
12. Attempted <Alt-F10> Acer recovery, went 30% then gave Restore failed, reason 0xd00000d.
13. Yes, replaced new RAM with original to no avail - decided help was needed from my bench system.
14. Yes, slaved notebook's SATA drive to Promise SATA/IDE controller with exisitng 200gb SATA drive, however booting drive is an 80gb IDE not attached to the Promise controller, but to that system's native onboard IDE controller.  Win XP is the booting OS on the bench.
15. Yes, could still see all data (except data in Acer's recovery partition, hidden, possibly non-standard format - data was already copied to ext USB HD much before this step.
16. Rebooted to a booting Spinrite 6.0 CD and ran diags on the slaved drive.
17. While checking this slaved drive, I avoided testing the bench main (IDE) drive - could this have somehow occurred without my intention to do so?
18. Slaved drive's 1st partition (normally 70gb) tested for approx 2 seconds with no Bad or Recovered sectors (strange), 2nd (hidden, 6gb) partition 1 sec with same results (expected), 3rd partition (normally 70gb) tested for 8-10 seconds, same results (expected).
19. Returned tested slaved drive to Acer notebook, attempted boot, no go, tried <Alt-F10> again, same results - at 30% into recovery, procedure stopped, this time gave Restore failed, reason 0xc00000e9.
20. Checked DT's bios settings, intermittently recognizes Maxtor, then shows "none" next reboot.

My intention was to slave drive to bench to see if it would be a good candidate for an OS re-install from mfg's restore CD/DVD.
My results left me with a bench system whose main drive is now intermittently detectd by its BIOS, but even when detected, reboot results in "boot failed" or system just hangs, no message.

We have other working PCs in the household (I'm on an HP now using Gmail to correspond), but we're down to this and a Compaq desktop, no notebooks (hate that).

Today, the notebook & dirve go to Staples to get a free diagnostic run, when I will explain this to the tech and see where it goes.
I may bring in the bench system as well - will see ...
Ted
0
 

Author Comment

by:modemmixer
ID: 24097169
Btw, I have no ability with these drives and systems to go to any websites recommended since I've now lost the bench system's ability to boot at all.  And understandably, I am loathe to attach the notebook drive to yet another PC and risk losing its ability to operate.

Wish I'd heard from you fellows before I'd run Spinrite from the bench - at least then I'd have been able to reach a web site.  Could install WinXP to the other 200gb SATA I suppose - we'll see ...

First I'll see what the Staples tech says about these drives/systems (late this afternoon), thanks.
Ted
0
 
LVL 1

Expert Comment

by:RecoveryMan
ID: 24100410
Just for clarification Spinright can cause problems case in point with this original issue above. YES Spinright and other tools that read all areas of the drives ARE dangerous to use prior to having a backup of your data because they are not cloning the blocks but just reading them. Speak to any professional data recovery technician and ask them if they use Spinright...the answer would be NO. It is however a good tool to test hard drives to know if they are clean of bad areas prior to using them. Adding an area to my site soon of the pro's and conn's of using the the main retail software out there. If you compare retail software side by side over many recovery sceneros over many years only then will you know which are good for what specific task.
Back to the topic, not sure if a Staples Tech is going to help except run another scan on the drive, not recommended.  I would take the advice here and slave it in to another computer and run a data recovery tool to scan for data like getdatback (runtime.org) or FileScavenger or R-Studio...all have try first buy later options. If that fails contact a professional data recovery tech.
RecoveryMan
0
 

Author Comment

by:modemmixer
ID: 24100557
Recoveryman,

Please read my first point (as above, repeated here) ...
1. All Data was been successfully recovered PRIOR to using Spinrite, by slaving drive to my bench system (but not before the following steps were taken first).

Thus there is no concern for the data, only for the drive's ability to be used further for an OS (preferably what came with the Acer notebook, i.e. Vista, though Win XP would be OK, if no cost involved).

Also a concern for what happened to the bench system's main drive - seems to have taken a hit somehow, as the BIOS only sees the drive intermittently, and even then cannot boot from it.

So, there are 2 issues, one caused before Spinrite was involved, the other after.

That where it becomes perplexing <sigh>.
Ted
0
 

Author Comment

by:modemmixer
ID: 24100574
Sorry - 1. above should read ...
1. All Data had been successfully recovered PRIOR to using Spinrite, by slaving drive to my bench system (but not before the following steps were taken first).
Ted
0
 
LVL 91

Accepted Solution

by:
nobus earned 350 total points
ID: 24104509
can you boot from cd?  if not, read lower part
download ubcd, and run ram and disk tests : http://www.ultimatebootcd.com/
then we can start with good basics

Here my troubleshooting procedure :
clean the system from dust, then  test with the minimum setup - disconnect also all peripherals and network cables :
motherboard + cpu + 1 ram stick, video card, power supply
verify that the 4-pin cpu Aux power plug is connected
on boot, do you have a display?
if NO it is one of the connected, swap ram, Power supply, video card or monitor - leaving only motherboard and cpu
if Yes, add devices till the problem shows

you can also check the motherboard for bad capacitors as shown here :   www.badcaps.net
0
 

Author Closing Comment

by:modemmixer
ID: 31568414
Thanks to NAK321 (100 pts) for suggesting trying the disk tests with Spinrite with the SATA drive back in the notebook - essentially this drive simply lost its OS bearings - a reinstall resolved the SATA drive's dilemna.

Thanks to nobus for suggesting stripping down to the bare essential components, then adding others one by one until saturation is either reached (then back off with that item) or if not reached, add no more.
This is essentially what the Staples fellow suggested after first testing my notebook's SATA drive (installed into the notebook) using PC Doctor on a USB key stick.  My bench system (surprisingly) came up first time,
Perhaps removal of the SATA drive being tested at home, then a few reboots caused the BIOS to recover from hardware interrupt addressing fatigue and it self-corrected ... at least it only cost me a bit of time and about a litre of gas (about $0.85)

Thanks to all others for trying - as stated early on, I'd already recovered my data prior to running Spinrite, so thanks for the suggestions to go to various web links to recover data, but was unnecessary - this time.
Ted
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Bellevue, WA, USA; Late December, 1980 "OK, folks, we nailed the IBM contract. We're going to have many meetings like this to discuss features and functions...and how to move from 86-DOS, the CP/M clone we just purchased, to our baby, MS-DOS. Thi…
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
This video discusses moving either the default database or any database to a new volume.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now