Solved

After creating Network Bridge I can't access 1&1 dedicated server

Posted on 2009-04-07
8
731 Views
Last Modified: 2012-05-06
Hi there,
I have created myself a right pickle. I rent a dedicated server from 1&1 internet and am just starting to go down the virtualization route. I took some bad advice and did the following:

The server has a single network adapter with a single static IP.
I created a new network adapter, "Microsoft Loopback Adapter".
I used the "Bridge Connections" function to create a network bridge between the two.

At tis point I lost all IP connectivity to the server. I logged onto the serial console, ipconfig said that there was just one network adapter which was the "MAC bridge miniport adapter". This had an autoconfig IP address.

I then deleted the following keys from the registry hoping to get rid of the bidge:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Bridge
and
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BridgeMP

Upon reboot ipconfig shows that the bridge has gone however now there are no network adapters listed at all.

Is there a way out of this using only serial console access?

Hope you can help.

OS is Server 2003 R2.
0
Comment
Question by:derbyp
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 10

Expert Comment

by:ashwin_kumar525
ID: 24093066
Do you see the device under:
HKLM\System\CurrentControlSet\Services\TCPIP\Parameters\Interfaces

Does windows detect the Device?

Try re-installing the NIC drivers and reboot the machine.

If it does not help, switch off the server, pull out the power cable and pull out the NIC as well if it not on board. Put them back and try again.
0
 

Author Comment

by:derbyp
ID: 24093197
Hi there,
Thanks for your swift reply. The server is rented from a hosting company so I only have access via a serial console that gives command prompt access only.

There are devices present under HKLM\System\CurrentControlSet\Services\TCPIP\Parameters\Interfaces, however none are shown in ipconfig /all.

I would like to use devcon however there is no way of downloading it as there is no network connectivity.
0
 
LVL 10

Expert Comment

by:ashwin_kumar525
ID: 24093343
If you can go in to BIOS then you may disable the device, delete the key which is under 'Interfaces' for NIC from the safe mode and then enable it back on. Hope fully you will get back the device listed.
0
Transaction Monitoring Vs. Real User Monitoring

Synthetic Transaction Monitoring Vs. Real User Monitoring: When To Use Each Approach? In this article, we will discuss two major monitoring approaches: Synthetic Transaction and Real User Monitoring.

 

Author Comment

by:derbyp
ID: 24093365
I can't get into the bios, will it work if I just delete the key and then reboot?
0
 
LVL 10

Expert Comment

by:ashwin_kumar525
ID: 24093415
Dont do that, you might fall into further problems. copy devcon.exe using a CD or floppy if thats possible

Devcon command line parameters:
http://support.microsoft.com/kb/311272
0
 

Accepted Solution

by:
derbyp earned 0 total points
ID: 24094746
Got it sorted, cheers for the suggestions Ashwin, unfortunately I couldn't copy devcon using a cd as I haven't got phsical access to the server. Very glad you stopped me from deleting more out of the registry as who knows what woud have happened.

Here's what I did in case anyone else finds themselves in the same unsteady boat:

Phoned 1&1 support and got them to boot the machine into the Linux rescue OS. From here there was a network connection so I could ftp devcon.exe over.
Tried mounting the hard drives normally using the mt command but did not have write access.
FTP'd two software packages to the server called "fuse" and "ntfs-3g" then installed them as per this webite:
http://forums.opensuse.org/archives/sf-archives/archives-tips-tricks-tweaks/335102-howto-how-get-full-read-write-support-ntfs.html
Then used the "mt -t ntfs-3g..." command and got write access, from here I could ftp devcon.exe to the c:\ partition and reboot back into windows.
I used "devcon remove =net ...." to remove the bridge connection and to remove the physical network card.
I rebooted the machine and then used "devcon rescan". It found the network card again and even put all the old network settings back.
Bingo. Tired but happy.

0
 
LVL 10

Expert Comment

by:ashwin_kumar525
ID: 24096548
Great job!!! thank you for posting the solution.

good luck.
0

Featured Post

What Is Transaction Monitoring and who needs it?

Synthetic Transaction Monitoring that you need for the day to day, which ensures your business website keeps running optimally, and that there is no downtime to impact your customer experience.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Preface Having the need * to contact many different companies with different infrastructures * do remote maintenance in their network required us to implement a more flexible routing solution. As RAS, PPTP, L2TP and VPN Client connections are no…
INTRODUCTION The purpose of this document is to demonstrate the Installation and configuration of the Data Protection Manager product. Note that this demonstration was prepared on the basis of Windows OS is 2008 R2 and DPM 2010. DATA PROTECTI…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question