Application popup: BbDevMgrDeviceListener: BbDevMgr.exe - Unable To Locate Component : This application has failed to start because RAPI.dll was not found. Re-installing the application may fix this

i got this error message each time i open my bes application , but the application work:

Application popup: BbDevMgrDeviceListener: BbDevMgr.exe - Unable To Locate Component : This application has failed to start because RAPI.dll was not found.
Re-installing the application may fix this problem.
TisgfAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Gary CutriConnect With a Mentor Data & Communications SpecialistCommented:
In this case re-apply SP6 and then MR4.  You can try manually searching for RAPI.dll and attempting to register the file.  As a worst case you can uninstall BES and the reinstall and point back to the existing database and services will resume.
0
 
SappbrostsCommented:
0
 
Gary CutriData & Communications SpecialistCommented:
Hi, what is the exact version of BES that you are running? (e.g. 4.1.6.9)

0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
Gary CutriData & Communications SpecialistCommented:
If you aren't running the latest service pack (SP6) just install it over your current BES and it will correct this issue. As a FYI the third point in the version number is the service pack level e.g. 4.1.4.15 = 4.1 with SP4, 4.1.6.9 = 4.1 with SP6
0
 
TisgfAuthor Commented:
i got version 4.1.6 MR4 (bundle 105)

ithink this is the last update
0
 
TisgfAuthor Commented:
i try to find rapi.dll, only found mprapi.dll

and try to reinstall sp6 and mr4 ...

same problem...

about the uninstall, not sure about that one...

any other suggest
0
 
SappbrostsCommented:
make sure you're not out of licenses on the server
0
 
TisgfAuthor Commented:
3 licences left..... so no im ok with that
0
 
Gary CutriData & Communications SpecialistCommented:
Uninstalling is not as scary as it sounds.  All the user data, licensing, configuration is stored in the database which isn't removed when you uninstall BES.  Normally when I perform the process I also delete the BESadmin profile from the server (i.e. c:\Documents and Settings\BESadmin).
0
 
TisgfAuthor Commented:
ok, will try this weeken,after a backup  and let you know
0
 
NemskinatorCommented:
I am having the same issue with BES5.0 - is this associated with active sync or BES application only?
I only found mprapi.dll as well in system32
Could this error come up simply due to license count? thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.