?
Solved

Cannot mount ntfs with freenas

Posted on 2009-04-08
4
Medium Priority
?
4,824 Views
Last Modified: 2013-11-22
I recently turned to freenas and I have everything set up (windows file sharing, ftp all that good stuff).  I used the file system ufs for this for my first time.  Now after I have formatted the hard drive to NTFS, it will not mount the partition, da1s1.  The reason for this is just in case the hardware fails, I will still be able to use the hard drive with read/write ability with windows.  Does anybody know how to mount a hard drive with file system NTFS in freeNAS?
0
Comment
Question by:htn5ca
  • 2
4 Comments
 
LVL 23

Accepted Solution

by:
ComputerTechie earned 500 total points
ID: 24101126
Normally, your NTFS partitions will be read only. There are a couple of R/W options, but these are beta drivers that shouldn't really be used for day-to-day purposes. Your best option would be to trow the EXT3 drivers at WinXP and convert your drives one at a time.
CT

0
 

Author Comment

by:htn5ca
ID: 24102264
Okay that sounds like a plan.  Just to be clear: I will format the hard drives in EXT3 and if I want I can swap the hard drive to my windows xp and it will still be able to read/write (with the EXT3 drivers loaded of course).
0
 
LVL 35

Expert Comment

by:torimar
ID: 24121116
ComputerTechie,
your comment is a literal copy/paste from the second post of this forum thread: http://forums.whirlpool.net.au/forum-replies-archive.cfm/530058.html
but you do not list your source, and claim the text to be yours.

This is a) a potential violation of someone's copyright which could get Experts-Exchange into trouble; b) not very helpful at all for the asker here, because the quoted text is more than 2 years old.
Since then, FreeNAS, BSD and Linux have changed considerably, and so has the read/write access for Ntfs volumes.

htn5ca,
I am no FreeNAS expert, but I think it will run the ntfs-3g driver just like most contemporary linux and unix distributions do.
To mount a ntfs volume with this driver, use the following command:
mount -t ntfs-3g _volume_ /mount_point

For more info, please refer to the ntfs-3g manual:
http://www.ntfs-3g.org/manual.html
0
 
LVL 23

Expert Comment

by:ComputerTechie
ID: 24208207
I did forget to post the link and will make sure to include it in future posting. It was my mistake.

CT
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Dropbox has a relatively new feature called Smart Sync.  This feature allows Dropbox Professional (not plus) and Dropbox Business (if enabled) users to store information in Dropbox WITHOUT storing any files on their computer.
Office 365 has multiple features and services which are specially designed to help businesses to reduce their dependence on on-premises IT resources. It also offers great flexibility and enhanced security. But like any other data, Office 365 mailbo…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Suggested Courses

600 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question