?
Solved

How do you adjust screen saver timeout and "password protect on resume" on the GUI-free Windows Server Core 2008?

Posted on 2009-04-08
2
Medium Priority
?
693 Views
Last Modified: 2012-05-06
Normally in XP or Server2003, I'd either go into control panel and adjust the display settings, or I'd run DESK.CPL (or desktop.cpl in 2000 or 98 or whatever).

However all desk.cpl does in 2008 and Vista is give you screen resolutions. The only CPL files I found were INTL and TIMEDATE. Since you don't have control panel or "Personalize" in the command-prompt-only Server Core, how do you adjust those settings?

I'm training on it right now and am running 2008 on a VM/Virtual PC, but it keeps going to screensaver and asking me to log in each time. If it was a production server or connected to the internet I would understand the security risk but neither of those conditions are being met.
0
Comment
Question by:johngerity
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 8

Accepted Solution

by:
joefreedom earned 1000 total points
ID: 24102115
Check out this link:
http://redmondmag.com/columns/article.asp?editorialsid=3061

"By default, the screensaver on a Windows Server Core computer locks the screen after 600 seconds, or 10 minutes. If this doesn't suit you, use one of the few GUI tools included with Server Core, the Registry Editor. To start it, type regedit at the command prompt, then edit any of the following registry keys: 
 
HKEY_CURRENT_USER\Control Panel\Desktop\ScreenSaveActive 
(Change this from 1 to 0 to disable the screensaver.) 
 
HKEY_CURRENT_USER\Control Panel\Desktop\SCRNSAVE.EXE 
(Change this from logon.scr to scrn save.scr to switch from the Windows logo screensaver to the blank screen version.) 
 
HKEY_CURRENT_USER\Control Panel\Desktop\ScreenSaverIsSecure 
(Change the value from 1 to 0 if you don't want Windows to prompt you for credentials when waking the server.) 
 
HKEY_CURRENT_USER\Control Panel\Desktop\ScreenSaveTimeOut 
(Edit this value to change the timeout from its default value of 600 seconds.) "
 
 
Excerpt from link:

Open in new window

0
 

Author Closing Comment

by:johngerity
ID: 31568280
oh DUH! Registry Editor! Why didn't I think of that? I tested it and it worked. I logged off and on first so I can't say for sure if the changes were effective immediately but that's hardly an issue.

Thanks!
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Redirected folders in a windows domain can be quite useful for a number of reasons, one of them being that with redirected application data, you can give users more seamless experience when logging into different workstations.  For example, if a use…
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question