Solved

Passive/Active FTP

Posted on 2009-04-08
3
1,693 Views
Last Modified: 2013-12-02
Different FTP clients have different results when connecting to my FTP server.  DOS and WS_FTP always connect successfully.  IE, Firefox and Windows Explorer don't.

1)  What is the reason for my issue above?
2)  How can I tell if I'm in active or passive mode with these clients (DOS, IE, Firefox, Windows Explorer)?
0
Comment
Question by:Whah
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 3

Expert Comment

by:mikey1h
ID: 24102744
usually, web browsers try to log in with Anonymous access.  If this is disabled on your server, they wont be able to connect.    you can either enable anonymous access on the server, or disable login anonymously in the browsers settings
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 24103718
do you have a firewall in front of your server? Do you allow ports 20 and 21 TCP in that firewall?
0
 
LVL 2

Accepted Solution

by:
TheChemic earned 500 total points
ID: 24112523
You're getting this problem because web browsers use FTP Passive mode by default.  FTP clients use Active mode by default and then fall back to passive mode if active mode fails.  At first glance I would say that passive mode is not working.  Why not?  This could be due to numerous factors.  The most likely scenario is that you're behind a router and you have not properly configured passive mode in the FTP server and forwarded the appropriate passive port range in your router.

If this is not the case, please provide more detailed information about your network configuration.

If your FTP server (and router, if you have one) is properly configured to use passive mode then you wont have problems with any type of connection.

Q: How can I tell if I'm in active or passive mode with these clients (DOS, IE, Firefox, Windows Explorer)?
A: Review your FTP server logs.  You will see where the server tells the client to enter passive mode because active mode failed.

If you are behind a router then you will need to enable, and properly configure passive mode in your FTP server setup.
0

Featured Post

Why You Need a DevOps Toolchain

IT needs to deliver services with more agility and velocity. IT must roll out application features and innovations faster to keep up with customer demands, which is where a DevOps toolchain steps in. View the infographic to see why you need a DevOps toolchain.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello, As I have seen there a lot of requests regarding monitoring and reporting for exchange 2007 / 2010 / 2013 I have decided to post some thoughts together and link to articles that have helped me. Of course a lot of information you can get…
Determining the an SCCM package name from the Package ID
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question