• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 568
  • Last Modified:

How to set up internet connection to virtual machine on Windows Server 2008?

I am running Windows Server 2008 Enterprise x64 and have installed a virtual machine running Windows XP x64.  My Windows virtual machine cannot detect any network adapters for whatever reason and therefore cannot connect to the internet.  How do I set it up so that the virtual machine can access the internet?

0
kayhustle
Asked:
kayhustle
3 Solutions
 
kumarnirmalCommented:
Have you installed Windows XP Professional x64 with Service Pack 2 ?

Supported Guest OS for Hyper-V - http://www.microsoft.com/windowsserver2008/en/us/hyperv-supported-guest-os.aspx
0
 
Darius GhassemCommented:
Go into the settings of the VM then add a Legacy Network Adapter to the VM. This should give you access to the network. Also, make sure you install the integration components. Go to Action then select install integration components.
0
 
kayhustleAuthor Commented:
I dont have service pack 2 installed.  I'm guessing I have to download it, burn it to a disk then mount the disk on the vm and install?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
DPOTTS01Commented:
Since you are running Windows Server 2008 x64, I'm assuming that you are running Hyper-V.  You will need to be running service pack 2 or later on the XP VM.   On the settings for the VM is there anything listed in the Ethernet Port?  If there isn't then you can use the Add Hardware option at the top of the list to add a Network Adapter.  You will have to shutdown the VM first.  After you add the network adapter you can restart the VM and you should be able to setup the network connection the same as on as physical device.
0
 
kayhustleAuthor Commented:
Ok I have it recognizing the network adapter, but that adapter doesn't have access to the internet, or even to my own network.  I have it conected to the VLAN but that doesn't seem to do anything
0
 
kayhustleAuthor Commented:
I got it working, thanks
0
 
DPOTTS01Commented:
1.  Have you mounted the Integrated Services setup disk from the Action menu and ran the install for the Integration services?

2.  On the settings page for the VM NIC do you have the "Enable Virtual LAN identification" checked if you do uncheck the the option and restart the VM.  You will have to shutdown the VM to make this change.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now