Solved

Issue with DropCap in first paragraph of Chapter in Adobe InDesign CS4

Posted on 2009-04-08
12
1,066 Views
Last Modified: 2013-12-02
I am attaching a PNG file of the problem.  I use a Paragraph Style called Chapter Beginning. I has an embedded Character Style to do the Drop Char of the first char in this style. As you can see the "P" runs into the word "Gospel" below.

I can't seem to remedy this problem. I am happy with leading at 18pt (font is 12pt for normal text) This drop char is 30pt.

TIA!
issue.PNG
0
Comment
Question by:SStory
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 6

Expert Comment

by:casinnola
ID: 24106719
Go into your Drop Caps paragraph style and put a check mark next to "scale for descenders." Without checking that box, InDesign is assuming that a capital letter does not have a descender. Once you check that box, you should get the alignment you want.
0
 
LVL 6

Expert Comment

by:casinnola
ID: 24106792
If you're still getting a collision after you do this, there are a couple other options we could explore.
 
0
 
LVL 25

Author Comment

by:SStory
ID: 24112631
casinnola,

I have that checked.. See attached screenshot.
issue-shot2.PNG
0
Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

 
LVL 25

Author Comment

by:SStory
ID: 24112635
Am I doing it wrong by using a Nested Style?  My Drop char is of a different font and size.  I was able to get what I wanted by doing the above, but of course it is colliding now on the P. When it was and "I" it didn't collide.
0
 
LVL 25

Author Comment

by:SStory
ID: 24112665
If I choose the Indents and spacing-> Align to Grid -> All Lines
it seems to fix the P issue (I don't know about other letters...but then it seems to change the leading to be larger than 18pt...more like double spaced. The paragraph font is 12pt...I wanted 18pt leading which looks like 1.5 line spacing to me. I guess 24pt would produce double line spacing...

Any thoughts?
0
 
LVL 6

Expert Comment

by:casinnola
ID: 24116039
Even though they're in the same panel of the Paragraph Styles Options dialog box, Nested Styles and Drop Caps are two different things. So in effect, you are trying to accomplish the same thing by using two different methods.

Try this: First, go into the definition of your Chapter First Letter character style and delete any values that you've put for size, leading, etc. The only thing you want the Character Style to control is the font family. Next, go into your Paragraph Style, go to the Drop Caps panel, and delete the nested style by highlighting its name and hitting "delete". Then, go up to your Drop Cap definition, and where it says "Character Style", pull that down and choose your Chapter First Letter character style. That should do it.

Let me know if that doesn't work.

chapterfirstletter.jpg
0
 
LVL 25

Author Comment

by:SStory
ID: 24119565
Well that made it different, but now the letter looks small and it is too far down. I liked it just the way it was...I just don't want it to run into things below. Any thoughts as to what to do now?
issue-shot3.PNG
0
 
LVL 6

Expert Comment

by:casinnola
ID: 24120766
Make sure you undo Align All Lines to Grid. Then try putting a size in your Character Style... start with 24 and see how that looks.

Just make sure you keep the "Scale for Descenders" option checked in your Paragraph Style or you'll end up with the collision again.
0
 
LVL 6

Accepted Solution

by:
casinnola earned 500 total points
ID: 24120788
After you do this, if your letter is now big enough but you're still getting the collision, go into your character style, and under "Advanced Character Formats", add a positive baseline shift.

To watch your changes in real time, make sure you have "Preview" checked in the bottom left of the Character Style dialog box. Then click in the Baseline Shift space and use the up and down arrows to increase/decrease the shift. As long as the Character Style dialog box isn't blocking your view, you will be able to watch the letter go up and down. (You can do this with the Size value, also.)
0
 
LVL 6

Expert Comment

by:casinnola
ID: 24120804
The only other problem that could happen is: you've tweaked the settings in your character style so that the P displays perfectly. But then the next chapter begins with, say, the letter A... and in this typeface, "A" doesn't have a descender (or its descender is not as long,  twice as long, etc.). So either you're back to having a collision... or the A looks ridiculous because it's sitting too high.

If that happens, you'll have to manually adjust the Baseline Shift on each drop capped letter in each chapter. Doing this will create an override to the Paragraph Style.

To manually adjust the Baseline Shift, highlight just the drop capped letter, then open your Character panel (Ctrl-T or Cmd-T on a Mac) and increase or decrease the Baseline Shift as needed. (Again, click in the box and use your up/down arrow keys so you can watch the letter go up and down.)
0
 
LVL 25

Author Closing Comment

by:SStory
ID: 31568359
I think by playing with these values I am able to get it.  With this FlowerCaps font, the P has a big descender, but the I (that i as in after h) doesn't and leaves a skip after it, but I suppose that is normal.  This has been a bear to figure out. Thanks so much for your help! I am a newbie with InDesign.
0
 
LVL 25

Author Comment

by:SStory
ID: 24122614
OK. Are you saying adjust baseline shift in the paragraph style of the FirstLetter style? If I do so how does it not affect the style in all other places?
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When designing and editing page layouts in inDesign, fonts can become messy without the help of paragraph styles. How many times have you re-read through a document you created and noticed a sentence in the middle of a paragraph happened to be a dif…
The ability to automatically add page numbers to a layout is one of the many easy, convenient features InDesign has to offer. There are many reasons why you would want to automatically generate page numbers in your next project, so whether it’s a ma…
Learn how to automatically add page numbers in your next InDesign project. This can be very helpful in multi-page books and magazines that you are designing. Make sure your Pages window visible.:  In the document you wish to add page numbers to. Act…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question