Solved

My wubi ubuntu stopped booting

Posted on 2009-04-08
25
1,883 Views
Last Modified: 2013-11-15
I did install ubuntu 8.10 via wubi on Vista 64 home premium dell laptop
It was working fine till yesterday.
now it's not booting giving following error

GRUB4DOS 0.4.4 2008-10-27 Memory 625K/ 3027M CodeEnd: 0x42910

and then gives GRUB> prompt none of options with ESC work

How do I recover from this ? Can I read /recover ubuntu files from vista ?

The solutions provided for very similar problem elswhere don't work
0
Comment
Question by:qvts
  • 13
  • 11
25 Comments
 
LVL 35

Expert Comment

by:torimar
ID: 24103854
Try this tool to access your Ubuntu files: http://www.chrysocome.net/explore2fs

Run Explore2fs, select File > Open image file... and point it to your Wubi image file.
0
 
LVL 3

Expert Comment

by:GarthSnyder
ID: 24103860
It's hard tell what the root problem might be without more investigation, but yes, you can recover your files using Vista. Your Ubuntu disk or partition is probably formatted with the ext2fs or ext3fs filesystem, so you'll need to install this filesystem driver under Vista to make it understand the Ubuntu disk. (ext3 is practically identical to ext2 in this context, so don't worry about the distinction or which one it is.)

With that driver installed, just follow the instructions to mount the disk under a Vista drive letter and copy off any files that you need.
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 500 total points
ID: 24103875
ps:
The image file or files will be in the \ubuntu\disks folder.
0
 

Author Comment

by:qvts
ID: 24103882
I did install explore2fs but where to find ex2 or img file ?
0
 

Author Comment

by:qvts
ID: 24103903
c:\ubuntu does not have disks folder
0
 

Author Comment

by:qvts
ID: 24103907
Also as this is wubi installation there is no partition
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 500 total points
ID: 24103937
"The relevant Wubi files you need to access are located under C:\ubuntu\disks\"

This is a quote from the WubiGuide: https://wiki.ubuntu.com/WubiGuide. So theoretically, there needs to be a \disks folder.
Anyway, those image files must be relatively large, a couple of gigabytes. Check your \ubuntu folder and subfolders for such large files, or for files with the extension ".disk".

Also, make sure that you are able to see hidden files, as these may be hidden files and folders.
0
 

Author Comment

by:qvts
ID: 24104061
found
c:\ubuntu\swap.disk(953MB)  and root.diak(13 GB)

now how to read them ?
or use those o restore ubuntu booting
0
 

Author Comment

by:qvts
ID: 24104074
There is also disks folder but cannot open it
0
 

Author Comment

by:qvts
ID: 24104102
it says disks folder is empty
0
 
LVL 35

Expert Comment

by:torimar
ID: 24104107
Try pointing Explore2fs to the root.disk file.
This should give you access to the contents of your Ubuntu drive. Use it to recover important files and data.
Also, please check out the file /boot/grub/menu.lst; copy/paste its contents here.

Accessing the files will not restore Ubuntu, however.
Many people report to have had the problem that you have now, and nobody seems to have solved it without a re-installation. The only possible cause that the Wubi documentation lists for this issue is file system errors caused by improper shutdown of Ubuntu.
Since Wubi-Ubuntu resides on a Windows drive, this has to be repaired from within Windows by running "chkdsk /r"; did you already try that?
0
 
LVL 35

Expert Comment

by:torimar
ID: 24104111
Next to the contents of /boot/grub/menu.lst please also list the contents of c:\boot.ini here.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:qvts
ID: 24104163
how to point explore2fs
0
 
LVL 35

Expert Comment

by:torimar
ID: 24104222
File > Open image file; select file type "all files".
0
 

Author Comment

by:qvts
ID: 24106753
cannot read menu.lst with explore2fs
also root.disk and swap.disk disapperaed
0
 
LVL 35

Expert Comment

by:torimar
ID: 24106896
The menu.lst file will be inside root.disk. Or is there a separate menu.lst file listed? In this case, you will be able to open it in Notepad or any text editor.

What does it mean that the .disk files "disappeared"??
They don't disappear by themselves. Did you run chkdsk, and afterwards they were no longer there?
0
 

Author Comment

by:qvts
ID: 24108275
Ran chkdsk
Still cannot find .disk files
the c:\ubuntu\menu.lst file has:
debug off
hiddenmenu
default 0
timeout 0
fallback 1

title find /ubuntu/disks/boot/grub/menu.lst
      find --set-root --ignore-floppies /ubuntu/disks/boot/grub/menu.lst
      configfile /ubuntu/disks/boot/grub/menu.lst

title find /ubuntu/install/boot/grub/menu.lst
      fallback 2
      find --set-root --ignore-floppies /ubuntu/install/boot/grub/menu.lst
      configfile /ubuntu/install/boot/grub/menu.lst

title find /menu.lst
      fallback 3
      find --set-root --ignore-floppies /menu.lst
      configfile /menu.lst

title find /boot/grub/menu.lst
      fallback 4
      find --set-root --ignore-floppies /boot/grub/menu.lst
      configfile /boot/grub/menu.lst

title find /grub/menu.lst
      fallback 5
      find --set-root --ignore-floppies /grub/menu.lst
      configfile /grub/menu.lst

title commandline
      commandline

title reboot
      reboot

title halt
      halt


0
 
LVL 35

Accepted Solution

by:
torimar earned 500 total points
ID: 24108585
If the .disk files disappeared after running chkdsk, this means that they were damaged. Which would most likely have happened in an improper shutdown of Ubuntu (crash, cold reboot etc.).
A real Ubuntu installation is much more tolerant here than a Wubi install, it seems. You now have to rely on Windows to have repaired the files - which it may or may not have done.

Look for folders called "FOUND.0000", "FOUND.0001" etc. (They could be hidden). Check if you find the lost .disk files inside them. If not, look for files that have the size those .disk files had; rename them and move them to the place where the disk files used to be.
Reboot and hope for the best.


That menu.lst you copied here is not the one that boots Ubuntu (which will be on root.disk), it is the fallback menu that you see when Ubuntu cannot be booted.
If you still end up on the "GRUB >" prompt, press ESC. Then you should see that menu. Try each single one of the first 5 options.
If your Ubuntu installation is reparable, and your .disk files are at the correct position, then one of these options should boot Ubuntu.
If none does, I'm afraid your installation might be damaged beyond repair.
0
 

Author Comment

by:qvts
ID: 24108858
no found.0000 or found.0001
nothing in recycle bin
In that case where are these missing 13-14 GB
How can I find it on vista ? sort files by size etc.
Because that much GBs are missing.
0
 
LVL 35

Expert Comment

by:torimar
ID: 24110266
0
 

Author Comment

by:qvts
ID: 24111651
I ran ubuntu live cd and found found.000 and under it root.disk and swap.disk

now how do I read those I tried expore2fs before bu could not get it to work

Also I found menu.lst there
it's as follows

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default            0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout            10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title            Windows 95/98/NT/2000
# root            (hd0,0)
# makeactive
# chainloader      +1
#
# title            Linux
# root            (hd0,1)
# kernel      /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=F4DC3C18DC3BD398 loop=/ubuntu/disks/root.disk ro ROOTFLAGS=syncio

## default grub root device
## e.g. groot=(hd0,0)
# groot=()/ubuntu/disks

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title            Ubuntu 8.10, kernel 2.6.27-11-generic
root            ()/ubuntu/disks
kernel            /boot/vmlinuz-2.6.27-11-generic root=UUID=F4DC3C18DC3BD398 loop=/ubuntu/disks/root.disk ro ROOTFLAGS=syncio quiet splash
initrd            /boot/initrd.img-2.6.27-11-generic

title            Ubuntu 8.10, kernel 2.6.27-11-generic (recovery mode)
root            ()/ubuntu/disks
kernel            /boot/vmlinuz-2.6.27-11-generic root=UUID=F4DC3C18DC3BD398 loop=/ubuntu/disks/root.disk ro ROOTFLAGS=syncio  single
initrd            /boot/initrd.img-2.6.27-11-generic

title            Ubuntu 8.10, kernel 2.6.27-7-generic
root            ()/ubuntu/disks
kernel            /boot/vmlinuz-2.6.27-7-generic root=UUID=F4DC3C18DC3BD398 loop=/ubuntu/disks/root.disk ro ROOTFLAGS=syncio quiet splash
initrd            /boot/initrd.img-2.6.27-7-generic

title            Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode)
root            ()/ubuntu/disks
kernel            /boot/vmlinuz-2.6.27-7-generic root=UUID=F4DC3C18DC3BD398 loop=/ubuntu/disks/root.disk ro ROOTFLAGS=syncio  single
initrd            /boot/initrd.img-2.6.27-7-generic

title            Ubuntu 8.10, memtest86+
root            ()/ubuntu/disks
kernel            /boot/memtest86+.bin

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title            Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda3
title            Windows Vista/Longhorn (loader)
root            (hd0,2)
savedefault
chainloader      +1
0
 

Author Comment

by:qvts
ID: 24111942
I created disks directory under c:\ubuntu and moved root.disk and swap.disk there and restarted ubunt
and it booted fine.
It's working now.
Thanks.
0
 
LVL 35

Expert Comment

by:torimar
ID: 24113134
Glad to hear it worked. That's really good news.
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 500 total points
ID: 24121054
qvts,
if your Ubuntu works fine now and the problem was solved, is there a reason why you don't close the question properly, by selecting one or more answers as solution?

If this is because you are new to Experts-Exchange, and you don't yet know the way it works, this page might help you:
http://www.experts-exchange.com/help.jsp
0
 

Author Closing Comment

by:qvts
ID: 31568366
I found elsewhere on ubuntu forums to create and use live-CD, I credit 20% to it because I was not able to find found.000 etc in vista. The last commet given 100 points for this 20%
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Users are often faced with high disk consumption without really knowing where the largest amount of data resides. Disk Usage Analyzer (aka Baobab) is is a graphical, menu-driven application to analyse disk usage in any Gnome environment and can e…
Are you sitting there reading this and wondering how to get started with Linux? It almost seems like picking the right Linux distribution is about like picking the right college or buying a new car if you read some of the article out there. Relax… l…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now