Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2007 Upgrade to SP1 Failed

Posted on 2009-04-09
15
Medium Priority
?
366 Views
Last Modified: 2012-05-06
I was upgrading Exchange 2007 RTM to SP1, as it failed in the Hub Transport Role section with the following message:

When the AuthMechanism parameter on a Receive connector is set to the value ExchangeServer, you must set the FQDN parameter on teh Receive connector to one of the following values: the FQDN of the transport server "martini.bcr.loal", the NetBIOS name of the transport server "MARTINI", or $null.

Please help, I am unfamiliar with this.
ExchangeSp1.jpg
0
Comment
Question by:pzozulka
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 3
  • +1
15 Comments
 
LVL 3

Expert Comment

by:tompi68
ID: 24104995
try to run the sp1 Update in an command line and NOT in the gui
setup.com /mode:upgrade
that should work
0
 
LVL 3

Expert Comment

by:tompi68
ID: 24105020
0
 
LVL 8

Author Comment

by:pzozulka
ID: 24105078
I tried running it from command prompt as well but it fails. You second advice sounds very good. I have only one question. The FQDN is currently set to mail.domain.com. The internal FQDN is totally different, as you can see in the attached picture it is "martini.bcr.local".

I am afraid that if I change that, it is somehow tied into our SSL certificates, and that might cause problems.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 13

Expert Comment

by:FearNoMore
ID: 24105115
You can change mail.domain.com to the FQDN of the server martini.bcr.local and then once SP1 upgrade completes....then go ahead and change it back to mail.domain.com
0
 
LVL 8

Author Comment

by:pzozulka
ID: 24105119
Tried that, and I get the same exact error message seen above.
0
 
LVL 13

Assisted Solution

by:FearNoMore
FearNoMore earned 200 total points
ID: 24105289
Uncheck the Exchange Server Authentication from the Authentication tab of the
Receive Connector and try the same steps mentioned above
0
 
LVL 65

Accepted Solution

by:
Mestha earned 1800 total points
ID: 24105290
You need to change the FQDN on your receive connector to one of the values mentioned, then restart the transport service.
You will NOT be able to change it back as the only accepted values are those listed - the NETBIOS name, the FQDN or blank.

Simon.
0
 
LVL 3

Expert Comment

by:tompi68
ID: 24106444
Did you try the update via command shell?
0
 
LVL 8

Author Comment

by:pzozulka
ID: 24107938
Yes, I tried updating via command shell. Same thing.

FearNoMore: "Uncheck the Exchange Server Authentication from the Authentication tab of the
Receive Connector".

*************  What does this option do? *******

This kind of fixed it. I didnt have to change the FQDN part, but now our Blackberry handhelds can no longer send emails, but still can receive emails. Our Blackberry Enterprise Server is on a different box.

Mestha: I will try to change it to one of the suggestions "martini.bcr.local", and will enable Exchange Server Authentication for now. **********What does this options do?***********
0
 
LVL 8

Author Comment

by:pzozulka
ID: 24107963
Mestha: Also, if I change this to the suggested option of "martinit.bcr.local" how will this effect our SSL certificate?
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24108405
Has nothing to do with the certificate, and has nothing to do with the authentication settings. Purely and simply down to the fact that the receive connectors can only have one of the three names on them.

I blogged on this problem when SP1 was released in November 2007:
http://blog.sembee.co.uk/archive/2007/11/30/63.aspx

Simon.
0
 
LVL 8

Author Comment

by:pzozulka
ID: 24108909
I will go through your blog right now. I have one more question. When I was playing around with the settings of the Receive Connectors I don't remember the original settings of the "Exchange Server Authentication" option.

I have 2 connectors:
Martini (Port 25)
Martini (Port 587) Secure

Is the "Exchange Server Authentication" option suppose to be checked for both of them? I think it was originally checked for only Martini (Port 25). This was very late at night yesterday, and I don' t remember the original settings. How is this set by default?
0
 
LVL 8

Author Comment

by:pzozulka
ID: 24108943
"Why would you change this? When you telnet to the server it is the receive connector that is answering the call and you may want to change it so that the public name of the server is answered instead."

This is a quote from your blog. I wanted to know what you mean by "you may want to change it so the public name of the server is answered instead"???

This is what it used to be. We had it set to the public name of "mail.domain.com" and that didnt work.
0
 
LVL 65

Expert Comment

by:Mestha
ID: 24109161
Having it set to the public name is why people are changing it, but doing so makes no difference to email delivery. The only one that is of any concern is the Send connector, because that is how your server appears to the internet. For receiving email the remote site doesn't care how your server announces itself.

Simon.
0
 
LVL 8

Author Closing Comment

by:pzozulka
ID: 31568411
Mestha's way solved to problem.
FearNoMore: Your way seemed to have worked for us as well in post ID: 24105289. Unchecking the Exchange Server Authentication also fixed the problem without having to change the FQDN. I guess this would work for those that only have 1 Exchange Server in their environment, and no Exchange Server to Exchange Server authentication would be required. We have more than 1, we still have the old Exchange 2003 that we did not fully move out yet. It still holds the Blackberry Enterprise Server on it. When we unchecked "Exchange Server Authentication" we could no longer send out emails via Blackberries.
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question