Folder Redirection

I have been reconfiguring group policy folder redirection settings and the folder redirection is now working fine, but I am having trouble accessing the folders whilst the user is working offline.

I have accessed the users profile folder and I have changed the caching settings to create a copy so that it is available offline. I have also ensured that the user has full control over their profile. Even though I have performed these changes the folders are still not available offline

Does anyone have suggestions that might resolve this problem? I
LVL 1
MartynLawsonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PeteJThomasCommented:
So you've configured folder redirection (for my Docs or users home drive?) through a GPO.

Have you configured offline files through group policy as well? Or are you trying to do this manually for 1 particular user?

When you initially configured offline files, you should see it synchronise to create the cached copy on the users PC/Laptop. Did you see this?
PeteJThomasCommented:
From the users laptop/PC, if you navigate to the redirected folder (I'll just assume it's My Docs for now), and right-click it, you should see similar to the screenshot I've attached. In most cases the option will be 'greyed out' but still must be ticked.

Can you confirm if this is the case?
Offline-Example.JPG
MartynLawsonAuthor Commented:
I have configured folder redirection for Users My documents. The actual settings that I have used are the Basic folder redirection option and the target is the users home directory.

I then accessed the server that the profile is stored on and atempted to manually set the caching for the profile folder. In then checked the Event logs and it is showing an error for SceCli Event 1202 (0x534: No mapping between account names and security IDs was done.)

Although this test would prove that I could turn the offline caching opiton on for one user profile I do not want to have to change this for all users profiles as this would take some time. Is there a setting within Group Policy that I can set for caching of the My Douments folder
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

PeteJThomasCommented:
There are many policy settings that relate to the use of offline folders. These are detailed here -

http://technet.microsoft.com/en-us/library/cc759721.aspx

As I understand it, the default setting for offline files behaviour, is that any redirected shell folders should always be made available offline. This setting can be explicitly set, using the "Do not automatically make redirected folders available offline" policy setting (available in User Config > Admin Templates > Network > Offline Files) and in your case should be either 'DISABLED' or 'NOT CONFIGURED'. It may be worth explicitly setting it to disabled. However I would use a test OU etc to ensure you get the desired results.

There are other settings within the same location of the Comp Config of a GPO...

:)

Pete
MartynLawsonAuthor Commented:
Would it be better to configure this under User Config or the Computer Config?

 I have attempted it under the User Config but it does not appear to have worked. I am wondering if this is not working because the actual location of the files that it is trying to make offline is on another domain that is Trusted to the domain that I am trying to make the changes on.

Do you think that I am going to have to make the changes to a GPO on that particular domain?
PeteJThomasCommented:
Neither would be 'better', and both would normally produce different results, except in cases where you're applying the policy to ALL users or ALL computers, in which case the final outcome would probably be the same.

One important difference with certain policy settings, is that the settings available to you under Comp Config and User Config are actually DIFFERENT. Often you have a bunch of settings that you can apply through either, with a few extra settings different between the two. For example, the previously mentioned "Do not automatically make redirected folders available offline" policy setting is only available under User Config.

Perhaps a more detailed explanation of your forest infrastructure would be appropriate at this point -

Are both domains in the same forest?
Are you redirecting users from Domain A's home drives to a file server on Domain B?
You stated that the redirection itself is working properly, but the offline caching is not - Is that still the case?

Any other relevant info on you're forest(s) layout would be helpful.

Cheers!

Pete

MartynLawsonAuthor Commented:
I have done some playing with this and I have come across another problem. In order to explain the problem fully I will give you a quick overview of our setup.

Basically we have three domains, all in different forests. We have a localdomain1.net and localdomain2.com. We then have a new domain that encompasses then enitre company. Users in the two local domains have been given logins for the new domain. but the folder redirection is going to point back to the local domain server and storage area. We also have users that only have an account on the new domain. The users on this domain are the ones that I am having problems with now because it will not redirect the My Document folders. The error message that I am getting when trying to do this is "The security descriptor is not valid". The only difference that I see between redirecting the new domain users and the ones on the older domains is that the users on the old domain are stored on a specific server were the users on the new domain are pointed to a cluster (\\company.com\). If I go to start and run with the location is finds it fine.

Do you have any ideas why this might not be working?
PeteJThomasCommented:
Ok I'm getting a little confused - So does your original problem still stand? Is this issue you just mentioned basically just a standalone issue with folder redirection to your cluster?

It's probably not a good idea to start looking at a new problem at this point unless the 2 problems are directly related, and it would be best to post a new question on EE regarding the redirection to your cluster if that is a separate issue...

It's hard enough trying to get your head around a problem without being able to see it all and experiment for yourself, let alone if we're switching between problems half way through... :)

Pete
MartynLawsonAuthor Commented:
Sorry, my original problem still stands of not being able to get the folders to be available offline. I have amended some of the GPOS settings to no avail. The properites that I have changed so far are 'synchronise all offline files when logging on' and logging off. I have also set 'Do not automatcially make redirected folders available offline' disabled.

Do you have any suggestions pertaining to this issue?
PeteJThomasCommented:
Ok, so now I understand a little more about your domains etc, can you clarify the exact problem?

i.e. which domain are you having this problem with? All or just one?
Are you redirecting users from Domain A's home drives to a file server on Domain B?

If you can explain the exact outcome you want, I can make a suggestion on the next thing to try. :)

Pete
MartynLawsonAuthor Commented:
Basically I am trying to configure the offline files for the users that are working on Domain A, but the profile (Home drive) is stored on a server in another domain (Domain B). I have been doing some experimenting since we last spoken and I think that I am getting close to resolving the issue. I had completely forgotten about the Workstation Configuration GPO's and just expected the config to be in the User GPO's. I believe that I might have isolated the problem. Now its just a case of doing some testing.

Sorry for taking you down the wrong path. Although having said that I wouldn't have been able to resolve the issue without your suggestions :)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PeteJThomasCommented:
No need to apologise, it happens sometimes. :)

Sounds like you may now have the problem in hand, so good luck, and I'm obviously monitoring the question so if you need any advice just post and I'll respond as soon as I can. :)

Pete
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.