Cannot change password in OWA form through ISA 2006

Posted on 2009-04-09
Last Modified: 2012-06-21
Hi Experts,
We are not able to change password through OWA form which is published through ISA 2006.It gives an "Credentials entered are not valid" error.

The configuration of Exchange and ISA is as follows:
In Exchange 2007 Basic Authentication is enabled.
ISA 2006 is installed in a Load Balancing mode.And ISA is installed as a Domain member.
While publishing OWA through ISA we used the authentication as Windows (Active directory).

We also tried to configure LDAP in ISA and changed the authentication of OWA listner in ISA as LDAP(Active Directory).After doing that when we tried to change the password & it gave a "page cannot be displayed-Internal server 500 error".
So we removed LDAP authentication and changed it to Windows (Active Directory) now we get an error which says :"Credentials entered are not valid" error it happens for all the users.

Please help.

Thanks and regards
Question by:pageast
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
LVL 24

Expert Comment

by:Rajith Enchiparambil
ID: 24168208
Are you entering a complex password? If not, try that. Something like Passw0rd1.


Author Comment

ID: 24182030
Thanks for the reply,even the simplest password dosent work.its a genunine problem with ISA 2006 SP1.Previously it was working fine,after we upgraded ISA 2006 to ISA 2006 SP1 in Load Balanced mode it stopped working.
There is a KB which suggests to download the hotfix and then run a script for this "Password change issue in ISA 2006" However there is no hotfix included in this KB,really frustrating.

Please let us know if you get any updates on the same.

Thanks and regards
LVL 24

Expert Comment

by:Rajith Enchiparambil
ID: 24185985
Why don't you use the script in the KB article ?


Accepted Solution

pageast earned 0 total points
ID: 24393119
To run the scriprt we need to download the hotfix first as mentioned in the KB,However i dont see an option to download ny hotfix from this site.


Expert Comment

ID: 25250933
Sorry to see the solution was not posted. To get the Hotfix you must contact Microsof Support it took me 6 hours to fix this issues.

Just a note for anyone who is trying to do this too.

Your Web Listener authenication should be Connect LDAP servers over secure connection is your ISA is a stand alone box. This means you must have a SSL Cert on your domain controler and copied to ISA for it to work. Hope this helps anyone in the future.

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question