Powerbook G-4

Posted on 2009-04-09
Last Modified: 2013-11-24
I apologize in advance but this will probably be a little long b/c I want to try to relay everything I can about my PowerBook G4 problems so you can figure out what's wrong with it.

I bought this G4 PowerBook used several years ago. It's been a good computer, but I did have to replace the hard drive about a year ago.

A month or so ago it started making a little buzzing sound on startup that would last about 15 seconds then go away. I wasn't having any other problems and it wasn't acting erratic in any way so I didn't worry about it.

Then last night I was online and suddenly my wireless mouse quit working. I replaced the battery, reset the mouse, etc. and it still wouldn't work. I tried to do a force quit of my browser and that didn't work so I had to do a hard shut down. When I turned it back on, I heard the dong sound, but the screen was black. I tried to start up from my Drive Genius II CD, my system CD and I also tried starting up in Safe Mode, but it would never come up. I shut it down for about an hour and tried to start up again and this time it came up normally, but within 2 minutes it was frozen again. So I waited until this morning and started up using my Drive Genius CD and it came right up. I started running the hard drive repair mode and within 2 minutes it was locked up again and wouldn't come back up. The keyboard won't work, the mousepad and the wireless mouse won't work and the screen stays black. However, whenever I restart I always hear the dong and it sounds like the hard drive is doing it's job so I'm thinking it probably isn't a hard drive issue - especially since the drive is less than a year old.

Can you tell by the above information what my problem might be? It is about 6 years old so if it is fixable, do you think it is worth fixing?

Thanks a lot!
Question by:Kenniebee
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
LVL 53

Accepted Solution

strung earned 500 total points
ID: 24107068
Try resetting the PMU:

Author Comment

ID: 24107297
You are a genius! Thank you sooooooooo much!

LVL 53

Expert Comment

ID: 24107316
Service with a smile!
Guide to Performance: Optimization & Monitoring

Nowadays, monitoring is a mixture of tools, systems, and codes—making it a very complex process. And with this complexity, comes variables for failure. Get DZone’s new Guide to Performance to learn how to proactively find these variables and solve them before a disruption occurs.


Author Closing Comment

ID: 31568512
You are a genius! Thank you soooooooo much!

Author Comment

ID: 24117162
Hi Strung! Thank you so much for your help yesterday with my Powerbook G4. After resetting the PMU like you told me to, my laptop ran fine for a few hours and then I shut it down thinking everything was great. But last night when I turned it back on the problems started again (black screen, keyboard, wireless mouse, mouse pad wouldn't work). I reset the PMU again like you told me to yesterday and it didn't work that time. I did it about 5 more times and it finally started working again, but only for a few minutes, before it quit again. This went on for a while and then I was unable to get it to come back up at all anymore. I am going to the Apple Store tonight to get a new MacBook Pro 17", but I wonder if all is lost with my Powerbook or if there is anything you can tell me to do to fix it and keep it running. That way I could give it to my daughter. Or maybe you might know exactly what the problem is that is causing it to be so hornery.
: ) Thanks a lot! - Kennie
LVL 53

Expert Comment

ID: 24117204
Sounds like a hardware problem. Might possibly be a bad battery. You could take it to the Apple store with you and see if they will let you swap the battery with one of theirs to see if it makes a difference.

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
How do I properly setup Back to My Mac on an Apple Time Capsule? 5 123
Simple backup program needed in Mac network environment 12 110
Disk Repair Tools 17 186
Macbook Air ports 2 32
How to recover a playlist after moving the music from one location, folder or hard disk, to a new one, folder or disk. Disclaimer I have performed this procedure after moving my music from one hard disk to a second hard disk using Windows XP sp3…
A lot of new and distinct gadgets are making their appearance every other day. The latest gadget that has wooed the attention of all gadget lovers and non gadget lovers alike is the Smartwatch. This tiny gadget is capable of offering live access to …
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question