Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

How do I trunk a Cisco 2950 to a Cisco 3550 switch

Posted on 2009-04-09
10
Medium Priority
?
866 Views
Last Modified: 2012-05-06
I am adding an additional network at my office.  The new network is going to be on a cisco 2950 switch that is connected to a "Layer 3" Cisco  3550 switch.  I have the ports on the 2950 going to the 3550 set as "switchport mode trunk".  On the 3550, I have the port configured with "switchport trunk encapsulation dot1q"  I can't get these two switches to communicate.  Any Ideas?
0
Comment
Question by:Crossroads305
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 10

Expert Comment

by:atlas_shuddered
ID: 24110991
On all ports:

switchport trunk encapsulation dot1q
switchport mode trunk

If I read the above right you have half the answer on each port.

Cheers
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 24111107
Thanks.  On the 2950, the command "switchport mode trunk" works, but "switchport trunk encapsulation dot1q" does not.  It will work on the 3550?
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 24111201
Any other ideas?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 10

Expert Comment

by:atlas_shuddered
ID: 24111296
Sorry - 2950 only supports dot1q so you won't have to run the command on its interface.

Use both commands on the 3550 ports.
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 24111396
Still not working.  My 3550 is a 10 port fiber switch.  I have run the command "switchport trunk encapsulation dot1q" on the 3550 for the port that the 2950 connects to.  I still can't communicate between switches
0
 
LVL 10

Expert Comment

by:atlas_shuddered
ID: 24111505
Can you post a config of both?
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 24111755
First config is the 2950.  Second config is the 3550.  The 2950 connects to int gigabitethernet 0/7 on the 3550.

version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 2950
!
clock timezone est -5
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
switchport mode trunk
!
interface Vlan1
 ip address 10.0.32.2 255.255.240.0
 no ip route-cache
!
ip default-gateway 10.0.32.1
ip http server
!

!
!
end

Cisco 3550

Building configuration...

Current configuration : 3071 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3550
!
no logging console
!
clock timezone EST -5
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
interface GigabitEthernet0/1
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface GigabitEthernet0/3
 no ip address
!
interface GigabitEthernet0/4
 no ip address
!
interface GigabitEthernet0/5
 no ip address
!
interface GigabitEthernet0/6
 no ip address
!
interface GigabitEthernet0/7
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/8
 no ip address
!
interface GigabitEthernet0/9
 no ip address
!
interface GigabitEthernet0/10
 no ip address
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
 no ip address
!
interface Vlan1
no ip addresss
!
interface Vlan2
 no ip address
!
interface Vlan20
 description TEST
 ip address 10.0.32.1 255.255.240.0
!
interface Vlan30
 no ip address

end

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 24112291
Please post the output of a "show int status" for both switches.


0
 
LVL 10

Accepted Solution

by:
atlas_shuddered earned 2000 total points
ID: 24113262
On the 3550:

int gig 0/1
no shut
switchport mode access

int gig 0/7
switchport mode trunk
no shut

int vlan 20
no ip address 10.0.32.1 255.255.240.0

int vlan 1
ip address 10.0.32.1 255.255.240.0
no shut


on 2950

int fast 0/1
no shut
switchport mode access

int gig 0/1
no shut

int gig 0/2
no shut

int vlan 1
no shut


Right now you have your IP's set up in two different vlans so ping is not going to work.  Connect a PC to the access interfaces on each of the switches and test your ping.

0
 
LVL 1

Author Closing Comment

by:Crossroads305
ID: 31568708
Thanks, I can't believe I overlooked that.   I put them both in the same vlan and was then able to pass traffic with no problem
0

Featured Post

Looking for the Wi-Fi vendor that's right for you?

We know how difficult it can be to evaluate Wi-Fi vendors, so we created this helpful Wi-Fi Buyer's Guide to help you find the Wi-Fi vendor that's right for your business! Download the guide and get started on our checklist today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question