• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 919
  • Last Modified:

Exchange 2007 transport rule, exemt an email address from max send limits

I have recently installed Exchange 2007 SP1 and I have a Send Connector created on the Exchange 2007 server.  I have not yet moved over any mailboxes to the new server.  

By default, I know that the mail will prefer the new send connector.  

A couple of days ago I set a maximum message size limit to be 25 MB. (it was set as the default until that time). Soon after that I received a call that somebody was having trouble scanning to email.  I did some investigating and I found out that this person was using a scanner to send documents to their email address.  I did notice that the attachment sizes were greater than 25 MB.  

I disabled the maximum message size limit on the Send Connectors for the time being.  The receive connectors for the new Exchange server still has a 25 MB limit on it, I haven't changed that.  I don't think the receive connector will make a difference anyway.

The from address is HSCOPIER@TEST.COM  This email address is not in my AD domain as a valid address.

I'm kind of surprised that it hadn't failed before with the default settings and then just started having issues right after I changed it to 25 MB.

I would like to create some kind of transport rule that says: Emails coming from this copier can exceed the max send limit.  I went thru the Transport Rules wizard but I couldn't find any options to do what I'm trying to do.

How do I create a Hub Transport Rule to send email from the scanner to anybody and be exempted from the max send limit??
0
Florescu
Asked:
Florescu
  • 3
  • 3
1 Solution
 
MesthaCommented:
If the scanner is sending the email to an internal user then the Send Connector has nothing to do with the delivery of that email. Send Connectors are for outbound email FROM your server only.

If you want the scanner to be able to send messages to users on the server that are over the usual limit then I would suggest a new Receive Connector specifically for the scanner to use. With Exchange 2003 this is the same thing we would so with a second SMTP virtual server.

Simon.
0
 
FlorescuAuthor Commented:
How would I set that up?  What settings in the Receive connector do I need to setup?  

I looked in the Properties sheet but couldn't really figure out how to set it up properly.
0
 
MesthaCommented:
The size restriction is not in the GUI.
You can setup the additional receive connector in the usual way, but to change its size restriction you need to use EMS:

Set-ReceiveConnector "Connector Name" -MaxMessageSize 50MB

Simon.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
FlorescuAuthor Commented:
How is the receive connector going to know that it should be used for a particular user??  
How is the server going to know that it should use the new connector for the copier?

0
 
MesthaCommented:
You cannot restrict connectors to a specific user.

You would need to use some other means for the connector to be differentiated - separate IP address, custom port, something like that.

As long as the connector cannot be seen from the internet it cannot be abused.

Simon.
0
 
FlorescuAuthor Commented:
I ended up calling Microsoft Tech support on this and we figured out that it was Trend Antivirus that was causing this.  I unloaded it and reset iis, then it started working just fine.  I did have exclusions setup for Trend but apparently they weren't working right.  I'll have to call Trend support on this.

One thing to note is that it was all going thru the old Exchange 2003 server, it wasn't even using Exchange 2007.  All of my email accounts are still on the old Exchange 2003 server, I haven't migrated any users yet.

I found out a few interesting things from Microsoft support.  The server looks at the send/receive limits this way:

1.      Exchange checks the Global settings (Send/Receive connectors, etc.)
Both incoming and outgoing email is first check by the Global level and proceed for categorization and at this level step 2 is followed
2.      Exchange then checks Transport Rules if any
3.      Exchange checks the user mailbox restriction

Note: which ever size restriction is less will take priority

Also, they said that I could setup a receive connector as a "relay" so that the copier could relay messages outside of the organization.  You can restrict the receive connector by specifying the IP address of the copier machine in the Remote section.  That's how the copier knows to use that connector.  You can in fact restrict the connector size in the GUI.  

The easiest solution for what I will be trying to do is to setup the global settings at 50 MB for example, then create transport rule that says "send a NDR if message size is greater than 25 MB", unless it's from the copier email address.  I did have to add the copier as a Mail Contact.  

Microsoft did recommend that I should set the 50 MB on all the receive/send connectors and globally as well under Hub Transport, Global Settings, Transport Settings.  Then you can restrict it down via the transport rules or at the user level.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now