Solved

how to disable ppp0 bringing up interface while booting

Posted on 2009-04-09
6
468 Views
Last Modified: 2013-12-16
hi all how can I disable bringing up  interface ppp0  while booting
0
Comment
Question by:hatem_from_mesr
  • 3
  • 2
6 Comments
 
LVL 7

Expert Comment

by:Thomas Wheeler
ID: 24113830
what distro
0
 
LVL 7

Accepted Solution

by:
mchkorg earned 500 total points
ID: 24114034
Depending on the distribution

Example:
- Edit /etc/network/interfaces
- Remove "auto ppp0", the configuration for this interface will remain, but it won't activate automatcally, you'll have to "ifup ppp0" later.

If you can't find this file (because it might be somewhere else depending on your distribution), you can't try to discover it by yourself.
Try:
cd /etc
grep -ri "auto ppp0" *
This is a bit dirty, but you might get results
If you don't get it, it'll look for "auto ppp0" in all your conf files.
0
 

Author Comment

by:hatem_from_mesr
ID: 24115201
hi mchkorg,
thanks for reply
I'm facing this situation
I deleted ifcfg-ppp0, ifup ppp, if down ppp
is this enough please guide me
[root@localhost etc]# cd /etc/sysconfig/network-scripts
[root@localhost network-scripts]# ls
ifcfg-eth0
ifdown-ipv6
ifup
ifup-ipx
ifup-tunnel
ifcfg-lo    
ifdown-isdn
ifup-aliases
ifup-isdn
ifup-wireless
ifdown
ifdown-post
ifup-bnep
ifup-plip
init.ipv6-global
ifdown-bnep  
ifdown-routes  
ifup-eth      
ifup-plusb  
net.hotplug
ifdown-eth    
ifdown-sit    
ifup-ippp    
ifup-post  
network-functions
ifdown-ippp  
ifdown-sl      
ifup-ipsec    
ifup-sit    
network-functions-ipv6
ifdown-ipsec  
ifdown-tunnel  
ifup-ipv6    
ifup-sl
[root@localhost network-scripts]#
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:hatem_from_mesr
ID: 24115258
airtop,
distro is: centos 5
0
 
LVL 7

Assisted Solution

by:mchkorg
mchkorg earned 500 total points
ID: 24115346
Hi
I think you shouldn't have deleted it... hope you have a backup

On a redhat-based distro, I guess you should have modified the file instead
- Edit /etc/sysconfig/network-scripts/ifcfg-ppp0
- Modify the following value : ONBOOT=yes to ONBOOT=no

Then, either you reboot and check ppp0 is down after reboot, either you simply disable it with "ifdown ppp0" (anyway, you should check your modification remains OK after reboot)

Sorry, redhat-based distros aren't the ones I know better :)
0
 

Author Closing Comment

by:hatem_from_mesr
ID: 31568831
thanks man
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question