• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 21510
  • Last Modified:


I am getting an erorr when trying to link to a remote web server saying "PLEASE CHECK ERVIEWER.OCX INSTALLATION IS CORRECT. CURRENT VERSION 1.6.0" can anyone help?
  • 2
1 Solution
You are trying to connect to an EverFocus DVR. I'm trying to find a resolution to the same problem. When I find it, I'll post it.

Some suggestions have been to unregister the OCX, then reinstall, but it hasn't worked for me. It's worth trying though.

Go to Start > Run and type "regsvr32 -u erviewer.ocx". Then when you reconnect, presumably it would try to install it again (via activex).
Got it. I'm using IE8. I suspect IE7 is the same way.

You either need to define the site as trusted (if it's a DVR you should be OK), or go to the security settings for the internet zone, scroll down to "Download unsigned ActiveX controls" and change it from Disable to Prompt.

Then it will prompt you to install the ActiveX rather than block it.

I would suggest the 2nd method. Trusting a site unnecessarily even though it's not likely to be an attack vector is not the best idea.
There were a few ActiveX settings I had to change in IE7 Security but that did work thanks so much.
Didn't help any, not even the accepted solution.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now