Local Access Only wireless connection

Hello,

I have a laptop running Windows 7.

When the laptop is at a certain location, trying to connect to an open wireless network, I only get "Local Access Only"

Another laptop in the room works fine.

Can anybody help troubleshoot this?

Thanks in advance,

Steve
skbohlerAsked:
Who is Participating?
 
skbohlerConnect With a Mentor Author Commented:
OK, I was able to get this fixed. It seems some proxy setting had been turned on. Once I disabled it, all was fine.

Steve
0
 
dalesitConnect With a Mentor Commented:
Just because a wireless network is open doesn't necessarily mean that you can connect to the internet using it. It is possible that you might be at a wireless hotspot where they are running a "captive portal" which requires you to pay before you get internet access.

To check if this is the case, open a web browser, and try to go to any page. If there is a captive portal, you will be redirected to it which should give instructions for what to do next. It is possible that the laptop which works has been authenticated by mac address to bypass the captive portal.

Secondly, you should check to see if you have been assigned an IP address and default gateway. Not sure if this will work with Windows 7, but something like

ipconfig /all

should give you all the details about your network connection. Making huge assumptions about the fact that you are running Windows 7, I will assume that you are more than happy with basic networking configurations.

Essentially, I would check the settings on the laptop that works, and see if it has been configured to use manual addresses, or whether it is using DHCP, and also check to see what default router it is using, and whether that corresponds to what is set on the laptop that doesn't work.

Cheers,

Joel
0
 
skbohlerAuthor Commented:
Where do I check the laptops to see if they're set to use manual addresses or DHCP? Or what default router it's using?

It's not a captive portal issue. The wireless network is in a home.

Thanks,

Steve
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
dalesitCommented:
For XP, right click on the wireless connection, and select Status. Then you will see a screen giving information with more information on the Support tab.

From a command prompt, issue the command

ipconfig /all

and you will get output from all your network connections which will specify whether they are using DHCP or static addresses, and also what the default gateway for the interfaces is.

Cheers,

Joel
0
 
skbohlerAuthor Commented:
From the XP computer, ipconfig shows ...

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Owner>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : Laptop
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : hsd1.nj.comcast.net.

Ethernet adapter Wireless Network Connection:

        Connection-specific DNS Suffix  . : hsd1.nj.comcast.net.
        Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter
        Physical Address. . . . . . . . . : 00-C0-A8-B2-9D-F6
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.101
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 68.87.64.146
                                            68.87.75.194
                                            68.87.71.226
        Lease Obtained. . . . . . . . . . : Friday, April 10, 2009 12:39:08 PM
        Lease Expires . . . . . . . . . . : Saturday, April 11, 2009 12:39:08 PM


Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Marvell Yukon 88E8036 PCI-E Fast Eth
ernet Controller
        Physical Address. . . . . . . . . : 00-03-25-35-52-BF

FROM THE NON-WORKING LAPTOP, WHICH IS RUNNING WINDOWS 7, i GET...

ipconfig /all
Windows IP Configuration
   Host Name . . . . . . . . . . . . : SteveBohler-Lap
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
PPP adapter PdaNet Modem:
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : PdaNet Modem
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 68.245.171.115(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . : 0.0.0.0
   DNS Servers . . . . . . . . . . . : 68.28.114.91
                                       68.28.122.93
   NetBIOS over Tcpip. . . . . . . . : Enabled
Wireless LAN adapter Wireless Network Connection:
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Dell Wireless 1505 Draft 802.11n WLAN Min
i-Card
   Physical Address. . . . . . . . . : 00-24-2B-70-C0-8D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::909c:8b02:b6d5:f099%12(Preferred)
   Autoconfiguration IPv4 Address. . : 169.254.240.153(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 201335851
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-26-DA-34-00-23-AE-0E-5A-04
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled
Ethernet adapter Local Area Connection:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Marvell Yukon 88E8040 PCI-E Fast Ethernet
 Controller
   Physical Address. . . . . . . . . : 00-23-AE-0E-5A-04
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter isatap.nycap.rr.com:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter isatap.{679B8E29-B938-40BC-A00F-35365D6C2EAB}:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Teredo Tunneling Pseudo-Interface:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter isatap.hsd1.nj.comcast.net.:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter isatap.{53710400-BB85-4326-B514-A18B2E61541A}:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter 6TO4 Adapter:
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft 6to4 Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2002:44f5:ab73::44f5:ab73(Preferred)
   Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
   DNS Servers . . . . . . . . . . . : 68.28.114.91
                                       68.28.122.93
   NetBIOS over Tcpip. . . . . . . . : Disabled
Tunnel adapter isatap.{79896145-954D-4634-9827-6438BC790B81}:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
 
For some reason, the IP address starts with 169 (I have no idea).

Anything stand out as a possible problem or solution?

Thanks!

Steve
0
 
dalesitCommented:
Your machine is not getting a DHCP address assigned, so it is self assigning itself a 169.x.x.x address.

Try assigning yourself a static IP address of 192.168.1.200 with a default gateway of 192.168.1.1 and a DNS server of 68.87.64.146.

Is the wireless hub doing MAC authentication as well? It is possible that it is not responding to you because your machine is an unrecognised MAC. If the static address assignment works, then it is probably not this. If it doesn't work, I would suspect the authentication onto the wireless network isn't working properly. What wireless AP are you using?

Cheers,

Joel
0
 
skbohlerAuthor Commented:
OK, after following your advice, the connection now says "Locan and Internet". BUT, it does not give me Internet access. I've rebooted the router as well.

I'm using a standard Linksys wireless router.

Let me know other information you need, or something else I should check.

Thanks so much for your help!

Steve
0
 
dalesitCommented:
Linksys routers sometimes have a button which you have to press when you connect to the network. This does a basic form of MAC authentication - you can disable it and it will work fine. I suspect you are going to have to go in to the wireless router settings to be able to work out where the issue is. Pay particular attention to the security settings.

Cheers,

Joel
0
 
dalesitCommented:
The original request was to help troubleshoot the issue, and there was quite a lot of troubleshooting conducted. The proxy issue would not have helped when there was a self-assigned IP address. I feel that there should be some acknowledgement of the troubleshooting assistance that was provided.

Cheers,

Joel
0
 
skbohlerAuthor Commented:
I'm perfectly fine with acknowledging an effort to help. Is there a method for doing that, that's different from accepting a solution?

Steve
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.