• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1527
  • Last Modified:

.Net 3.5 SP 1 automatic update stuck Vista

I have a relatively new vista box that the updates are stuck on.  It keeps failing to install .net 3.5 sp1.  As a result it will not download any other updates either.  I tried to re-install 3.5 but it failed also (see error log below). I was going to attempt to remove this version from uninstall windows components, but when I open the Windows Features option it just shows a blank white box with no options (which I know is not right).  Is there a way/tool to completely remove 3.5 and start over?

I see this in the event log.

The Windows update "Update for Windows (KB948609)" could not be installed because of an error: 2147549183 "Catastrophic failure" (Command line: ""C:\Windows\system32\WUSA.exe" "C:\Users\Sandy\AppData\Local\Temp\dotnetfx3530729.01\1033\dotnetmsp\x86\NetFX2.0-KB948609-v6001-x86.msu" /quiet /norestart")
[03/21/09,06:36:08] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code -2147418113
[03/21/09,06:36:34] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.
[04/01/09,21:20:27] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code -2147418113
[04/01/09,21:21:07] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.
[04/09/09,10:08:16] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
[04/09/09,10:08:43] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.

Open in new window

0
bhieb
Asked:
bhieb
  • 5
  • 3
1 Solution
 
spprivateCommented:
It seems 3.5 is checking if 2.0 version is available.
So first install 2.0  from here

http://www.deploymaster.com/dotnetfx.html (They have all versions of .Net)
So once you are done with 2.0 if you want you can download 3.5 from there itself.(Infact the link takes you to Microsoft) so it is genuine.
0
 
bhiebAuthor Commented:
Ok tried to install 2.0 it gave me one next option then an error that said product is already installed as part of the OS.
0
 
spprivateCommented:
ok,
can you install the 3.5 framework from the link I provided
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
bhiebAuthor Commented:
Ok tried the full 3.5 and it produced the same error log in the code snipet above (actually I had tried this previously).

I also tried 3.0 but it said I must turn off .net in windows features, but I cannot do this since the list of features is not populating.  Seems like something has been corrupted.
0
 
bhiebAuthor Commented:
To clarify I had tried the 3.5 before, but I did try it again from your links as well.
0
 
spprivateCommented:
It seems many have this issues.Ok here is the link and possible resolution

http://ph.answers.yahoo.com/question/index?qid=20090227185854AAmzvMq
0
 
bhiebAuthor Commented:
Nice tool, but it did not work either.  I removed all I could (it won't let you do some that are part of Vista).  Still no luck.  I am working on why the windows features box is not showing up.  There are some articles on that, but so far no luck.  I've tried to run sfc /scannow from an elevated prompt but it errors out.  I'll keep the question updated if I make any progress.
0
 
bhiebAuthor Commented:
I've hit a dead end on this one. In diagnosing this I took a step back to try and figure out why it was not showing up in the windows features.  Turns out that is a fairly common problem.  There were a couple of "fixes".  

One was to delete a registry key by running "reg delete HKLM\Components /v StoreDirty" from an elevated prompt.  This came back with a no such key found message.

Secondly there was a ms KB931712 that suggested an sfc /scannow (again from and elevated prompt).  This fails with a "Windows Resource Protection could not perform this action".  Some get this error after x% done indicating a file that cannot be fixed, however I'm getting it right away, so no files are even being checked. It also fails to run a sfc /verifyonly so basically that command is not functioning either.  This behavior also persists in safe mode.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now