Using IE8, OWA attachment (docx, xlsx) wants to be saved as zip file.

I am having a problem with downloading Office 2007 attachments (.docx, .xlsx) in OWA being saved as .zip.
I found an article on this site about adding MIME types for Office 2007 extensions into IIS6. I applied the fix and it is working for IE7 users. Everyone using IE7 can now download .docx files correctly. However, IE8 users are still having the problem.
We are running Windows Server 2003, IIS6, and Exchange 2003. All users have Office 2007 Pro installed.
Futurenet_SolutionsAsked:
Who is Participating?
 
Futurenet_SolutionsAuthor Commented:
I think I have figured it out.
If you add the OWA site to the trusted sites in IE8 it allows you to download the attachment correctly.
0
 
brislaneCommented:
What have you the MIME types setup as ? They should be as follows :

.xlsx       application/vnd.openxmlformats-officedocument.spreadsheetml.sheet
.docx       application/vnd.openxmlformats-officedocument.wordprocessingml.document
0
 
Futurenet_SolutionsAuthor Commented:
I added all of these:

.xlsx - application/vnd.openxmlformats-officedocument.spreadsheetml.sheet  
.xltx - application/vnd.openxmlformats-officedocument.spreadsheetml.template  
.potx - application/vnd.openxmlformats-officedocument.presentationml.template
.ppsx - application/vnd.openxmlformats-officedocument.presentationml.slideshow
.pptx - application/vnd.openxmlformats-officedocument.presentationml.presentation
.sldx - application/vnd.openxmlformats-officedocument.presentationml.slide
.docx - application/vnd.openxmlformats-officedocument.wordprocessingml.document
.dotx application/vnd.openxmlformats-officedocument.wordprocessingml.template
.xlam application/vnd.ms-excel.addin.macroEnabled.12
.xlsb application/vnd.ms-excel.sheet.binary.macroEnabled.12
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
JWL5537Commented:
I'm experiencing the same problem and have added the same MIME in IIS.
0
 
Futurenet_SolutionsAuthor Commented:
Now I am going to create a GPO for adding the OWA site to the trusted sites in IE.
I found this site for creating a GPO for trusted sites:
http://windowsitpro.com/article/articleid/78049/jsi-tip-6644-how-can-i-use-group-policy-to-add-a-site-to-the-trusted-sites-zone.html
0
 
JWL5537Commented:
I tried putting it in trusted sites and it still won't open.  It's asking me to open the zip file and then save the excel file.
0
 
Futurenet_SolutionsAuthor Commented:
Maybe a silly question.....but you did make sure to restart IIS after adding the new MIME types?
0
 
JWL5537Commented:
Yes, multiple times.
0
 
JWL5537Commented:
Sorry, one thing of note is that I removed the registry entries for Level2 File Types and Level 2 Types.
0
 
Futurenet_SolutionsAuthor Commented:
I did not do that. I only added the MIME types and restarted IIS. Now it is working for me.
0
 
JWL5537Commented:
I put the MIME Reg keys back in, restarted IIS and am back to getting the message "To open this attachment you must save it to disk....".  I went back and re-copied the MIME Types back in and restarted IIS again.  Still no luck.
0
 
Futurenet_SolutionsAuthor Commented:
I still get that message also. However, now when i right-click and chose "save target as..." is saves it correctly.
Before adding the MIME types and adding OWA to trusted sites in IE8, when I would select "save target as..." it would save it as a zip.

As far and getting rid of the "To open this attachment you must save it to disk...", I have not figured that one out yet.
0
 
janiemoCommented:
To add to the confusion on this, when I create and email in MacOS using Office 2008 and then send it from Entourage, it opens just fine from OWA on Vista with IE8.  Explain that one.
0
 
JRigCommented:
I'm having this issue too.  MIME is correct, site added to trusted sites list.  Still no go.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.