Solved

Cant access coldfusion admin after new install

Posted on 2009-04-10
12
487 Views
Last Modified: 2013-12-24
just installed cf8 on a brand new server. cant access the admin

if i go to:http://127.0.0.1/CFIDE/administrator/index.cfm i get '400 bad request'

if i go to: http://127.0.0.1:8500/cfide/administrator/index.cfm i get:

404
File not found: /cfide/administrator/index.cfm


coldfusion.runtime.TemplateNotFoundException: File not found: /cfide/administrator/index.cfm
      at coldfusion.filter.PathFilter.invoke(PathFilter.java:89)
      at coldfusion.filter.ExceptionFilter.invoke(ExceptionFilter.java:70)
      at coldfusion.filter.ClientScopePersistenceFilter.invoke(ClientScopePersistenceFilter.java:28)
      at coldfusion.filter.BrowserFilter.invoke(BrowserFilter.java:38)
      at coldfusion.filter.NoCacheFilter.invoke(NoCacheFilter.java:46)
      at coldfusion.filter.GlobalsFilter.invoke(GlobalsFilter.java:38)
      at coldfusion.filter.DatasourceFilter.invoke(DatasourceFilter.java:22)
      at coldfusion.CfmServlet.service(CfmServlet.java:175)
      at coldfusion.bootstrap.BootstrapServlet.service(BootstrapServlet.java:89)
      at jrun.servlet.FilterChain.doFilter(FilterChain.java:86)
      at coldfusion.monitor.event.MonitoringServletFilter.doFilter(MonitoringServletFilter.java:42)
      at coldfusion.bootstrap.BootstrapFilter.doFilter(BootstrapFilter.java:46)
      at jrun.servlet.FilterChain.doFilter(FilterChain.java:94)
      at jrun.servlet.FilterChain.service(FilterChain.java:101)
      at jrun.servlet.ServletInvoker.invoke(ServletInvoker.java:106)
      at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvokerChain.java:42)
      at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequestDispatcher.java:286)
      at jrun.servlet.ServletEngineService.dispatch(ServletEngineService.java:543)
      at jrun.servlet.http.WebService.invokeRunnable(WebService.java:172)
      at jrunx.scheduler.ThreadPool$DownstreamMetrics.invokeRunnable(ThreadPool.java:320)
      at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.java:428)
      at jrunx.scheduler.ThreadPool$UpstreamMetrics.invokeRunnable(ThreadPool.java:266)
      at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66)


any ideas on wht i can check?
0
Comment
Question by:bede123
  • 6
  • 3
  • 3
12 Comments
 
LVL 16

Expert Comment

by:duncancumming
ID: 24117136
Did you opt to use CF's built-in webserver or your own webserver?
0
 
LVL 1

Author Comment

by:bede123
ID: 24118395
i installed CF with all the defualt options. i'm using IIS6.

ive done this a dozen times before and never had any problems. any ideas what it might be?
0
 
LVL 16

Expert Comment

by:duncancumming
ID: 24118659
If it's using IIS 6, the :8500 port won't apply, that's just for the built-in webserver that comes with CF.  

So, only the first URL is what we're interested in.  400 error, what do MS say:
http://support.microsoft.com/kb/247249


0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 1

Author Comment

by:bede123
ID: 24118773
naa nothing helpful from MS.

i found the 8500 mentioned on another site so thought i'd try it.

its probably somthing really simple that i need to do but i'm just not sure what else to try.

so what port does cf use?

0
 
LVL 16

Expert Comment

by:duncancumming
ID: 24118837
well if you're using IIS it'll use whatever port you have enabled there, default of 80
0
 
LVL 36

Expert Comment

by:SidFishes
ID: 24119871
is iis set up to use an IP?  if so localhost or loopback won't work

you might try

http://servermachinename/CFIDE/administrator/index.cfm

or

http://serverip.ip.ip.ip/CFIDE/administrator/index.cfm

0
 
LVL 1

Author Comment

by:bede123
ID: 24119946
thanks sid, tried both of those but still no joy.

0
 
LVL 36

Expert Comment

by:SidFishes
ID: 24122304
could try re-running IIS_connector.bat think it's in the wsconfig dir in {cfroot}

also... are you able to serve any pages at all? cfm htm etc
0
 
LVL 1

Author Comment

by:bede123
ID: 24122660
yes,

http://www.multibiz.biz/index.html

&

http://www.multibiz/index.cfm

no probs at all.


so thi tells us that everything is running like cf server and iis - just cant access the admin, strange!
0
 
LVL 1

Author Comment

by:bede123
ID: 24122666
0
 
LVL 36

Accepted Solution

by:
SidFishes earned 500 total points
ID: 24130211
try adding a virtual directory in iis for pointing to the  cfide dir (this is useful later on anyways)

0
 
LVL 1

Author Comment

by:bede123
ID: 24131358
got it. thanks for your help sid.

i just found cfide dir in and dir called the s30744093n which would appear to be the name of my hosted server.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question