?
Solved

invalid delimited data: text qualifier must be followed by a column delimiter

Posted on 2009-04-10
6
Medium Priority
?
1,469 Views
Last Modified: 2013-11-30
I have the same problem to import data by DTS, I clicked Delimited, file type: ANSI
row delimiter {CR}{LF} and text qualifieer Double Quote{"}, but I got this error
here is my .txt file
"2233","1","18-SEP-00","3","08-SEP-00","9","2000","647","1","1"
0
Comment
Question by:yrcdba7
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 17

Expert Comment

by:k_murli_krishna
ID: 24117274
I think, text qualifier " is only for text i.e. CHAR, VARCHAR etc. data. For date/datetime, it should be single quotes, for integer/decimal there should be no quotes in the .csv data file. You need to prepare/generate/export .csv file using better method/technique/tool.
0
 

Author Comment

by:yrcdba7
ID: 24117319
the file is with datetime, integer/decimal all of data is " ", I can not change them, it is 100K records.  what tool you prefer?
0
 
LVL 12

Expert Comment

by:Nathan Riley
ID: 24117452
I had this problem I I just changed the file to tab delimited and it worked.  Do you have the ability to change what type of delimited columns you will be getting in the file?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 17

Accepted Solution

by:
k_murli_krishna earned 2000 total points
ID: 24117559
Sorry, I do not think that is the problem. Are you mapping data to columns correctly? Also, without the double quotes ("), is the data's data type matching the column's data type? This is just a weather warning rather than a forecast ::)).
0
 

Author Comment

by:yrcdba7
ID: 24117672
I frist try to give all cols varchar (255), so I can import data into table then change data type. right now it stop to input data to table. it complain invalid delimited.  I look at text file, I don't see where I can change delimited to tab data type for .txt file.

I clicked Delimited and
file type: ANSI
Row delimiter:  {CR}{LF}
Text qualifier: Double Quote{"}

I used emediter delete .txt ending line space, then copy data to .txt file to import data. the delimiter gone maybe because I use editer to delete space, it taked delimiter out.   well still no work.
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 24124018
Please post a valid sample where we can duplicate the problem.  The line you posted is valid.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
Via a live example, show how to extract insert data into a SQL Server database table using the Import/Export option and Bulk Insert.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question