Solved

Need Help Getting OMA to work

Posted on 2009-04-10
14
579 Views
Last Modified: 2012-05-06
I have an exchange 2003 server (running on a backup domain controller)  The router for the network is a Linux firewall (Ubuntu) and dns is handled by the windows domain controllers.  The domain is example.internal but the users e-mail addresses are example.com.  webmail works just fine over https (port 80 goes to a linux web server, and the port 443 is sent directly to the exchange server)  I am trying to get Outlook Mobile Access working in order to allow my iphone, and the other users' pocket pcs/iphones/blackberries to sync calenders and contacts with the exchange server.  The current setup shows example.com/oma giving a server SERVERNAME cannot be found. I'm out of office right now, but I can post the actual error later.  What other details do you need to get this issue resolved ASAP?  I can't move the linux webservers website to windows in order to free up port 80, besides I'd rather have e-mail that uses SSL anyway. Thanks
0
Comment
Question by:2003domainadmin
  • 10
  • 3
14 Comments
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24119078
This is the acutal error when visiting https://owa.example.com/oma

Unable to connect to your mailbox on server SERVERNAME. Please try again later. If the problem persists contact your administrator.
0
 
LVL 4

Expert Comment

by:StefanKittel
ID: 24119099
Hallo,

you only need port 443. so no need to harm the pinguin.
Have a look here: http://www.petri.co.il/test_oma_in_exchange_2003.htm

Whenever I configured OWA OMA works without anything to do.
Have a look at your IIS. maybe one of the sites has a wrong hostname. maybe you enter a FQN name there.

Stefan
0
 
LVL 4

Expert Comment

by:StefanKittel
ID: 24119102
Oh..

and see here: http://www.petri.co.il/configure_oma.htm

Stefan
0
 
LVL 4

Assisted Solution

by:StefanKittel
StefanKittel earned 50 total points
ID: 24119109
and here you can test your server: https://www.testexchangeconnectivity.com/Default.aspx
Its from MS.

Stefan
0
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24120051
The FQDN for the exchange server is exchange.example.internal but the outside world sees it as owa.example.com.  Will this matter?  OWA works, but OMA gives the error: "Unable to connect to your mailbox on server EXCH01. Please try again later. If the problem persists contact your administrator."
This error occurs with or without SSL, but SSL is the only way to access it via outside world as port 80 is for the linux web server.
0
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24120098
I tried adjusting the SSL settings in IIS and now the following error occurs for https://oma.example.com/oma (oma and owa are both DNS CNAMEs to the same place, so that port 80 requests to those subdomains are redirected by the linus server to https://owa.example.com)

Eorror I now receive when logging into OMA via firefox 3.0: Item no longer exists. The item you are attempting to access may have been deleted or moved.
Home
0
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24120938
OK after browsing around, I decided to test to see if the domain administrator can use OMA, and after creatng a mailbox for the Domain Admin account, I found out that it works.  What can I do to get regular users to have a working OMA?
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 1

Author Comment

by:2003domainadmin
ID: 24120966
I've tried adding the regular user to the Domain Admins group and the error still occurs.
0
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24121073
I have OMA working in firefox, but not on my iphone.  How can I fix this?  The error the phone gives is:
Cannot Get Mail
The conection to the server failed
0
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24121097
Here is the response from the testexchangeconnectivity site
Sys.WebForms.PageRequestManagerServerErrorException: Exception Details: Message: More than a single test has been run in the last minute for domain owa.ryujinstemple.com, please try again later Type: System.Exception Stack Trace: at Microsoft.Exchange.Tools.ExRca.Website.Default.ThrowIfDomainThrottled(String domainName) at Microsoft.Exchange.Tools.ExRca.Website.Default.testSelectWizard_ActiveStepChanged(Object sender, EventArgs e) at System.Web.UI.WebControls.Wizard.OnActiveStepChanged(Object source, EventArgs e) at System.Web.UI.WebControls.Wizard.MultiViewActiveViewChanged(Object source, EventArgs e) at System.Web.UI.WebControls.MultiView.OnActiveViewChanged(EventArgs e) at System.Web.UI.WebControls.MultiView.set_ActiveViewIndex(Int32 value) at System.Web.UI.WebControls.Wizard.set_ActiveStepIndex(Int32 value) at System.Web.UI.WebControls.Wizard.OnBubbleEvent(Object source, EventArgs e) at System.Web.UI.WebControls.Wizard.WizardChildTable.OnBubbleEvent(Object source, EventArgs args) at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) at System.Web.UI.WebControls.Button.OnCommand(CommandEventArgs e) at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) at System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 

Open in new window

0
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24121140
Ok I had OMA working, but then OWA was broken.  I changed the settings back in order to fix OWA (more important than OMA) but now OWA would login but it wouldnt show messages sent to it via outside or inside the exchange network.
0
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24121156
OK. Now both OMA and OWA are working, but the OWA login form with our company's nice usage warning no longer works, because form based authentication had to be disabled for OMA.  Anyway to fix this?
0
 
LVL 17

Accepted Solution

by:
JohnGerhardt earned 450 total points
ID: 24130107
Hi 2003domainadmin,
The trouble is active sync doesnt like forms based auth.. You need to create a seperate virutla directory for either OWA or OMA.
You will find a nice guide from petri here:
http://www.petri.co.il/problems_with_forms_based_authentication_and_ssl_in_activesync.htm
I hope this helps..
0
 
LVL 1

Author Comment

by:2003domainadmin
ID: 24366789
Couldn't get both to work.  Only the original VD works, but I just left the forms off.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now