• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1577
  • Last Modified:

On netgear wfs709tp wireless switch, how to configure guest disclaimer

We're running the Netgear wfs709tp wireless switch, which supports a captive portal for authorizing users, as well as a separate guest/contractor network. Both SSIDs are encrypted with WPA and thus require login, but the guest login we just give out to guests en masse. We don't track guest access individually.

Management says we must display a disclaimer to guests saying that they use the network at their own risk, etc. The box has a place to create custom login pages, and we can create a disclaimer for the staff network, but the HTML code we enter for the guest network never seems to appear. We just get the ordinary plain vanilla login.Netgear is silent on the subject, saying they will support the actual wifi operational aspects, but not the "window dressing" features, which they say customers are on their own to support. They say they won't debug HTML code for customers. Attached is the HTML code we used. We've tried it both with and without <HTML>, <HEADER>, and <BODY> tags with no change.
<HTML>
<HEAD>
</HEAD>
<BODY>
<H1><FONT COLOR=D6000></H1>
<P>
<FONT SIZE=4>
This network is provided as a courtesy to our guests.  You use it at your own risk and are responsible for ensuring your own security.
<P>
</FONT>
</BODY>
</HTML>

Open in new window

0
packetguy
Asked:
packetguy
  • 3
  • 2
2 Solutions
 
_Commented:
Did you try adding a TITLE between the HEAD?
<HEAD>
<TITLE>Title of your page</TITLE>
</HEAD>

Open in new window

0
 
mycroftxCommented:
Here are some aspects of the Captive Portal install you may want to consider...
If an appropriate server certificate is not installed in the WFS709TP, wireless clients that use Captive Portal may see a Security Alert message when logging in and portal pages may not display correctly.

If you are using Captive Portal to authenticate users, configure the authentication server that will be used to validate users. The authentication server can be either an external server or the WFS709TPs internal database.

By default, HTTPS is used on redirection to the Captive Portal page. If you need to use HTTP instead, do the following:
1. Navigate to the Configuration > Advanced > Security > Authentication Methods > Captive Portal page.
2. For Protocol Type, select http and click Apply.

Here's the steps for Captive Portal Customization.  Keep in mnd that custom HTML cannot simply be pasted into the Captive Portal, you MUST use the built in editor or the HTML cannot be parsed correctly.

(Optional) Customize the captive portal background text.
a. Set the background color in the Custom page background color field. The color code must a hexadecimal value in the format #hhhhhh.
b. Click Submit on the bottom on the page.
c. To view the background setting, click the View Captive Portal link. This displays the Captive Portal page as it will be seen by users  

(Optional) Customize the captive portal background text:
a. Enter the text that needs to be displayed (in HTML format) in the Page Text message box.
b. To view the changes, click Submit at the bottom on the page and then click the View Captive Portal link. This displays the Captive Portal page as it will be seen by users.

(Optional) Customize the text under the Acceptable Use Policy:
a. Enter the policy information in the Policy Text text box. This text appears only for a guest logon.
b. To view the changes, click Submit at the bottom on the page and then click the View Captive Portal link. This displays the Captive Portal page as it will be seen by users

Good luck, and le me know how it turns out, as I had the same problem with my first install of a WFS709TP ProSafe Wireless Switch.
0
 
packetguyAuthor Commented:
Thanks! I'll be onsite again to try these instructions on Monday or Tuesday!
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
packetguyAuthor Commented:
Alas, none of these suggestions seem to work. The captive portal just lets the users online without displaying the disclaimer.

 -mel
0
 
_Commented:
Bummer.   : (
0
 
packetguyAuthor Commented:
This seems to be a bug in the firmware that Netgear won't address and for which nobody has devised a workaround. So the question has not been solved.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now