error in ip tables configuration

somehow I managed to mess up my ip-tables config. I get this error when I try to restart iptables,


[root@tktdgt ~]# service iptables restart
: command not foundbles-config: line 7:
: command not foundbles-config: line 14:
: command not foundbles-config: line 20:
: command not foundbles-config: line 26:
: command not foundbles-config: line 33:
Flushing firewall rules:                                   [  OK  ]
Setting chains to policy ACCEPT: mangle filter             [  OK  ]
[root@tktdgt ~]#

My file is below, it looks fine to me.


# Load additional iptables modules (nat helpers)
#   Default: -none-
# Space separated list of nat helpers (e.g. 'ip_nat_ftp ip_nat_irc'), which
# are loaded after the firewall rules are applied. Options for the helpers are
# stored in /etc/modules.conf.
IPTABLES_MODULES=""
 
# Unload modules on restart and stop
#   Value: yes|no,  default: yes
# This option has to be 'yes' to get to a sane state for a firewall
# restart or stop. Only set to 'no' if there are problems unloading netfilter
# modules.
IPTABLES_MODULES_UNLOAD="no"
 
# Save current firewall rules on stop.
#   Value: yes|no,  default: no
# Saves all firewall rules to /etc/sysconfig/iptables if firewall gets stopped
# (e.g. on system shutdown).
IPTABLES_SAVE_ON_STOP="no"
 
# Save current firewall rules on restart.
#   Value: yes|no,  default: no
# Saves all firewall rules to /etc/sysconfig/iptables if firewall gets
# restarted.
IPTABLES_SAVE_ON_RESTART="no"
 
# Save (and restore) rule and chain counter.
#   Value: yes|no,  default: no
# Save counters for rules and chains to /etc/sysconfig/iptables if
# 'service iptables save' is called or on stop or restart if SAVE_ON_STOP or
# SAVE_ON_RESTART is enabled.
IPTABLES_SAVE_COUNTER="no"
 
# Numeric status output
#   Value: yes|no,  default: yes
# Print IP addresses and port numbers in numeric format in the status output.
IPTABLES_STATUS_NUMERIC="yes"

Open in new window

LVL 1
JPERKS1985Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
arnoldConnect With a Mentor Commented:
Post the contents of /etc/sysconfig/iptables*
0
 
Morne LateganCommented:
Did you edit the file in dos? If so, run

dos2unix -p /path/to/file

It seems its complaining about all the blank lines
0
 
JPERKS1985Author Commented:
no more errors but it will not start




Setting chains to policy ACCEPT: mangle filter             [  OK  ]
[root@tktdgt ~]# service iptables start
Flushing firewall rules:                                   [  OK  ]
Setting chains to policy ACCEPT: mangle filter             [  OK  ]
[root@tktdgt ~]# service iptables status
Firewall is stopped.
[root@tktdgt ~]#
0
The Firewall Audit Checklist

Preparing for a firewall audit today is almost impossible.
AlgoSec, together with some of the largest global organizations and auditors, has created a checklist to follow when preparing for your firewall audit. Simplify risk mitigation while staying compliant all of the time!

 
arnoldCommented:
run iptables -L
chkconfig --list iptables

What do you have for the above?
0
 
JPERKS1985Author Commented:
[root@tktdgt ~]# run iptables -L
-bash: run: command not found
[root@tktdgt ~]# chkconfig --list iptables
iptables        0:off   1:off   2:on    3:on    4:on    5:on    6:off
0
 
arnoldCommented:
iptables -L
0
 
Kerem ERSOYPresidentCommented:
Remove run execute only iptables -L

If seems that you're running over RedHAT / CentOS . The default configuration is in /etc/sysconfig/iptables

If the code sniipet belongs to this file it is normal that you have nothing because your file does not contain any rules for firewall.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.