Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Using Cisco IOS 12.4(12c) with DYNDNS

Posted on 2009-04-11
3
1,367 Views
Last Modified: 2012-05-06
I have an 831 router with 12.4(12c) IOS and I can't get it to update my dynamically assigned IP address. I've read the Cisco documentation, DynDNS documentation on the subject, and I still am having problems. Below is my entire running config, with the passwords and sensitive IP addresses change to protect the guilty. Also I'm running Dynamic VPN which IS working beautifully. If someone could correct my code and paste it in its entirity, I would be eternally greatful. Also Everyone's including Cisco was unclear what I should enter in place of <H> and <A> in the url.
version 12.4(12c)
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname HomeSpoke
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$okB.$ctJfdwqzdwSh44PxOy81
!
no aaa new-model
!
!
!
!
ip cef
ip host members.dyndns.org 63.208.196.96
ip ddns update method DynDNS
!
ip ddns update method dyndns
 HTTP
  add https://john:NhguH76K@members.dyndns.org/nic/update?system=dyndns&hostname=john.dyndns.org&myip=<a>
 interval maximum 28 0 0 0
 interval minimum 28 0 0 0
!
!
!
crypto pki trustpoint example
 enrollment terminal pem
 revocation-check none
!
!
crypto pki certificate chain example
 certificate ca 35DEF4CF
  30820320 30820289 A0030201 02020435 DEF4CF30 0D06092A 864886F7 0D010105
  0500304E 310B3009 06035504 06130255 53311030 0E060355 040A1307 45717569
  66617831 2D302B06 0355040B 13244571 75696661 78205365 63757265 20436572
  74696669 63617465 20417574 686F7269 7479301E 170D3938 30383232 31363431
  35315A17 0D313830 38323231 36343135 315A304E 310B3009 06035504 06130255
  53311030 0E060355 040A1307 45717569 66617831 2D302B06 0355040B 13244571
  75696661 78205365 63757265 20436572 74696669 63617465 20417574 686F7269
  74793081 9F300D06 092A8648 86F70D01 01010500 03818D00 30818902 818100C1
  5DB15867 0862EEA0 9A2D1F08 6D911468 980A1EFE DA046F13 846221C3 D17CCE9F
  05E0B801 F04E34EC E28A9504 64ACF16B 535F05B3 CB6780BF 42028EFE DD0109EC
  E100144F FCFBF00C DD43BA5B 2BE11F80 70991557 9316F10F 976AB7C2 68231CCC
  4D5930AC 511E3BAF 2BD6EE63 457BC5D9 5F50D2E3 500F3A88 E7BF14FD E0C7B902
  03010001 A3820109 30820105 30700603 551D1F04 69306730 65A063A0 61A45F30
  5D310B30 09060355 04061302 55533110 300E0603 55040A13 07457175 69666178
  312D302B 06035504 0B132445 71756966 61782053 65637572 65204365 72746966
  69636174 65204175 74686F72 69747931 0D300B06 03550403 13044352 4C31301A
  0603551D 10041330 11810F32 30313830 38323231 36343135 315A300B 0603551D
  0F040403 02010630 1F060355 1D230418 30168014 48E668F9 2BD2B295 D747D823
  20104F33 98909FD4 301D0603 551D0E04 16041448 E668F92B D2B295D7 47D82320
  104F3398 909FD430 0C060355 1D130405 30030101 FF301A06 092A8648 86F67D07
  4100040D 300B1B05 56332E30 63030206 C0300D06 092A8648 86F70D01 01050500
  03818100 58CE29EA FCF7DEB5 CE02B917 B585D1B9 E3E095CC 25310D00 A6926E7F
  B692639E 5095D19A 6FE411DE 63856E98 EEA8FF5A C8D355B2 667157DE C021EB3D
  2AA72349 01048642 7BFCEE7F A21652B5 6767D340 DB3B2658 B228773D AE147761
  D6FA2A66 27A00DFA A7735CEA 70F19421 65445FFA FCEF2968 A9A28779 EF79EF4F AC077738
  quit
!
!
!
crypto isakmp policy 1
 authentication pre-share
crypto isakmp key mykey address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set trans2 esp-des esp-md5-hmac
 mode transport
!
crypto ipsec profile vpnprof
 set transform-set trans2
!
!
!
!
interface Tunnel0
 bandwidth 1000
 ip address 10.0.0.2 255.255.255.0
 no ip redirects
 ip mtu 1700
 ip nhrp authentication test
 ip nhrp map multicast 65.140.80.167
 ip nhrp map 10.0.0.1 65.140.80.167
 ip nhrp network-id 100000
 ip nhrp holdtime 300
 ip nhrp nhs 10.0.0.1
 ip ospf network broadcast
 ip ospf priority 0
 delay 1000
 tunnel source Ethernet1
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile vpnprof
!
interface Ethernet0
 ip address 172.27.19.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Ethernet1
 description Outside WAN Interface
 ip ddns update hostname john.dyndns.org
 ip ddns update DynDNS host members.dyndns.org
 ip ddns update dyndns
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
!
interface Ethernet2
 no ip address
 shutdown
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 172.27.19.0 0.0.0.255 area 0
!
ip route 172.0.0.0 255.0.0.0 10.0.0.1
!
ip http server
no ip http secure-server
!
ip nat inside source list 101 interface Ethernet1 overload
!
access-list 101 permit ip 172.27.19.0 0.0.0.255 any
!
!
!
control-plane
!
!
line con 0
 no modem enable
 transport output all
line aux 0
 transport output all
line vty 0 4
 password 7 11f37aa8d99a
 login
 transport input all
 transport output all
!
scheduler max-task-time 5000
end

Open in new window

0
Comment
Question by:n7okn
  • 2
3 Comments
 
LVL 13

Accepted Solution

by:
Quori earned 500 total points
ID: 24127932
HTTP
  add https://john:NhguH76K@members.dyndns.org/nic/update?system=dyndns&hostname=john.dyndns.org&myip=<a>



See the issue there? :)

0
 
LVL 3

Author Comment

by:n7okn
ID: 24172670
Sorry... I don't follow....
0
 
LVL 13

Expert Comment

by:Quori
ID: 24180656
Change your https:// to http://
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Port forwarding 14 172
How to choose hardware firewall 5 60
Cisco 800 router unable to connect through TPG network 12 23
unable to set full duplex 100 on WAN interface 11 60
Envision that you are chipping away at another e-business site with a team of pundit developers and designers. Everything seems, by all accounts, to be going easily.
Microservice architecture adoption brings many advantages, but can add intricacy. Selecting the right orchestration tool is most important for business specific needs.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question