• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 569
  • Last Modified:

Vista network interface metrics are wonky - what am I doing wrong?

I have need to be active on more than one NIC at a time. I noticed that my gigabit connection always drops into last place if any wireless connections are on too. I turned off automatic metrics in each adapter's advanced tcp settings and specified values as per Microsoft. 10, for example, for the gigabit NIC and much higher numbers (40) for the wireless NICs based on speed.

No change.

I checked the output of "route" and found the metrics there don't look anything like the metrics I specified. The wireless default routing table entry has a metric of 80 where the gigabit line has a metric of 266!.

What am I doing wrong?
0
pkivolowitz
Asked:
pkivolowitz
  • 2
  • 2
1 Solution
 
knoxzooCommented:
Are you doing this with elevated rights?
0
 
pkivolowitzAuthor Commented:
Certainly.

The settings I make are all sticky.

p
0
 
knoxzooCommented:
Go into Advanced in Network Connections.  Under Adapters and Bindings you'll see your Wireless and Wired adapters listed.  Click on the wired one, then click the up arrow as often as necessary to give it top priority.
0
 
pkivolowitzAuthor Commented:
I did as you suggested and found that adjusting the order in the advanced settings had no impact on the router metrics. Gigabit connection: 266. Wireless connection: 50.

I did find how to do this:
Router metric is the sum of ncpa.cpl > adapter > properties > tcp/ip > properties > advanced > default gateways  and interface metric.

In the end, you pointed the way.


0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now