Solved

Having Boot Issues Setting IDE as Slave.

Posted on 2009-04-11
18
293 Views
Last Modified: 2012-05-06
I have an HD that I want to slave to my other HD which is running XP.  I have my XP HD set to Master and the other HD as Slave.  When I start the PC I get a Boot Disk error.  I go into BIOS and it sees my good XP HD as the primary master.  I'm able to slave other drives without issue.  Any ideas?
0
Comment
Question by:vsllc
  • 8
  • 4
  • 3
  • +2
18 Comments
 
LVL 5

Expert Comment

by:brandonvmoore
ID: 24123730
Try using the cable select option on both of the drives.  Then the hardware will automatically assign master and slave status based on which drive is hooked to the cable first.

Also, try making the slave a master and only hooking it up just to see if you get any errors.  This way if it doesn't work you will know that the drive has a problem.
0
 
LVL 66

Assisted Solution

by:johnb6767
johnb6767 earned 150 total points
ID: 24123749
Or, if you dont need the CDRom for a bit, just set it there as a master....

What kinds of Drives?

Some older (maybe currrent even)WD drives had a "Master", AND a "Master w/ Slave Present" jumper.....
0
 

Author Comment

by:vsllc
ID: 24123807
My master is a Seagate ST340810A and the slave is a WD1200.  When I just hook up the HD I want to slave with no jumpers set and the other HD unhooked I get the Boot Disk error.
0
Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

 

Author Comment

by:vsllc
ID: 24123856
OK.  The Seagate HD had a second configuration.  I had to add a second jumper to setup "Master with a Non-ATA Compatible Slave".  Unfortunately, I can't see anything on the slaved HD.  Any ideas?
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 24123865
Does it who up in Windows>Start>run>compmgmt.msc>Disk Management?
0
 

Author Comment

by:vsllc
ID: 24123910
No.  Just my C and two CD-ROMs.  Nothing in BIOS either.  The drive was not working in an old PC so I was hoping to slave and pull the data off.
0
 
LVL 5

Expert Comment

by:brandonvmoore
ID: 24123944
Sounds like you have a bad drive.  One more thing you might try though is to go to your local computer store and buy a dongle that will allow you to hook up your hard drive directly to a usb port.
0
 

Author Comment

by:vsllc
ID: 24123962
Got that.  Recognizes the USB device but does not see the HD to view the files.
0
 
LVL 5

Expert Comment

by:brandonvmoore
ID: 24123977
Yeah, sounds like a bad hard drive then :(
0
 

Author Comment

by:vsllc
ID: 24124000
Anyway to retrieve the data short of sending it off for $$$$ to some specialty shop?
0
 
LVL 5

Expert Comment

by:brandonvmoore
ID: 24124167
Well, you could learn how to do what the specialty shop guys do for yourself... but that's not really a better solution.  As Forest Gump once said: shit happens :-\
0
 
LVL 48

Assisted Solution

by:dbrunton
dbrunton earned 150 total points
ID: 24124624
You may wish to see what this person did

http://www.deadharddrive.com/

Essentially he obtained a similar logic board and swapped it in and tried that.  Try eBay for logic boards.
0
 
LVL 12

Expert Comment

by:coredatarecovery
ID: 24127300
Hey, the master needs to be on the end of the IDE cable, the slave needs to be on the middle connector.

Set them both to cs or cable select, or if they don't identify that way, turn down the ATA level to ata-33 as the older drive won't identify at ata-100.

You MUST set a jumper on the slave to CS or slave.
If you choose SLAVE on the slave drive, you must select master on the master drive.

Alternatively, you can just get an external USB to IDE adaptor for about 15.00 including shipping from your local shop or ebay.

You most likely Do Not need professional help with this type of data retrieval.


If you cannot get your drive to identify with this information above, attach the slave drive on the middle connector right below the cd-rom. (or disconnect the cdrom.)

The problem with not jumpering the secondary drive is that both want to become master and will argue, this confuses the IDE controller.
0
 

Author Comment

by:vsllc
ID: 24130917
dbrunton - Nice link!  I've swapped the logic board with a known working drive that I successfully slaved.  The bad HD is spinning, there is no unusual knocking, grinding or other troublesome sounds.  However the system still does not see the drive.

coredatarecovery - I can successfully slave (I say successful because I don't get errors on boot anymore) but the drive is still unrecognizable to the system.  See my response to dbrunton.  I also tried the USB and CD hookup as you suggested.  No luck with either.  Of course I don't think I have the USB method working right because I can't get any disk to recognize with it.  Even ones I can slave and see the data files.
0
 
LVL 12

Expert Comment

by:coredatarecovery
ID: 24131251
If the circuit board does not match exactly (Model and firmware) the drive may not identify.
0
 

Author Comment

by:vsllc
ID: 24131377
Visually, they are the same and the numbers I can find on them match but I could be missing some other identifiers or stickers.  I tried Western Digitals site but kept getting 0 results on the search.  Here's the HD model #'s:

Bad - WD1200BB-22CAA0
Good - WD400BB-00CAA0
0
 
LVL 12

Accepted Solution

by:
coredatarecovery earned 200 total points
ID: 24131396
you can't use the circuit board from a 40 gig drive to run the 120 gig drive.
and the firmware is different.
(part after the dash.)

http://cgi.ebay.com/PCB-logic-board-for-WD1200BB-22CAA0-WD1200BB-22CAAO_W0QQitemZ350174402096QQcmdZViewItemQQptZPCC_Drives_Storage_Internal?hash=item350174402096&_trksid=p3286.m20.l1116

is a circuit board for you that should work.

Hope this helps,
Chuck House
Core Data Recovery
0
 

Author Comment

by:vsllc
ID: 24131903
Thanks.  I'll keep the link in case I can't find a replacement locally.  I appreciate all the help.
0

Featured Post

Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question