No apache services installed

I have installed apache server on my development machine (XP pro)but for some reason there are no services installed and nothing shows in the apache service monitor screen. How is the service created?
LVL 1
jezskillAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

crossdevCommented:
Here are the isntructions you are looking for:

http://httpd.apache.org/docs/1.3/win_service.html

You can install Apache as a Windows NT service as follows:

    apache -i -n "service name"
To install a service to use a particular configuration, specify the configuration file when the service is installed:

    apache -i -n "service name" -f "\my server\conf\my.conf"


The page listed above will provide more details.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jezskillAuthor Commented:
there was no "Install as Service for All Users" option in the installattion package, the instructions mention that it should be run from a console window first, but when i do this nothing happens, apache does not start.
0
jezskillAuthor Commented:
apologies, there was an option to install as a service , but I am running IIS so want to do this manually under port 8080. I have downloaded 2.2 apache now and I get the same thing, it installs but there are no services installed which makes sense, but I dont where I execute the commands from your linked instructions to create the service or get apache running.
0
crossdevCommented:
ok you are running IIS which is using port 80.  Apache by default trys to use port 80 as well.  you will need to go into the configuration and cange the port that apache is listening to.  Here are the directions.

http://httpd.apache.org/docs/2.0/bind.html
0
jezskillAuthor Commented:
I have worked out that starting apache in console does start the Apache process and then I am able to see the apache test page in a browser http://localhost:8080. So this closes out this question I now create my next, thanks for your comments.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.