Need a right version of ncurses libraries and ncurses-devel

1) Currently I have:
[root@localhost linux-2.6.29]# uname -r
2.6.27.21-170.2.56.fc10.i686
2) I want to install
linux-2.6.29.tar.bz2
3) when I tried
make menuconfig
I got the errors:
 *** Unable to find the ncurses libraries or the
 *** required header files.
 *** 'make menuconfig' requires the ncurses libraries.
 ***
 *** Install ncurses (ncurses-devel) and try again.
 ***
make[1]: *** [scripts/kconfig/dochecklxdialog] Error 1
make: *** [menuconfig] Error 2
4) I checked
[root@localhost linux-2.6.29]# rpm -qa | grep ncurses
ncurses-base-5.6-20.20080927.fc10.i386
ncurses-libs-5.6-20.20080927.fc10.i386
ncurses-5.6-20.20080927.fc10.i386

5) My questions are
* which version of ncurses-devel do I need?
* how/where to get it?
jl66Asked:
Who is Participating?
 
ewest02Connect With a Mentor Commented:
Doh! .. but you already know that!  Since you already have ncurses 5.6-20, get that flavor of the development package.

  --Eric
0
 
ewest02Commented:
Based on the error mesg, you need to install ncurses-devel

  --Eric
0
 
jl66Author Commented:
Where (a link) to get the dev pack for ncurses 5.6-20?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
jl66Author Commented:
Does linux community have a repository for devel package? Sorry I am a newbie.
0
 
ewest02Commented:
You did not mention if you were using redhat, fedora, suse, opensuse, debian, etc...

Each distro has a repository for packages. Check your distribution's web site. (eg for OpenSuse, http://en.opensuse.org/Package_Repositories)  rpmfind is another place to look for packages, http://rpmfind.net/ ..and of course just doing google searches can turn up the appropriate repository.

--Eric
0
 
Duncan RoeSoftware DeveloperCommented:
Do you have X installed? You may find "make xconfig" works.
0
 
jl66Author Commented:
1) fedora 10.
2) got the rpm as ncurses-devel-5.6-20.20080927.fc10.i386.rpm.
3) not install X
How should I do?
I tried
rpm -U ncurses-devel-5.6-20.20080927.fc10.i386.rpm
rpm -U --update ncurses-devel-5.6-20.20080927.fc10.i386.rpm
rpm --update ncurses-devel-5.6-20.20080927.fc10.i386.rpm
rpm -update ncurses-devel-5.6-20.20080927.fc10.i386.rpm
None of them worked.
0
 
Duncan RoeConnect With a Mentor Software DeveloperCommented:
I am not normally an rpm user, but I think you need to install rather than upgrade the package. rpm -ivh ncurses-devel-5.6-20.20080927.fc10.i386.rpm
If you get an error, post it here.
0
 
ewest02Commented:
Explain " None of them worked" ... Are you installing the rpm as root? Are you missing dependencies?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.