Wired and Wireless NICs Not Operational on Laptop

Averatec 6200 Series Laptop
XP Home SP3
Wired NIC - SiS 900-Based PCI Fast Ethernet Adapter
Wireless NIC - 802.11g MiniPCI Wireless Adapter

This laptop is a client's and the problem started with him not being able to boot the machine. One day, it was fine and the next day, nada. The machine wouldn't boot to any Safe Mode or LKGC or normally. Troubleshooting showed that it was hanging up on gagp30kx.sys. It was a hassle but I got that situation resolved. The machine now boots normally and consistently now.

As per the suggestions for fixing the gagp30kx.sys error, I ran CHKDSK from Recovery Console to check disk integrity. Some errors were found and fixed but nothing major. So the hard drive seems to be OK.

Neither network connection will work. Both are enabled. No link light on the wired connection and the wireless connection will not survey wireless networks. I know my wireless network is operational as I am connected to it right now on this computer.

Things I have tried:
1. Uninstalled (via Device Manager) the NICs and reinstalled them.
2. Updated drivers for both (downloaded to a USB flash drive on another machine)
3. For the wired connection, tried 10 different ports on my switch. Switch is a fairly new Dell PowerConnect 2324 24-port switch and I have 8 machines connected to it. None of the other machines are having connectivity issues. Even plugged the misbehaving laptop into a port being used by a known working machine.
4. Used the IP RESET command - netsh int ip reset c:/resetlog.txt.
5. Rebuilt the protocol stack using the "Hard Core" method on this page: http://smokeys.wordpress.com/2008/07/20/how-to-recover-a-really-dead-windows-xp-sp2sp3-tcpip-stack/

Things I have NOT tried:
1. Repair Install. Haven't had much luck with repair installs and therefore don't trust them. Once I got the machine is up and running, I did backup everything on the laptop to an external hard drive. So...I could try a Repair Install but I'd rather see if there's another way to fix the NICs before doing that.
2. Reformat and Reinstall. Don't want to do this unless there is no other option.
3. Did not scan for malware. He has Symantec 360 on the machine, but I can't get updates with no Internet connectivity.
4. Did not (as I don't have one) attach a USB external NIC to see if it would work.
5. Did not (as this is a laptop), physically remove the NICs and install known good ones, which would have been my first step if this were a desktop.

The research I did on gagp30kx.sys referred to Via motherboards several times and that this file, gagp30kx.sys is notorious for failing with Via mobos/chipsets. I can't find the specs on this Averatec to determine if it has a Via motherboard or chipset. The Averatec website didn't have much in the way of support other than a User Guide. Even so, since I have recovered from that error (by replacing gagp30kx.sys), would, or could, a video driver cause problems with NICs? I can't see that it would. The user said that everything was working fine before the crash - no errant behavior, no error messages, no indication of any kind that there was a problem. This, though, is common with gagp3kx.sys failure.

Any ideas?
gbrookeAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
PCBONEZConnect With a Mentor Commented:
gagp30kx.sys is an agp driver and works similarly to the agp440.sys.

gagp30kx.sys is a red herring, meaning that's not the problem.
gagp30kx.sys is shown because it's the last driver that DID load.
The problem is the one the -should- load after that, but didn't.
Network drivers generally load after the agp drivers.
-
You problem is network drivers that are corrupt or missing.
A driver reinstall may see the driver is there, not know it's corrupt, and then not over write it.
You need to go in [probably in safe-mode] and delete the old driver files THEN do a reinstall.

.
0
 
MSRamrodConnect With a Mentor Commented:
This file has been suspect of ALOT of viruses lately. Personally, it sounds like you have one option. Get a version of linux that is bootable from a flash drive. Boot into linux. This will tell you 2 major things. one being if its in fact a hardware problem, and second, exactly what files are installed in the root directories (C:/ , C:/WINDOWS)
Change the view to list and order by date-last modified. Check what changed about when this ordeal started. I'm willing to bet you infected, rather your client is infected. What are the chances of both the wired and wireless NIC's going out simotainiously, while nothing else burning out? If its not an infection tell your buddy to buy a lotto ticket because those are some insane odds.
0
 
gbrookeAuthor Commented:
I updated both NICs to the most current version of their drivers as each was several versions out of date. Would that not have written over the old (maybe corrupt) driver files? What method is suggested for positively deleting the driver files? I, too, am puzzled most by the fact that both NICs died at the same time but everything else seems OK.

Several of the posts (from here and other sites) did say that gagp30kx.sys is not the problem and is shown because it's the last driver that DID load. I am not disputing that assertion but replacing the file (per some of the posts' suggestions) enabled me to boot the machine.

I will figure out a way to get current virus definitions on there and scan it to see if something comes up.

0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
gbrookeAuthor Commented:
Booted to Damn Small Linux 1.4, which is what I had laying around.

In Wlanconfig, I get this: No wireless network card found. Probably a driver issue.

In Netcardconfig, I plugged in all of the IP settings but nada. No link light, no connectivity.
0
 
PCBONEZCommented:
If the wireless card is installed in a slot of some kind (like a mini-PCI slot of similar) then remove and reinstall the card. It may just have a bad connection in the socket.
0
 
nobusConnect With a Mentor Commented:
any errors in devive manager ?
note that it can be the networking hardware that became bad...
0
 
gbrookeAuthor Commented:
No errors in Device Manager.

Both NICs are on-board, so I can't remove/replace either one..
0
 
ridConnect With a Mentor Commented:
I wouldn't choose Damnsmallinux for this troubleshooting; try Knoppix or Ubuntu. The Live CD option is fairly good at finding and using (working) hardware.

The problem is possibly with the HD after all; some sort of system file corruption that isn't readily detected. You should test the HD and the RAM with a good tester software. Chkdsk isn't really a tester in this sense.
/RID
0
 
nobusCommented:
for testing, download ubcd : http://www.ultimatebootcd.com/
0
 
gbrookeAuthor Commented:
I have downloaded the Ultimate Boot CD. Good stuff there. Still, what do you think about SpinRite? I have a copy and  that was going to be my next move. I have had success with it in the past.
0
 
nobusCommented:
Spinrite is one of the best disk tools, for data corruption etc, and maintenance; but NOT for testing the disk.
the worst the disk condition is, the longer it needs to run - thus it can ruin it further.
0
 
gbrookeAuthor Commented:
OK. Thanks. I will use the Ultimate Boot CD.
0
 
gbrookeAuthor Commented:
The drive tests on the Ultimate Boot CD showed that the drive is healthy.

Booted to Knoppix and Ubuntu. Neither worked.

In desperation, tried a repair install. No good.
0
 
PCBONEZCommented:
If the wireless is integrated then why do they sell replacement wireless cards for it?

http://www.excelcomputerinc.com/html/details.asp?ref=2015&category=boards
0
 
nobusCommented:
>>  Booted to Knoppix and Ubuntu. Neither worked. <<  this points to ba d hard ware - did you see any errors?
try disabling devices in the bios, or removing them - extra cards, drives...

   
0
 
gbrookeAuthor Commented:
We (on PCBONEZ's recommendation) acquired a new wireless card for it and installed it. Nothing.

We have given up and the user is going to buy a new laptop.

The suggestions were helpful in the troubleshooting process and I learned something (Ultimate Boot CD...good stuff) but nothing resolved the situation. I will, though, award points for the efforts. Thanks for the help, guys.
0
 
PCBONEZCommented:
Check in device manager for ? marks, especially in system devices.
If you have one the drivers associated with the add-in slot may be on the fritz. [Corrupt]
Reinstalling the driver should fix that.
-
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.