?
Solved

Linux WiFi ath5k driver AP-mode

Posted on 2009-04-12
3
Medium Priority
?
5,375 Views
Last Modified: 2013-11-15
Hi! I did a lot of research trying to find a suitable WLAN card that would work with Linux, and I eventually found a D-Link I thought would work.

The card works fine in standard mode using the ath5k driver, but was trying to get it to function as an access point using hostapd. I just read that the ath5k not yet supports ap-mode. I've also tried removing ath5k and using the older MadWifi driver, but that didn't work either (I installed the Ubuntu linux-restricted-modules package and rebooted, but the WLAN card isn't being detected).

Is there any way to do this? It's an AR5001X+ chip.
0
Comment
Question by:Julian Matz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
3 Comments
 
LVL 21

Author Comment

by:Julian Matz
ID: 24128057
Ok, I managed to install the MadWifi driver on m second try. I should have installed [linux-restricted-modules-2.6.27-11-server] instead of [linux-restricted-modules]. Then I did:

root@delta:~# modprobe ath_pci
root@delta:~# modprobe ath_hal

Now my wireless card is working using the madwifi driver, however I still cannot change the card to master mode:-

root@delta:~# iwconfig ath0 mode master
Error for wireless request "Set Mode" (8B06) :
    SET failed on device ath0 ; Invalid argument.

Any suggestions would be appreciated.
0
 
LVL 21

Author Comment

by:Julian Matz
ID: 24128101
Ok, I think I'm getting somewhere ... Apparently I had to do following:

root@delta:~# ifconfig ath0 down
root@delta:~# wlanconfig ath0 destroy
root@delta:~# wlanconfig ath0 create wlandev wifi0 wlanmode ap

After testing hostapd for the first time, I could see the SSID of the Ubuntu AP on my Windows laptop.
0
 
LVL 21

Accepted Solution

by:
Julian Matz earned 0 total points
ID: 24180206
I'm not sure if I even need hostapd, I'll need to try without it, but I got my wireless card working in AP-mode using following commands:

root@delta:~# apt-get install linux-restricted-modules-2.6.27-11-server
root@delta:~# modprobe ath_pci
root@delta:~# modprobe ath_hal

root@delta:~# echo 'blacklist ath5k' >> /etc/modprobe.d/blacklist

root@delta:~# shutdown -r now

root@delta:~# ifconfig ath0 down
root@delta:~# wlanconfig ath0 destroy
root@delta:~# wlanconfig ath0 create wlandev wifi0 wlanmode ap
0

Featured Post

DFW AZURE MEETUP TONIGHT FRI 6PM

We will be discussing what Azure Stack is, how does it fit into the suit of offerings that Azure has currently, and where can it fit into your organizations technology stack. We will also be discussing limitations of the platform while covering various applicable scenarios.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
In this article we have discussed about the OS X EI Capitan and how to fix Wi-Fi issue in OS X El Capitan. We have explained how to delete system level preferences and create a new Wi-Fi location to resolve Wi-Fi issue.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question