Solved

Can't connect to clients via Windows Remote Desktop Connection - works under Ubuntu

Posted on 2009-04-13
11
1,007 Views
Last Modified: 2013-11-21
Here's just another example of why Ubuntu wipes the floor with Windows:

I have a domain consisting of a domain controller running Windows SBS 2003, Terminal Services, etc., to which are connected approximately 30 Windows Vista Business workstations.

When I'm using Ubuntu, and I want to remote into any of those workstations, I just fire up Terminal Server Client, put in the name of the computer I want to remote into, my login credentials, and the domain IP address (x.x.x.x).  It takes me directly to the desktop of the client machine that I desire.

On Windows, however, I'm trying to do the same thing using the Remote Desktop Connection application, but it only gives me two options: "Computer" and "User name".  Nowhere does it allow me to specify the domain, so when I put my IP address into the "Computer" box, all it allows me to do is log into my small business server, not the actual clients.

This is getting pretty frustrating - I'm sure the Windows program would work, if it would allow me to put in the complete information like I can under Ubuntu, but it just doesn't have the necessary fields.  I've tried putting in things like "Computer: x.x.x.x\computer_name", and various other combinations using slashes, colons, etc., with no success.  This feels like a really dumb question, but how do I RDP connect to my clients?  I've been googling for hours with no success.  :-(

PS - I know I can access all the computers in my domain through the web by going to https://x.x.x.x/remote, but I want to be able to use the Remote Desktop Connection app to save credentials, settings, etc.

I will attach a screenshot, in case the above is confusing.
Terminal-services-screenshot.jpg
0
Comment
Question by:comptechmike
  • 5
  • 4
  • 2
11 Comments
 
LVL 4

Expert Comment

by:Matkun
ID: 24131271
In Windows, under Computer:
type in the machine name\ip address. It's the same field as in ubuntu.

The domain, put under username. ie: domainname\username.

It's really that simple. RDP only uses the domain for user authentication to log into the machine
0
 
LVL 9

Accepted Solution

by:
asawatzki earned 125 total points
ID: 24131278
In the username field try specifying the domain before the username.  Like blahblah.com\username or blahblah\username .  You shouldn't have to enter the domain name for the computer itself unless you want/need to use the FQDN for the computer to get to it.  
0
 
LVL 4

Expert Comment

by:Matkun
ID: 24131298
to clarify, under computer: type in the ip address OR the machine name, not machine\ip
You may also need to fully qualify the machine name. ie: if it is called 'computer2' and the domain name is 'mydomain.com' you should put 'computer2.mydomain.com'

My hunch is your not fully qualifying the domain names
0
NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

 

Author Comment

by:comptechmike
ID: 24131698
@Matkun-

I've tried every combination of your suggestions, and just can't get it to work.

Typing just my single static IP address into the "Computer" box remotes me into the server, which is great, but not where I want to be (btw, if it matters - my router is configured to forward port 3389 to the server).

Typing computer_name.x.x.x.x (my ip address) gives me a "this computer can't connect to the remote computer, can't find remote computer, etc." error.

Note that when I use this under Ubuntu, I enter the following information into the fields:
Computer: the computer name
User name: my user name
Password: my password
Domain: my domain IP address (x.x.x.x), not my domain name

Using the above settings, I can remote into any machine on my small business network, as long as they are configured to accept incoming connections.  Windows just doesn't give me the same options.  :-(
0
 
LVL 4

Assisted Solution

by:Matkun
Matkun earned 125 total points
ID: 24131893
under the computer field, either use the fully qualified computer_name or the ip address, not both.

I'm not sure what you mean by domain IP address. Do you mean the domain controller? Individual domain controllers are identified by ip addresses, but the domain is identified by the domain name, which is typically something like domainname.com

If you want to test connectivity for RDP at all, open a command prompt and use the command: telnet machinename 3389

If the telnet command times out or the connection is denied, then you have a port/connectivity issue.
0
 

Author Comment

by:comptechmike
ID: 24132033
@asawatzki & Matkun:

I believe I have got this solved.  What a tricky, pain in the ass it was, though, and I used bits from both your responses.

Under new remote desktop connection, this is what I'm doing:

Computer: Computer_name
User name: x.x.x.x (domain ip address, the static address from my ISP to my router) \ user_name

Then I click connect, and it gives me a window asking if I trust this remote connection.  I say "connect", then I get a second window asking for my credentials.  From here I pick the third option, "Use another account", and put in the following:

User name: domain_name \ user_name
Password: password

From here, it does appear to work.  I've successfully logged into five of my different workstations this way.  It's critical to use the third option at that last window, otherwise it doesn't know what domain to log into.

I'm gonna try this from home tonight and confirm that it's working (since I made so many changes to my laptop here in the office, I don't know if I trust it anymore, lol), then will split up the points.  Thanks, guys!  :-)
0
 
LVL 4

Expert Comment

by:Matkun
ID: 24132098
Good to hear you got it working. Btw: you can enter anything you want in user name. It's just what is copied/pasted in to the login window in your last step
0
 
LVL 9

Expert Comment

by:asawatzki
ID: 24132188
Great to hear that its working for you now.
0
 

Author Comment

by:comptechmike
ID: 24187121
As a side note, this didn't wind up working, after all.  It worked great from the office, inside the domain, but was a no-go outside of the office.  I'm going to close this question out because I don't have time to deal with it at this time, but I'd still like to hear a solution to using Remote Desktop Connection from outside the domain, so I can create auto-logging-in scripts, etc., and don't have to use the Remote Web Workplace through a web browser.  :-(

Maybe one of these days I'll get back to this project, but in the meantime RWW for my users, it is...
0
 

Author Closing Comment

by:comptechmike
ID: 31569589
See note from my last comment.  Both of these users provided good help, I just don't understand why Microsoft has to have such a crappy Remote Desktop Connection approach.  It looks like it would only work if each individual machine within my domain had it's own IP address on the Internet, instead of going through a router/NAT/small business server setup.  *sigh*
0
 

Author Comment

by:comptechmike
ID: 24187158
See note from my last comment.  Both of these users provided good help, I just don't understand why Microsoft has to have such a crappy Remote Desktop Connection approach.  It looks like it would only work if each individual machine within my domain had it's own IP address on the Internet, instead of going through a router/NAT/small business server setup.  *sigh*
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

832 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question