Solved

I keep getting a certificate error when accessing server 2008 TS locally

Posted on 2009-04-13
10
526 Views
Last Modified: 2012-05-06
I just installed server 2008 to test in our environment.  When I go to https:\\server2008\ts, I get a certificate error there is a problem with this sites security certificate.  I just click continue.  Everything works until I try to run a remote program then I get the certificate mismatch name error.  I added the cert opn the server 2008, but it seems like the name is wrong.  Any ideas?
certerror.bmp
0
Comment
Question by:TriCountyIT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
10 Comments
 
LVL 7

Accepted Solution

by:
60MXG earned 250 total points
ID: 24131989
You might want to type in the whole link like https://Server08.tricountyhospital.org

0
 

Author Comment

by:TriCountyIT
ID: 24132015
Doing it that way I was able to browse to the site with out getting the certificate error, but it still errors out when I try to connect to a remote app.
0
 
LVL 7

Expert Comment

by:60MXG
ID: 24132025
What is the error on remote app?  Maybe you need to set your default url or default path in remote app??  Just a thought!
0
How Do You Stack Up Against Your Peers?

With today’s modern enterprise so dependent on digital infrastructures, the impact of major incidents has increased dramatically. Grab the report now to gain insight into how your organization ranks against your peers and learn best-in-class strategies to resolve incidents.

 

Author Comment

by:TriCountyIT
ID: 24132421
the error is the screen shot.  It says there is a name mismatch on the cert.  Since that is happening it wont connect.
0
 
LVL 7

Expert Comment

by:60MXG
ID: 24132496
Try to go to your browser and delete all those certificates cached and re-enter the site again!
0
 

Author Comment

by:TriCountyIT
ID: 24132611
The problem is my self signed certificate says server08.tricountyhospital.org.  I am able to access remote programs when I go into the remote connection settings and change it to server08.tricountyhospital.org.  is there any way to change that to just server08 so i dont have to go the the FQDN all the time?
0
 
LVL 58

Assisted Solution

by:tigermatt
tigermatt earned 250 total points
ID: 24132702

The problem you are seeing is two-fold. The first issue is the FQDN on the certificate; if this does not match, the system you are connecting from will deem the connection unsafe and throw an error. The second issue is your certificate is a self-signed certificate, meaning most machines will automatically distrust it, once again deeming the connection insecure.

Your best option would be to purchase and install an SSL certificate from a trusted certification authority. This will eliminate both issues. You could use a SAN (Subject Alternate Name) certificate if you wished to address your server by more than one name, such as its FQDN and its NetBIOS (server08) name. Use https://domainsforexchange.net/ for cheap SAN SSL certificates; although it states it's for Exchange Servers, their certificates work equally as well for any other application requiring a certificate.

-Matt
0
 

Author Comment

by:TriCountyIT
ID: 24132970
ya I figured that.  I was able to get it to work for testing purposes for now.  if we stick with the software we will purchase teh cert.  Thanks
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 24133001

You would need to re-generate the SSL certificate internally (meaning you will need a Certification Authority installed) in order to eliminate the error at this stage. If it is purely a test environment, I'd suggest you simply ignore the error for now.

-Matt
0
 

Author Comment

by:TriCountyIT
ID: 24133032
thanks for your help
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question